Page 1 of 2

filesystem ... does not contain valid init=/sbin/init

Posted: Sat Apr 05, 2014 12:45
by udiljak
Hi everybody.

Yesterday I upgraded my system and updated the kernel from 3.9 to 3.13. When I rebooted the laptop I only received the message:

filesystem ... mounted on /newroot does not contain valid init=/sbin/init

(the ... stands for the lvm root partition)

I can't start older kernels neither! (Similar error message)

Please help!
Ben

Re: filesystem ... does not contain valid init=/sbin/init

Posted: Sun Apr 06, 2014 10:05
by svantoviit

Re: filesystem ... does not contain valid init=/sbin/init

Posted: Mon Apr 07, 2014 3:12
by tinogil
Hi, I have the same problem and I changed the line in grub of linuxrc to systemd path and don't work. I get this allways:

Code: Select all

[      1.273296] drm/i810 does not support SMP
mdadm: No arrays found in config file or automatically
  3 logical volume(s) in volume group "vg_asterix" now active
!! The filesystem /dev/mapper/vg_asterix-lv_root, mounted at /newsroot does not contain a valid init=/sbin/init
!! Please file a bug report with this message
My laptop is a 32bits system and I press ctrl+e in bootand I change init=/linuxrc for init=/usr/lib/systemd/systemd after I press ctrl+x and boot and I get the same message. How can I recovery my system?

Re: filesystem ... does not contain valid init=/sbin/init

Posted: Mon Apr 07, 2014 7:58
by svantoviit
Try "real_init=/usr/lib/systemd/systemd"

Re: filesystem ... does not contain valid init=/sbin/init

Posted: Mon Apr 07, 2014 9:20
by udiljak
Hi.

Thanks for your hint.

I can boot my system with the 3.13 kernel, but not for the old 3.9 kernel. Same message "no valid init=/sbin/init" although I changed "init=/linuxrc" to "init=/usr/lib64/systemd/systemd".

With the 3.13 kernel I have not network. When I try to open networ preferences I get a message like "not compatible with this version".
The symlink "/sbin/init" is pointing to a non-existing file.
Reinstalling every package with "systemd" doesn't help. Another related packege seemed to be "sysvinit". When I reinstall that one I get an error like "sysvinit is not a valid target".

Sorry for not giving exact error messages. I have only one computer and I have to boot a live CD to write this post.

Greetings,
Ben

Re: filesystem ... does not contain valid init=/sbin/init

Posted: Mon Apr 07, 2014 16:21
by Stupot
Are you you guys using the limbo repo by any chance?

If you are, make sure you're including that when making these posts.

Re: filesystem ... does not contain valid init=/sbin/init

Posted: Mon Apr 07, 2014 19:40
by tinogil
Ok thanks, it worked, but when I try to change this in /etc/default/grub GRUB_CMDLINE_LINUX_DEFAULT and I do grub2-mkconfig the grub conf changes but when I reboot I get the same message and it have linuxrc in the conf. How can I change this? I'm not using limbo repo.

Re: filesystem ... does not contain valid init=/sbin/init

Posted: Tue Apr 08, 2014 9:56
by udiljak
No, I'm not using limbo.

Re: filesystem ... does not contain valid init=/sbin/init

Posted: Tue Apr 08, 2014 14:47
by linuxfluesterer
I assume, that in the meantime too many things have been changed (sysvinit to systemd?).
You may consider to make a complete new install from a daily build. It should be possible to start the installation icon successfully now. (Some days before, there was a bug, which prevented this).

-Linuxfluesterer (I love KDE ...)

Re: filesystem ... does not contain valid init=/sbin/init

Posted: Tue Apr 08, 2014 15:42
by udiljak
Well, then I consider a complete new install. :-(