Rigo not asking for root password

Anything that pertains to Entropy, Equo or Sulfur

Moderator: Moderators

Ponder
Simple Hen
Posts: 61
Joined: Wed Apr 28, 2010 21:30

Re: Rigo not asking for root password

Post by Ponder » Wed Jul 24, 2013 19:54

dconf-editor starts fine. Rigo still doesn't ask for a password.

life-on-mars
Simple Hen
Posts: 83
Joined: Fri Jul 12, 2013 14:05

Re: Rigo not asking for root password

Post by life-on-mars » Thu Jul 25, 2013 3:36

Is it working when you use polkit directly?

Code: Select all

pkexec <random command>
If this isn't working either, then it should be a problem with polkit and not Rigo itself.
sɹɐɯ uo əɟıɿ sı əɹəɥʇ -- ⠐⠮ ⠊⠎ ⠇⠊⠋⠑ ⠕⠝ ⠍⠜⠎⠖

Ponder
Simple Hen
Posts: 61
Joined: Wed Apr 28, 2010 21:30

Re: Rigo not asking for root password

Post by Ponder » Thu Jul 25, 2013 20:37

That brings up the password box. I see that when I plug in a flash drive. Rigo doesn't ask for it.

life-on-mars
Simple Hen
Posts: 83
Joined: Fri Jul 12, 2013 14:05

Re: Rigo not asking for root password

Post by life-on-mars » Fri Jul 26, 2013 6:40

Does /var/log/entropy/rigo-daemon.log say anything? Not sure if rigo-daemon is related to that.

I think without exact knowledge how rigo calls the polkit authorization, it won't be possible to track the problem.
Perhaps you can try uninstalling and reinstalling rigo?
If it's still not working, add a new user and give add him to all groups required to access entropy and superuser rights. Run rigo as that user, and see what happens. If it everything is normal, then the settings of your normal user got messed up somehow. Delete the temporary user account afterwards, if it's not needed anymore (for security reasons).

And if that doesn't work, I would file a bug report.
sɹɐɯ uo əɟıɿ sı əɹəɥʇ -- ⠐⠮ ⠊⠎ ⠇⠊⠋⠑ ⠕⠝ ⠍⠜⠎⠖

Ponder
Simple Hen
Posts: 61
Joined: Wed Apr 28, 2010 21:30

Re: Rigo not asking for root password

Post by Ponder » Fri Jul 26, 2013 21:26

I shall try next time updates are available.

Post Reply