Rigo says: dependencies not found[Solved]

Anything that pertains to Entropy, Equo or Sulfur

Moderator: Moderators

Rigo says: dependencies not found[Solved]

Postby ags40 » Tue Jul 02, 2013 21:46

I have 77 updates available. Rigo says: dependencies not found. System upgrade error. How do I go about it, please?
Thanks
Last edited by ags40 on Wed Jul 03, 2013 22:46, edited 1 time in total.
ags40
Simple Hen
 
Posts: 71
Joined: Fri Dec 09, 2011 22:15

Re: Rigo says: dependencies not found

Postby Stupot » Tue Jul 02, 2013 22:16

Please post the whole error if you would.

Also, try doing to the following:

Code: Select all
#equo update
#equo install equo --relaxed
equo update
equo upgrade


That should update your equo to the very latest version before attempting to do the system upgrade.
Stupot
Sagely Hen
 
Posts: 1556
Joined: Wed Feb 14, 2007 3:44
Location: St. Louis, MO, USA

Re: Rigo says: dependencies not found

Postby ags40 » Tue Jul 02, 2013 23:33

I had run your suggestions before, but re-tried them again. No success. Would you kindle tell me where to find the errors log, please?
ags40
Simple Hen
 
Posts: 71
Joined: Fri Dec 09, 2011 22:15

Re: Rigo says: dependencies not found

Postby Stupot » Wed Jul 03, 2013 1:49

Just give us the full terminal output of this:

Code: Select all
#equo upgrade --verbose
Stupot
Sagely Hen
 
Posts: 1556
Joined: Wed Feb 14, 2007 3:44
Location: St. Louis, MO, USA

Re: Rigo says: dependencies not found

Postby lxnay » Wed Jul 03, 2013 7:00

Mixing sabayon-weekly with sabayon-limbo :roll:
Image
Join us on IRC (chat.freenode.net #sabayon or WebChat)
Submit bugs to our Bug Tracker
Follow me on Twitter
Add me on Facebook
Add me on Google+
lxnay
Land Owner
 
Posts: 3596
Joined: Thu Oct 13, 2005 23:16
Location: Italy

Re: Rigo says: dependencies not found

Postby Dombra » Wed Jul 03, 2013 19:07

Hi,
I had the same problem with Rigo.
Rigo said linux-sabayon is masked; yes i masked the kernel. Because I use nvidia-173 drivers (for Nvidia FX5500 graphic card) and Rigo wanted upgrade it(nvidia173) to the newest version(nvidia319).

So that topic viewtopic.php?f=76&t=30171&p=163823&hilit=nvidia+173#p163823
helped me about the masking. After the Rigo said "deps not found" " linux-sabayon is masked" When I unmasked the "linux-sabayon" Rigo started to upgrade immediately.
Dombra
Baby Hen
 
Posts: 1
Joined: Sat Jun 22, 2013 19:38


Re: Rigo says: dependencies not found

Postby ags40 » Wed Jul 03, 2013 20:52

Here it goes:

Code: Select all
  @@ Calculating System Updates:
>>  @@ 70 => Packages matching update
>>  @@ 1 => Packages matching not available
>>  @@ 1088 => Packages matching already up to date
>>  @@ These are the selected packages:
>>    # (1/70) [sabayon-limbo] app-accessibility/at-spi2-atk-2.8.1
>>     Versions: 2.6.2 / NoTag / 1 ===> 2.8.1 / NoTag / 0
>>      Action:          Upgrade
>>    # (2/70) [sabayon-limbo] app-accessibility/at-spi2-core-2.8.0
>>     Versions: 2.6.3 / NoTag / 2 ===> 2.8.0 / NoTag / 0
>>      Action:          Upgrade
>>    # (3/70) [sabayon-limbo] app-crypt/gcr-3.8.2
>>     Versions: 3.6.2 / NoTag / 1 ===> 3.8.2 / NoTag / 0
>>      Action:          Upgrade
>>    # (4/70) [sabayon-limbo] app-crypt/p11-kit-0.18.4
>>     Versions: 0.18.2 / NoTag / 0 ===> 0.18.4 / NoTag / 0
>>      Action:          Upgrade
>>    # (5/70) [sabayon-limbo] dev-db/sqlite-3.7.17
>>     Versions: 3.7.15.2 / NoTag / 3 ===> 3.7.17 / NoTag / 0
>>      Action:          Upgrade
>>    # (6/70) [sabayon-limbo] dev-libs/apr-1.4.8
>>     Versions: 1.4.5 / NoTag / 0 ===> 1.4.8 / NoTag / 0
>>      Action:          Upgrade
>>    # (7/70) [sabayon-limbo] dev-libs/apr-util-1.5.2
>>     Versions: 1.5.1 / NoTag / 0 ===> 1.5.2 / NoTag / 0
>>      Action:          Upgrade
>>    # (8/70) [sabayon-limbo] dev-libs/atk-2.8.0
>>     Versions: 2.6.0 / NoTag / 1 ===> 2.8.0 / NoTag / 0
>>      Action:          Upgrade
>>    # (9/70) [sabayon-limbo] dev-libs/check-0.9.10
>>     Versions: 0.9.8-r1 / NoTag / 0 ===> 0.9.10 / NoTag / 0
>>      Action:          Upgrade
>>    # (10/70) [sabayon-limbo] dev-libs/elfutils-0.155
>>     Versions: 0.153 / NoTag / 0 ===> 0.155 / NoTag / 1
>>      Action:          Upgrade
>>    # (11/70) [sabayon-limbo] dev-libs/gmp-5.1.2
>>     Versions: 5.0.2_p1 / NoTag / 1 ===> 5.1.2 / NoTag / 0
>>      Action:          Upgrade
>>    # (12/70) [sabayon-limbo] dev-libs/json-c-0.11
>>     Versions: 0.10-r1 / NoTag / 1 ===> 0.11 / NoTag / 0
>>      Action:          Upgrade
>>    # (13/70) [sabayon-limbo] dev-libs/libassuan-2.1.0
>>     Versions: 2.0.3 / NoTag / 0 ===> 2.1.0 / NoTag / 0
>>      Action:          Upgrade
>>    # (14/70) [sabayon-limbo] dev-libs/libattica-0.4.2
>>     Versions: 0.4.1 / NoTag / 3 ===> 0.4.2 / NoTag / 0
>>      Action:          Upgrade
>>    # (15/70) [sabayon-limbo] dev-libs/libbsd-0.5.2
>>     Versions: 0.4.2 / NoTag / 1 ===> 0.5.2 / NoTag / 0
>>      Action:          Upgrade
>>    # (16/70) [sabayon-limbo] dev-libs/libebml-1.3.0
>>     Versions: 1.2.2 / NoTag / 0 ===> 1.3.0 / NoTag / 0
>>      Action:          Upgrade
>>    # (17/70) [sabayon-limbo] dev-libs/libev-4.15
>>     Versions: 4.11-r1 / NoTag / 2 ===> 4.15 / NoTag / 0
>>      Action:          Upgrade
>>    # (18/70) [sabayon-limbo] dev-libs/libffi-3.0.13
>>     Versions: 3.0.11 / NoTag / 0 ===> 3.0.13 / NoTag / 0
>>      Action:          Upgrade
>>    # (19/70) [sabayon-limbo] dev-libs/libgcrypt-1.5.2-r1
>>     Versions: 1.5.0-r2 / NoTag / 0 ===> 1.5.2-r1 / NoTag / 0
>>      Action:          Upgrade
>>    # (20/70) [sabayon-limbo] dev-libs/libgpg-error-1.11
>>     Versions: 1.10 / NoTag / 1 ===> 1.11 / NoTag / 0
>>      Action:          Upgrade
>>    # (21/70) [sabayon-limbo] dev-libs/libical-0.48-r1
>>     Versions: 0.48 / NoTag / 0 ===> 0.48-r1 / NoTag / 0
>>      Action:          Upgrade
>>    # (22/70) [sabayon-limbo] dev-libs/libnl-1.1.4
>>     Versions: 1.1.3 / NoTag / 0 ===> 1.1.4 / NoTag / 0
>>      Action:          Upgrade
>>    # (23/70) [sabayon-limbo] dev-libs/libnl-3.2.22
>>     Versions: 3.2.21 / NoTag / 0 ===> 3.2.22 / NoTag / 0
>>      Action:          Upgrade
>>    # (24/70) [sabayon-limbo] dev-libs/libpcre-8.33
>>     Versions: 8.32 / NoTag / 0 ===> 8.33 / NoTag / 0
>>      Action:          Upgrade
>>    # (25/70) [sabayon-limbo] dev-libs/libpipeline-1.2.4
>>     Versions: 1.2.3 / NoTag / 0 ===> 1.2.4 / NoTag / 0
>>      Action:          Upgrade
>>    # (26/70) [sabayon-limbo] dev-libs/libsigsegv-2.10
>>     Versions: 2.9 / NoTag / 0 ===> 2.10 / NoTag / 0
>>      Action:          Upgrade
>>    # (27/70) [sabayon-limbo] dev-libs/libzip-0.11.1
>>     Versions: 0.10.1-r1 / NoTag / 0 ===> 0.11.1 / NoTag / 0
>>      Action:          Upgrade
>>    # (28/70) [sabayon-limbo] dev-libs/mpfr-3.1.2
>>     Versions: 3.1.1 / NoTag / 1 ===> 3.1.2 / NoTag / 0
>>      Action:          Upgrade
>>    # (29/70) [sabayon-limbo] dev-libs/nettle-2.7.1
>>     Versions: 2.6 / NoTag / 0 ===> 2.7.1 / NoTag / 0
>>      Action:          Upgrade
>>    # (30/70) [sabayon-limbo] dev-libs/nspr-4.10
>>     Versions: 4.9.6 / NoTag / 0 ===> 4.10 / NoTag / 0
>>      Action:          Upgrade
>>    # (31/70) [sabayon-limbo] dev-libs/nss-3.15
>>     Versions: 3.14.3 / NoTag / 1 ===> 3.15 / NoTag / 0
>>      Action:          Upgrade
>>    # (32/70) [sabayon-limbo] dev-libs/oniguruma-5.9.4
>>     Versions: 5.9.2-r1 / NoTag / 1 ===> 5.9.4 / NoTag / 0
>>      Action:          Upgrade
>>    # (33/70) [sabayon-limbo] dev-libs/protobuf-2.4.1
>>     Versions: 2.4.1 / NoTag / 0 ===> 2.4.1 / NoTag / 1
>>      Action:          Upgrade
>>    # (34/70) [sabayon-limbo] dev-libs/rasqal-0.9.30
>>     Versions: 0.9.29 / NoTag / 1 ===> 0.9.30 / NoTag / 0
>>      Action:          Upgrade
>>    # (35/70) [sabayon-limbo] dev-libs/shared-desktop-ontologies-0.11.0
>>     Versions: 0.10.0 / NoTag / 0 ===> 0.11.0 / NoTag / 0
>>      Action:          Upgrade
>>    # (36/70) [sabayon-limbo] dev-libs/soprano-2.9.2
>>     Versions: 2.9.0 / NoTag / 3 ===> 2.9.2 / NoTag / 0
>>      Action:          Upgrade
>>    # (37/70) [sabayon-limbo] dev-python/PyQt4-4.10.2
>>     Versions: 4.10.1 / NoTag / 0 ===> 4.10.2 / NoTag / 0
>>      Action:          Upgrade
>>    # (38/70) [sabayon-limbo] dev-python/pygobject-base-3.8.2
>>     Versions: 3.4.2-r1 / NoTag / 0 ===> 3.8.2 / NoTag / 0
>>      Action:          Upgrade
>>    # (39/70) [sabayon-limbo] dev-python/pygobject-cairo-3.8.2
>>     Versions: 3.4.2-r1 / NoTag / 0 ===> 3.8.2 / NoTag / 0
>>      Action:          Upgrade
>>    # (40/70) [sabayon-limbo] gnome-base/gnome-keyring-3.8.2
>>     Versions: 3.6.3 / NoTag / 0 ===> 3.8.2 / NoTag / 0
>>      Action:          Upgrade
>>    # (41/70) [sabayon-limbo] gnome-base/gsettings-desktop-schemas-3.8.2
>>     Versions: 3.6.1 / NoTag / 1 ===> 3.8.2 / NoTag / 0
>>      Action:          Upgrade
>>    # (42/70) [sabayon-limbo] kde-misc/networkmanagement-0.9.0.9
>>     Versions: 0.9.0.8 / NoTag / 1 ===> 0.9.0.9 / NoTag / 0
>>      Action:          Upgrade
>>    # (43/70) [sabayon-limbo] media-libs/alsa-lib-1.0.27.1
>>     Versions: 1.0.27-r2 / NoTag / 0 ===> 1.0.27.1 / NoTag / 0
>>      Action:          Upgrade
>>    # (44/70) [sabayon-limbo] media-libs/fontconfig-2.10.91
>>     Versions: 2.10.2-r1 / NoTag / 0 ===> 2.10.91 / NoTag / 0
>>      Action:          Upgrade
>>    # (45/70) [sabayon-limbo] media-libs/libmatroska-1.4.0
>>     Versions: 1.3.0 / NoTag / 0 ===> 1.4.0 / NoTag / 0
>>      Action:          Upgrade
>>    # (46/70) [sabayon-limbo] media-libs/opencore-amr-0.1.3-r1
>>     Versions: 0.1.3 / NoTag / 0 ===> 0.1.3-r1 / NoTag / 0
>>      Action:          Upgrade
>>    # (47/70) [sabayon-limbo] media-libs/vo-amrwbenc-0.1.2-r1
>>     Versions: 0.1.2 / NoTag / 0 ===> 0.1.2-r1 / NoTag / 0
>>      Action:          Upgrade
>>    # (48/70) [sabayon-limbo] media-sound/clementine-1.1.1
>>     Versions: 1.1.1 / NoTag / 9 ===> 1.1.1 / NoTag / 10
>>      Action:          Upgrade
>>    # (49/70) [sabayon-limbo] media-sound/gsm-1.0.13-r1
>>     Versions: 1.0.13 / NoTag / 0 ===> 1.0.13-r1 / NoTag / 0
>>      Action:          Upgrade
>>    # (50/70) [sabayon-limbo] media-sound/lame-3.99.5-r1
>>     Versions: 3.99.5 / NoTag / 0 ===> 3.99.5-r1 / NoTag / 0
>>      Action:          Upgrade
>>    # (51/70) [sabayon-limbo] media-sound/pulseaudio-4.0
>>     Versions: 4.0 / NoTag / 0 ===> 4.0 / NoTag / 1
>>      Action:          Upgrade
>>    # (52/70) [sabayon-limbo] media-video/vlc-2.0.7
>>     Versions: 2.0.7 / NoTag / 0 ===> 2.0.7 / NoTag / 2
>>      Action:          Upgrade
>>    # (53/70) [sabayon-limbo] net-fs/samba-3.6.16
>>     Versions: 3.6.13-r1 / NoTag / 0 ===> 3.6.16 / NoTag / 0
>>      Action:          Upgrade
>>    # (54/70) [sabayon-limbo] net-libs/libsoup-2.42.2
>>     Versions: 2.40.3 / NoTag / 0 ===> 2.42.2 / NoTag / 0
>>      Action:          Upgrade
>>    # (55/70) [sabayon-limbo] net-misc/openconnect-5.01
>>     Versions: 4.99 / NoTag / 2 ===> 5.01 / NoTag / 0
>>      Action:          Upgrade
>>    # (56/70) [sabayon-limbo] net-misc/openssh-6.2_p2
>>     Versions: 6.1_p1-r1 / NoTag / 4 ===> 6.2_p2 / NoTag / 0
>>      Action:          Upgrade
>>    # (57/70) [sabayon-limbo] sci-libs/fftw-3.3.3-r2
>>     Versions: 3.3.3 / NoTag / 0 ===> 3.3.3-r2 / NoTag / 0
>>      Action:          Upgrade
>>    # (58/70) [sabayon-limbo] sys-apps/ed-1.9
>>     Versions: 1.8 / NoTag / 0 ===> 1.9 / NoTag / 0
>>      Action:          Upgrade
>>    # (59/70) [sabayon-limbo] sys-apps/kmod-13-r1
>>     Versions: 12-r1 / NoTag / 1 ===> 13-r1 / NoTag / 0
>>      Action:          Upgrade
>>    # (60/70) [sabayon-limbo] sys-apps/usb_modeswitch-1.2.6_p20130610
>>     Versions: 1.2.5_p20121109 / NoTag / 2 ===> 1.2.6_p20130610 / NoTag / 0
>>      Action:          Upgrade
>>    # (61/70) [sabayon-limbo] sys-kernel/linux-firmware-20130530
>>     Versions: 20130421 / NoTag / 0 ===> 20130530 / NoTag / 0
>>      Action:          Upgrade
>>    # (62/70) [sabayon-limbo] sys-process/procps-3.3.8
>>     Versions: 3.3.6 / NoTag / 0 ===> 3.3.8 / NoTag / 0
>>      Action:          Upgrade
>>    # (63/70) [sabayon-limbo] x11-drivers/xf86-video-intel-2.21.10-r1
>>     Versions: 2.21.9 / NoTag / 0 ===> 2.21.10-r1 / NoTag / 0
>>      Action:          Upgrade
>>    # (64/70) [sabayon-limbo] x11-libs/gnome-pty-helper-0.34.6
>>     Versions: 0.34.2 / NoTag / 2 ===> 0.34.6 / NoTag / 0
>>      Action:          Upgrade
>>    # (65/70) [sabayon-limbo] x11-libs/gtk+-3.8.2
>>     Versions: 3.6.3-r2 / NoTag / 1 ===> 3.8.2 / NoTag / 0
>>      Action:          Upgrade
>>    # (66/70) [sabayon-limbo] x11-libs/libXcursor-1.1.14
>>     Versions: 1.1.13-r1 / NoTag / 1 ===> 1.1.14 / NoTag / 0
>>      Action:          Upgrade
>>    # (67/70) [sabayon-limbo] x11-libs/libXi-1.7.1.901
>>     Versions: 1.7.1 / NoTag / 0 ===> 1.7.1.901 / NoTag / 0
>>      Action:          Upgrade
>>    # (68/70) [sabayon-limbo] x11-libs/libXv-1.0.9
>>     Versions: 1.0.8 / NoTag / 0 ===> 1.0.9 / NoTag / 0
>>      Action:          Upgrade
>>    # (69/70) [sabayon-limbo] x11-libs/pango-1.34.1
>>     Versions: 1.32.5 / NoTag / 3 ===> 1.34.1 / NoTag / 0
>>      Action:          Upgrade
>>    # (70/70) [sabayon-limbo] x11-libs/vte-0.34.6
>>     Versions: 0.34.2 / NoTag / 2 ===> 0.34.6 / NoTag / 0
>>      Action:          Upgrade
>>  @@ Packages involved: 70
>>  @@ Calculating dependencies...
>>  @@ Dependencies not found:
>>    # Not found: >=dev-libs/glib-2.36.0:2
>>      # package needed by:
>>         # [from: sabayon-limbo] net-libs/libsoup-2.42.2
>>         # [from: sabayon-limbo] dev-libs/gjs-1.36.1
>>         # [from: sabayon-limbo] net-libs/webkit-gtk-2.0.3
>>         # [from: sabayon-limbo] gnome-base/gnome-core-libs-3.8.0
>>         # [from: sabayon-limbo] x11-wm/mutter-3.8.3
>>    # Not found: >=net-misc/networkmanager-0.9.8.2
>>      # package needed by:
>>         # [from: sabayon-limbo] kde-misc/networkmanagement-0.9.0.9
>>    # Not found: >=dev-libs/glib-2.35.3:2
>>      # package needed by:
>>         # [from: sabayon-limbo] gnome-base/nautilus-3.8.2
>>         # [from: sabayon-limbo] gnome-base/gnome-settings-daemon-3.8.3
>>         # [from: sabayon-limbo] x11-libs/gtk+-3.8.2
ags40
Simple Hen
 
Posts: 71
Joined: Fri Dec 09, 2011 22:15

Re: Rigo says: dependencies not found

Postby Stupot » Wed Jul 03, 2013 21:32

I'm gonna say lxnay is either right, or you have sabayon.org repo disabled.

Are you meaning to run sabayon-limbo? It's the testing repository. If you are, you need to remove sabayon-weekly, but you need to have the sabayon.org repository enabled or you will be missing dependencies.

https://wiki.sabayon.org/index.php?titl ... positories

But keep in mind, using the limbo repository, things will break from time to time. It's not recommended for inexperienced users. It's mainly for testers to use.
Stupot
Sagely Hen
 
Posts: 1556
Joined: Wed Feb 14, 2007 3:44
Location: St. Louis, MO, USA

Re: Rigo says: dependencies not found

Postby ags40 » Wed Jul 03, 2013 21:35

According to Rigo sabayon-limbo is enabled. Iwant to use it.
ags40
Simple Hen
 
Posts: 71
Joined: Fri Dec 09, 2011 22:15

Next

Return to Entropy|Equo|Rigo Package Managers

Who is online

Users browsing this forum: No registered users and 1 guest

cron