Several blender versions installed - how to remove?

Anything that pertains to Entropy, Equo or Sulfur

Moderator: Moderators

Several blender versions installed - how to remove?

Postby msdobrescu » Wed Apr 17, 2013 18:50

Hello,

I have several Blender versions installed, although only the latest version in the repo is listed in the package managers.

I have 2.4x (reduced security), 2.5x (3D modeller), 2.5x (re..(3D modeller (reduced security)), Blender (3D modeller)...
In time, I have experimented with several Blender versions available at that time.
Now, I wish to remove them and keep the latest only.
I can't see them anywhere in the installed packages.

How could I get rid of them?

For example, today, the 2.6.3 version of avidemux replaced 2.6.2 and a message regarding the 2.6.2 situation (not maintained anymore) was displayed at update - as it is not automatically updated (I really don't understand why...).

So, what's wrong with Blender packages remaining out of managers' range?

Thanks.
msdobrescu
Technological Hen
 
Posts: 423
Joined: Sun Aug 21, 2011 8:48

Re: Several blender versions installed - how to remove?

Postby albfneto » Thu Apr 18, 2013 15:22

In Sabayon, for removing unused versions the best manner is without removing deps:

Code: Select all
sudo equo remove package-version --nodeps


In "package-version" use the name of package and version as for example :

Code: Select all
sudo equo remove blender-2.64a --nodeps


will remove the installed package blender, only the version 2.64a.

But in Sabayon, older varsions of packages can not be source of problems, they may remain in the system.
ALBERTO FEDERMAN NETO
albfneto
[email protected]
Favorite Distros: Sabayon, Gentoo, Mageia and OpenSUSE
User avatar
albfneto
Sagely Hen
 
Posts: 1706
Joined: Fri Nov 16, 2007 1:15
Location: Ribeirão Preto City, São Paulo State, Brazil

Re: Several blender versions installed - how to remove?

Postby albfneto » Thu Apr 18, 2013 15:27

alternative, in RIGO, many packages you may mark for removal, example, "mark" for upgrade avidemux 2.6.3 and mark avidemux-2.6.2 for removal.

If in marking for removal many deps are called to be removed together
, use the procedure without deps, above, with commands.
ALBERTO FEDERMAN NETO
albfneto
[email protected]
Favorite Distros: Sabayon, Gentoo, Mageia and OpenSUSE
User avatar
albfneto
Sagely Hen
 
Posts: 1706
Joined: Fri Nov 16, 2007 1:15
Location: Ribeirão Preto City, São Paulo State, Brazil

Re: Several blender versions installed - how to remove?

Postby msdobrescu » Thu Apr 18, 2013 15:33

Thing is, old Blender issues do not appear in package managers as Rigo, Sulfur etc..
msdobrescu
Technological Hen
 
Posts: 423
Joined: Sun Aug 21, 2011 8:48

Re: Several blender versions installed - how to remove?

Postby msdobrescu » Thu Apr 18, 2013 16:48

In my case, I can't...

Code: Select all
equo remove blender-2.5 --nodeps
>> !!!
>> !!! Warning: blender-2.5 is not installed.
>> !!!
>>    ? When you wrote blender-2.5 You Meant(tm) one of these below?
>>     # media-gfx/blender
>> !!!
>> No packages found
msdobrescu
Technological Hen
 
Posts: 423
Joined: Sun Aug 21, 2011 8:48

Re: Several blender versions installed - how to remove?

Postby Stupot » Thu Apr 18, 2013 17:17

How do you know the old versions are installed?

How did you install the old versions. I assume you did so through rigo/entropy, but if not that would explain why entropy can't remove them.
Stupot
Sagely Hen
 
Posts: 1538
Joined: Wed Feb 14, 2007 3:44
Location: St. Louis, MO, USA

Re: Several blender versions installed - how to remove?

Postby msdobrescu » Thu Apr 18, 2013 17:57

I have used Sulfur.

I guess it is a combination of factors.
There are packages that are not updated when a new version is available, just as avidemux now.
I didn't know there are such packages.
At that time, several versions were available.
I have cleaned up the downloaded packages since then.
The version is not available anymore through repos.

Blender works pretty well. The entry remained in the KDE menu (there are 2 of 2.5, installed by that package...).
msdobrescu
Technological Hen
 
Posts: 423
Joined: Sun Aug 21, 2011 8:48

Re: Several blender versions installed - how to remove?

Postby Stupot » Thu Apr 18, 2013 19:27

Ok, but how do you know the old versions are still installed?

Can you run the different versions, or do you just see menu entries for these versions? Maybe it's just extra menu entries that weren't cleaned up?
Stupot
Sagely Hen
 
Posts: 1538
Joined: Wed Feb 14, 2007 3:44
Location: St. Louis, MO, USA

Re: Several blender versions installed - how to remove?

Postby msdobrescu » Thu Apr 18, 2013 19:36

Of course, there are both.
I have opened them, and I have latest blender (2.66) for "blender" and 2.5 for "blender-2.5" in the command line.
Both in /usr/bin.
msdobrescu
Technological Hen
 
Posts: 423
Joined: Sun Aug 21, 2011 8:48

Re: Several blender versions installed - how to remove?

Postby Stupot » Thu Apr 18, 2013 21:25

So, you installed these via entropy (either equo or rigo or sulfur). Upgrades have since been performed by entropy and now entropy can't remove the old versions of blender?

You should file a bug. https://bugs.sabayon.org/enter_bug.cgi?product=Entropy

Just as an fyi, there are such a thing as slotted packages (packages that can be installed at multiple revisions). This is normally done for libraries, so that one package can upgrade and use an upgraded library while other packages on the same system can continue using the older library.

However, entropy should be keeping track of all of these slotted packages and enable you remove them.
Stupot
Sagely Hen
 
Posts: 1538
Joined: Wed Feb 14, 2007 3:44
Location: St. Louis, MO, USA

Next

Return to Entropy|Equo|Rigo Package Managers

Who is online

Users browsing this forum: No registered users and 3 guests