Cant upgrade cos of missing dependency [Solved]

Anything that pertains to Entropy, Equo or Sulfur

Moderator: Moderators

Cant upgrade cos of missing dependency [Solved]

Postby makav3li » Tue Mar 19, 2013 5:55

I cant upgrade my system cos i have missing dependency my system has installed this package dev-lang/perl-5.12.4 but when i try to upgrade it's asking for perl-5.16.* version/s ,i tried to install Perl 5.16.3 from source but it failed , i was checking in my portage and i have an ebuild for perl-5.16.0 ,perl-5.16.1 and perl 5.16.3 but when i do emerge perl it always installs perl-5.12.4 version, can i get some help with this i would appreciate it very much , tnx :!:
Last edited by makav3li on Thu Mar 21, 2013 0:23, edited 1 time in total.
makav3li
Young Hen
 
Posts: 27
Joined: Sat Feb 23, 2013 7:28

Re: Cant upgrade cos of missing dependency(I need perl 5.16.

Postby makav3li » Tue Mar 19, 2013 7:09

i just did this
Code: Select all
equo upgrade --nodeps --ask
and its updating just fine i wonder what effect will that have on my system ??
:idea:
makav3li
Young Hen
 
Posts: 27
Joined: Sat Feb 23, 2013 7:28

Re: Cant upgrade cos of missing dependency(I need perl 5.16.

Postby makav3li » Tue Mar 19, 2013 9:43

I finally managed to install perl 5.16.0 from source but upgrade is still going on with command
Code: Select all
equo upgrade --nodeps --ask
,so I wonder how will that turn out , i ll post when i am done with upgrade my mirror is really slow today ,it's going under 100 kB's .....
makav3li
Young Hen
 
Posts: 27
Joined: Sat Feb 23, 2013 7:28

Re: Cant upgrade cos of missing dependency(I need perl 5.16.

Postby colock » Tue Mar 19, 2013 12:48

Are you aware that you are upgrading packages but not their dependencies right?

I hope that after the upgrade is finishied you will still be able to use equo to truly upgrade your system...
colock
Simple Hen
 
Posts: 56
Joined: Mon Feb 25, 2013 12:01

Re: Cant upgrade cos of missing dependency(I need perl 5.16.

Postby Stupot » Tue Mar 19, 2013 16:04

Installing a package from source means you are installing it without the package management system knowing you installed it. This is not recommend and it will never solve any dependency issues because the package manager doesn't know you've installed it.

Doing an equo upgrade --nodeps is a very scary thought. You could easily break your entire system doing that. Please don't do that one anymore.

I'm curious what is pulling that in for you. My system is completely updated via entropy and I don't have anything trying to pull in that version of perl.

The correct thing to do in this situation is to file a bug report, saying that this package needs a version bump in order to perform an entropy upgrade and attach all the necessary logs.
Stupot
Sagely Hen
 
Posts: 1556
Joined: Wed Feb 14, 2007 3:44
Location: St. Louis, MO, USA

Re: Cant upgrade cos of missing dependency(I need perl 5.16.

Postby makav3li » Tue Mar 19, 2013 16:05

No , I had no clue ,i am new at gentoo so I improvised , only 1 package needed that missing dependency, I am wondering does this means that all of the packages haven't been updated properly and how can i fix it , system is working just fine so far,I wonder if reinstalling all the packages would do the trick, and I would need a list of updates for this week, does anyone know where i can find the list of updated packages i had somewhere about 123 packages to upgrade, on scale 1-10 how big of a mess did I made ,lol ???
Last edited by makav3li on Tue Mar 19, 2013 16:06, edited 1 time in total.
makav3li
Young Hen
 
Posts: 27
Joined: Sat Feb 23, 2013 7:28

Re: Cant upgrade cos of missing dependency(I need perl 5.16.

Postby lxnay » Tue Mar 19, 2013 16:06

Update to Entropy 185 (available in minutes) and the problem will be solved.
Image
Join us on IRC (chat.freenode.net #sabayon or WebChat)
Submit bugs to our Bug Tracker
Follow me on Twitter
Add me on Facebook
Add me on Google+
lxnay
Land Owner
 
Posts: 3596
Joined: Thu Oct 13, 2005 23:16
Location: Italy

Re: Cant upgrade cos of missing dependency(I need perl 5.16.

Postby makav3li » Tue Mar 19, 2013 16:07

OK Tnx guys !!!
makav3li
Young Hen
 
Posts: 27
Joined: Sat Feb 23, 2013 7:28

Re: Cant upgrade cos of missing dependency(I need perl 5.16.

Postby lxnay » Tue Mar 19, 2013 16:11

We reached the monthly bandwidth limit (5TB) on mirror.de.sabayon.org and I am limiting the speed to 10Mbit (from 100Mbit). On April 1st, it will be back to 100Mbit/sec. In the meantime, you may want to use mirror.it.sabayon.org, which is unmetered.
Image
Join us on IRC (chat.freenode.net #sabayon or WebChat)
Submit bugs to our Bug Tracker
Follow me on Twitter
Add me on Facebook
Add me on Google+
lxnay
Land Owner
 
Posts: 3596
Joined: Thu Oct 13, 2005 23:16
Location: Italy

Re: Cant upgrade cos of missing dependency(I need perl 5.16.

Postby makav3li » Tue Mar 19, 2013 16:35

Yeah I noticed it today when i was downloading packages , i just installed Entropy 185 ,is there anything else i should do after this ?
makav3li
Young Hen
 
Posts: 27
Joined: Sat Feb 23, 2013 7:28

Next

Return to Entropy|Equo|Rigo Package Managers

Who is online

Users browsing this forum: No registered users and 1 guest