Rigo/Fonts Issues with latest updates [Solved]

Anything that pertains to Entropy, Equo or Sulfur

Moderator: Moderators

Rigo/Fonts Issues with latest updates [Solved]

Postby msdobrescu » Mon Apr 23, 2012 19:42

Hello,

I have updated my Sabayon using sabayonlinuix.org repository.
Then, all the GTK apps (except Firefox, if it is GTK based) have rectangles instead text characters.
It happens to Inkscape, Easytag, Geeqie, Gimp and so on. Even Rigo is affected.

Code: Select all
rigo

(rigo:13395): Pango-CRITICAL **: No modules found:
No builtin or dynamically loaded modules were found.
PangoFc will not work correctly.
This probably means there was an error in the creation of:
  '/etc/pango/pango.modules'
You should create this file by running:
  pango-querymodules > '/etc/pango/pango.modules'

(rigo:13395): Pango-WARNING **: failed to choose a font, expect ugly output. engine-type='PangoRenderFc', script='common'

(rigo:13395): Pango-WARNING **: failed to choose a font, expect ugly output. engine-type='PangoRenderFc', script='latin'

(rigo:13395): Gtk-WARNING **: Theme parsing error: rigo.css:16:20: Not using units is deprecated. Assuming 'px'.

(rigo:13395): Gtk-WARNING **: Theme parsing error: rigo.css:16:26: Not using units is deprecated. Assuming 'px'.

(rigo:13395): Gtk-WARNING **: Theme parsing error: rigo.css:20:22: Not using units is deprecated. Assuming 'px'.

(rigo:13395): Gtk-WARNING **: Theme parsing error: rigo.css:20:24: Not using units is deprecated. Assuming 'px'.

(rigo:13395): Gtk-WARNING **: Theme parsing error: rigo.css:32:20: Not using units is deprecated. Assuming 'px'.

(rigo:13395): Gtk-WARNING **: Theme parsing error: rigo.css:59:19: Not using units is deprecated. Assuming 'px'.


What should I do?
Thank you.


EDIT EDIT EDIT EDIT EDIT EDIT EDIT EDIT EDIT EDIT
Fix:
Code: Select all
# equo install x11-libs/gdk-pixbuf x11-libs/gtk+:2 x11-libs/gtk+:3 x11-libs/pango


than reboot.
Last edited by msdobrescu on Mon Apr 23, 2012 21:38, edited 1 time in total.
msdobrescu
Technological Hen
 
Posts: 444
Joined: Sun Aug 21, 2011 8:48

Re: GTK language or font under KDE

Postby joost » Mon Apr 23, 2012 20:09

as root:
Code: Select all
pango-querymodules > '/etc/pango/pango.modules'
joost
Sagely Hen
 
Posts: 2604
Joined: Fri Nov 17, 2006 12:11
Location: The Netherlands

Re: GTK language or font under KDE

Postby msdobrescu » Mon Apr 23, 2012 21:37

Thank you.
Reinstalling x11-libs/pango also fixed the issue.
msdobrescu
Technological Hen
 
Posts: 444
Joined: Sun Aug 21, 2011 8:48

Rigo/Fonts Problems after Update [Solved]

Postby linuxfluesterer » Fri Jan 18, 2013 18:03

Hallo guys.
Yesterday I've updated my SL X KDE with 250 packages, including KDE 4.9.5. I run Kernel 3.7 before and now.
Today I have found two problems, especially with Rigo.
1. The graphic is (how to say?) not ok (example to make it clear on the photo):
Image
2. Then in Rigo I can not confirm an action (install or update) with my root password. Before I can enter any password I see the Rigo window saying 'Not authorized' (see red area above).
Ok, then I click on the root password authorization window and type in my correct! password, like I do ever:
Image

And then I get a new window, which rejects ("abgewiesen") my password
Image
I can repeat to enter my root password, there is always the same window.

But with the same password (a test in another virtual screen) I can do an 'su' and login with my normal password. Finally an 'equo install xyz' in su konsole.

I assume there are two bugs? or problems. First, my graphics (NVidia GT630M, which worked good before, has got a problem at least in Rigo and (or) Rigo has got a bug.
Do you make same experience here? Is this a Sabayon topic? Then who can manage to repair Rigo?

Thank you in advance.

-Linuxfluesterer (I love KDE ...)

p.s. I've read the thread
viewtopic.php?f=57&t=28885
and I tend to a Rigo problem, because yesterday I did my Upgrade system with Rigo (under KDE 4.9.4) which was done successfully.
Last edited by linuxfluesterer on Thu Jan 24, 2013 20:26, edited 1 time in total.
I really hope, that by the Brexit (poor Britain), TTIP will be finally prevented. But don't get tired to talk to your local politician to open eyes for danger to democracy because of TTIP
User avatar
linuxfluesterer
Old Dear Hen
 
Posts: 725
Joined: Thu Sep 20, 2012 19:47
Location: Germany

Rigo: Problems after Update in SL X (17/01/2013)

Postby linuxfluesterer » Fri Jan 18, 2013 18:48

Update for this thread:
For my authentification problem I've found a solution, because there was an update according to 'DBUS'.
in my message before I said, that it is possible for me to open a konsole and do an su and login as root. That works.
So then when I am root I did an:
Code: Select all
equo upgrade

and after that, DBUS was updated.
Then I rebooted my laptop and started Rigo. It still looks weird like on first photo (graphics problem?) but now I can enter my root password to proceed an action. This works also.

But the graphics problem still persists.

-Linuxfluesterer (I love KDE ...)
I really hope, that by the Brexit (poor Britain), TTIP will be finally prevented. But don't get tired to talk to your local politician to open eyes for danger to democracy because of TTIP
User avatar
linuxfluesterer
Old Dear Hen
 
Posts: 725
Joined: Thu Sep 20, 2012 19:47
Location: Germany

Re: Rigo: Problems after Update in SL X (17/01/2013)

Postby ezioze » Fri Jan 18, 2013 19:21

Hi.
I also have graphic problems in Rigo under KDE and META.
On META as workaround, i select a new theme and rigo set display correctly
ezioze
Simple Hen
 
Posts: 47
Joined: Mon May 10, 2010 10:05

Re: Rigo: Problems after Update in SL X (17/01/2013)

Postby linuxfluesterer » Fri Jan 18, 2013 19:32

ezioze wrote:I also have graphic problems in Rigo under KDE and META.
On META as workaround, i select a new theme and rigo set display correctly

Thanks for your fast reply. But, sorry, I have no idea about a workaround. So, could you tell me pls,
what steps did you do? Delete KDE and then install KDE-Meta and then all the packages?
Or did you make a reinstall?

Again, thank you.

-Linuxfluesterer (I love KDE ...)
I really hope, that by the Brexit (poor Britain), TTIP will be finally prevented. But don't get tired to talk to your local politician to open eyes for danger to democracy because of TTIP
User avatar
linuxfluesterer
Old Dear Hen
 
Posts: 725
Joined: Thu Sep 20, 2012 19:47
Location: Germany

Re: Rigo: Problems after Update in SL X (17/01/2013)

Postby ezioze » Fri Jan 18, 2013 22:55

sorry. i always do this mistake.
I intend MATE (another DE) and not Meta.
I haven't found a workaroud for KDE jet
ezioze
Simple Hen
 
Posts: 47
Joined: Mon May 10, 2010 10:05

Re: Rigo: Problems after Update in SL X (17/01/2013)

Postby linuxfluesterer » Fri Jan 18, 2013 23:53

Anyway ... thank you.
I assume, there is a workaround possible in KDE also, because Sabayon is the (same) base for different DEs.

Good night.

-Linuxfluesterer (I love KDE ...)
I really hope, that by the Brexit (poor Britain), TTIP will be finally prevented. But don't get tired to talk to your local politician to open eyes for danger to democracy because of TTIP
User avatar
linuxfluesterer
Old Dear Hen
 
Posts: 725
Joined: Thu Sep 20, 2012 19:47
Location: Germany

Re: Rigo: Problems after Update in SL X (17/01/2013)

Postby linuxfluesterer » Sat Jan 19, 2013 17:16

Hallo all, especially Sabayonino.
According to this thread:
http://forum.sabayon.org/viewtopic.php?f=76&t=28871&start=10

I (and I assume, not only I) have a graphics problem with Rigo.
I also assume it is due to the same conclusion you made, a newer lib.
So, could you confirm this maybe and also ask for a new Rigo version (here KDE 4.9.5) then?

Thank you in advance.

-Linuxfluesterer (I love KDE ...)
I really hope, that by the Brexit (poor Britain), TTIP will be finally prevented. But don't get tired to talk to your local politician to open eyes for danger to democracy because of TTIP
User avatar
linuxfluesterer
Old Dear Hen
 
Posts: 725
Joined: Thu Sep 20, 2012 19:47
Location: Germany

Next

Return to Entropy|Equo|Rigo Package Managers

Who is online

Users browsing this forum: No registered users and 1 guest