Equo can't update repositories

Anything that pertains to Entropy, Equo or Sulfur

Moderator: Moderators

Equo can't update repositories

Postby argymeg » Sat Nov 24, 2012 14:32

Hello everyone! I have just installed Sabayon 10 KDE on amd64, but when I try to update the repositories I get the following response:
Code: Select all
fusionlinux argy # equo update --force
>> Repository sabayon-weekly hasn't been downloaded yet.
>> Repository sabayon-weekly is not available. Cannot validate
>> RepositoryError()
>> !!! Please update your repositories now in order to remove this message!
>>  @@ Repositories synchronization ...
>>   # Sabayon Linux Official Repository
>>   # Repository URL: http://pkg.sabayon.org/standard/sabayon-weekly/database/amd64/5
>>   # Repository local path: /var/lib/entropy/client/database/amd64/sabayon-weekly/standard/amd64/5
>>   # Repository API: 2
>>      Downloading repository ...
>>      Downloading checksum packages.db.dumplight.bz2.md5 ...
>>      packages.db.meta: available, w00t!.
>>        << unpacked meta file: 00-sabayon.package.use
>>        << unpacked meta file: eapi
>>        << unpacked meta file: make.conf
>>        << unpacked meta file: make.profile
>>        << unpacked meta file: package.keywords
>>        << unpacked meta file: package.mask
>>        << unpacked meta file: package.unmask
>>        << unpacked meta file: packages.db.critical
>>        << unpacked meta file: packages.db.fallback_mirrors
>>        << unpacked meta file: packages.db.keywords
>>        << unpacked meta file: packages.db.lic_whitelist
>>        << unpacked meta file: packages.db.mask
>>        << unpacked meta file: packages.db.mirrors
>>        << unpacked meta file: packages.db.post_update.sh
>>        << unpacked meta file: packages.db.post_upgrade.sh
>>        << unpacked meta file: packages.db.restricted
>>        << unpacked meta file: packages.db.revision
>>        << unpacked meta file: packages.db.system_mask
>>        << unpacked meta file: packages.db.webservices
>>        << unpacked meta file: parent
>>        << unpacked meta file: signature.asc
>>      packages.db.meta.asc: not available, it's ok.
>>      notice.rss: available, w00t!.
>>      Repository revision: 2820
>>      Downloaded repository status: ERROR
>>      An error occured while checking repository integrity. Giving up
>> Repository sabayon-weekly hasn't been downloaded yet.
>> Repository sabayon-weekly is not available. Cannot validate
>> RepositoryError()
>> !!! Please update your repositories now in order to remove this message!

...which is rather frustrating.
I thought maybe it was an issue with the particular weekly revision, so I tried changing to sabayonlinux.org, but still no luck:
Code: Select all
fusionlinux repositories.conf.d # equo update --force
>> Repository sabayonlinux.org hasn't been downloaded yet.
>> Repository sabayonlinux.org is not available. Cannot validate
>> RepositoryError()
>> !!! Please update your repositories now in order to remove this message!
>>  @@ Repositories synchronization ...
>>   # Sabayon Linux Official Repository
>>   # Repository URL: http://pkg.sabayon.org/standard/sabayonlinux.org/database/amd64/5
>>   # Repository local path: /var/lib/entropy/client/database/amd64/sabayonlinux.org/standard/amd64/5
>>   # Repository API: 2
>>      Downloading repository ...
>>      Downloading checksum packages.db.dumplight.bz2.md5 ...
>>      packages.db.meta: available, w00t!.
>>        << unpacked meta file: 00-sabayon.package.use
>>        << unpacked meta file: eapi
>>        << unpacked meta file: make.conf
>>        << unpacked meta file: make.profile
>>        << unpacked meta file: package.keywords
>>        << unpacked meta file: package.mask
>>        << unpacked meta file: package.unmask
>>        << unpacked meta file: packages.db.critical
>>        << unpacked meta file: packages.db.fallback_mirrors
>>        << unpacked meta file: packages.db.keywords
>>        << unpacked meta file: packages.db.lic_whitelist
>>        << unpacked meta file: packages.db.mask
>>        << unpacked meta file: packages.db.mirrors
>>        << unpacked meta file: packages.db.post_update.sh
>>        << unpacked meta file: packages.db.post_upgrade.sh
>>        << unpacked meta file: packages.db.restricted
>>        << unpacked meta file: packages.db.revision
>>        << unpacked meta file: packages.db.system_mask
>>        << unpacked meta file: packages.db.webservices
>>        << unpacked meta file: parent
>>        << unpacked meta file: signature.asc
>>      packages.db.meta.asc: available, w00t!.
>>      notice.rss: available, w00t!.
>>      Repository revision: 2824
>>      Downloaded repository status: ERROR
>>      An error occured while checking repository integrity. Giving up
>> Repository sabayonlinux.org hasn't been downloaded yet.
>> Repository sabayonlinux.org is not available. Cannot validate
>> RepositoryError()
>> !!! Please update your repositories now in order to remove this message!

Any ideas?

(On a sidenote, I should also mention that Rigo fails to display any errors, happily exiting with "No updates found", which is rather counter-intuitive.)
argymeg
Baby Hen
 
Posts: 7
Joined: Wed May 23, 2012 21:04

Re: Equo can't update repositories

Postby batvink » Sat Nov 24, 2012 15:02

I see you've installed the Daily ISO.
Some ISO'S in Daily are pretty useless.
The DE/WM'S are missing at some ISO'S, you can't login, Anaconda doesn't work, and very, very bad Graphics.
afaik KDE-x64, E17-x64 (tested) are affected.
viewtopic.php?f=53&t=28486&p=155490#p155490
User avatar
batvink
Old Dear Hen
 
Posts: 495
Joined: Sun Oct 28, 2007 11:44
Location: the netherlands

Re: Equo can't update repositories

Postby argymeg » Sat Nov 24, 2012 15:07

I don't know where you saw that, but it's the official v10 ISO, not a daily one...
argymeg
Baby Hen
 
Posts: 7
Joined: Wed May 23, 2012 21:04

Re: Equo can't update repositories

Postby batvink » Sat Nov 24, 2012 17:25

i'm sorry. you are right.
i misunderstood, and replied before i've read your complete Article.
User avatar
batvink
Old Dear Hen
 
Posts: 495
Joined: Sun Oct 28, 2007 11:44
Location: the netherlands

Re: Equo can't update repositories

Postby eflyinghi » Wed Nov 28, 2012 4:02

I got the same issue on amd64, gnome.
Any solution?
eflyinghi
Baby Hen
 
Posts: 4
Joined: Wed Oct 24, 2012 9:57


Re: Equo can't update repositories

Postby argymeg » Wed Nov 28, 2012 17:47

Thanks for your reply, but the issue was unrelated. The thread you posted was about being unable to connect to the repositories, while my issue was about the downloaded package lists failing integrity checks. In any case, I have -sort of- solved the issue: it seems to be a problem with my wireless card getting corrupted data, as I also had severe issues while browsing, and everything (including equo) works like a charm via Ethernet. I'll create a thread in the relevant forum.
argymeg
Baby Hen
 
Posts: 7
Joined: Wed May 23, 2012 21:04


Return to Entropy|Equo|Rigo Package Managers

Who is online

Users browsing this forum: No registered users and 2 guests

cron