equo --nocolor disappeared. [Solved]

Anything that pertains to Entropy, Equo or Sulfur

Moderator: Moderators

Post Reply
nobicycle
Simple Hen
Posts: 77
Joined: Fri Nov 20, 2009 13:55

equo --nocolor disappeared. [Solved]

Post by nobicycle » Sun Nov 18, 2012 3:54

Hi,
Where has the --nocolor option gone in equo?

http://wiki.sabayon.org/index.php?title ... #--nocolor

Code: Select all

equo search --nocolor sys-kernel/linux-sabayon
usage: equo search [-h] [--quiet] [--verbose] [--installed | --available]
                   <string> [<string> ...]
equo search: error: unrecognized arguments: --nocolor
Last edited by nobicycle on Sun Nov 18, 2012 11:23, edited 1 time in total.

User avatar
sabayonino
Sagely Hen
Posts: 3190
Joined: Sun Sep 21, 2008 1:12
Location: Italy
Contact:

Re: equo --nocolor disappeared.

Post by sabayonino » Sun Nov 18, 2012 7:26

Code: Select all

# equo --help
could help you :mrgreen:
[Che Cos'è Il Calcolo Distribuito (BOINC)

BOINC ready ! Sabayon+BOINC = BILD ,my Sabayon spin :cyclops: - Ready to crunch for the Science everywhere :)

nobicycle
Simple Hen
Posts: 77
Joined: Fri Nov 20, 2009 13:55

Re: equo --nocolor disappeared.

Post by nobicycle » Sun Nov 18, 2012 8:06

Thanks for the suggestion. :-)
However, unchanged scripts fail because the option is no longer available.
As in my example above:

Code: Select all

equo search [-h] [--quiet] [--verbose] [--installed | --available]
--nocolor is disappeared

User avatar
sabayonino
Sagely Hen
Posts: 3190
Joined: Sun Sep 21, 2008 1:12
Location: Italy
Contact:

Re: equo --nocolor disappeared.

Post by sabayonino » Sun Nov 18, 2012 8:27

uhm . latest equo changes seems to have new features and clear other

Code: Select all

# equo --help

Code: Select all

# man equo
if you need for this dropped features you can file a bug
[Che Cos'è Il Calcolo Distribuito (BOINC)

BOINC ready ! Sabayon+BOINC = BILD ,my Sabayon spin :cyclops: - Ready to crunch for the Science everywhere :)

nobicycle
Simple Hen
Posts: 77
Joined: Fri Nov 20, 2009 13:55

Re: equo --nocolor disappeared.

Post by nobicycle » Sun Nov 18, 2012 11:22

I just changed my scripts and piped the relevant data through sed s/\x1B\[[0-9;]*[JKmsu]//g' to get rid of colour codes.
I suppose this is rigo "less is more" philosophy carried to equo, who's api probably feeds rigo.
No worries.

Post Reply