Seeking help installing latest darktable

Anything that pertains to Entropy, Equo or Sulfur

Moderator: Moderators

Seeking help installing latest darktable

Postby yaeld » Wed Nov 16, 2011 18:31

I have installed Sabayon 7 on my laptop and did all the upgrade, so I guess I'm using Current.

When I bring Sulfur and search for the program DarkTable, it only shows the version 0.8r1 where as the latest is 0.9.3 as you can see here: http://packages.sabayon.org/quicksearch?q=darktable&x=0&y=0

What do I need to do to get the latest version? Do I need to do an install from the source?

Thank you for your help, that will help me understand how Sabayon works with the repo.
Yael
yaeld
Baby Hen
 
Posts: 9
Joined: Wed Nov 16, 2011 18:24

Re: Seeking help installing latest darktable (newbie here)

Postby gamjaevel » Wed Nov 16, 2011 19:32

hmm, sounds weird. not sure what's wrong, just tried to install the package myself, and im getting darktable-0.9.2-r2.

try to remove the package (if you might have it installed, or stored or something on your system)
and try to reinstall it.
gamjaevel
Simple Hen
 
Posts: 40
Joined: Tue Sep 27, 2011 18:40

Re: Seeking help installing latest darktable (newbie here)

Postby yaeld » Wed Nov 16, 2011 19:46

I did remove and did a equo update then equo install darktable and I'm getting the same older version.

I'm using the sabayon-weekly, does that change anything?
yaeld
Baby Hen
 
Posts: 9
Joined: Wed Nov 16, 2011 18:24

Re: Seeking help installing latest darktable (newbie here)

Postby yaeld » Wed Nov 16, 2011 20:55

also before that, I did a emerge --sync $$ layman --sync sabayon
don't know if that makes any difference.
yaeld
Baby Hen
 
Posts: 9
Joined: Wed Nov 16, 2011 18:24

Re: Seeking help installing latest darktable (newbie here)

Postby res0r9lm2 » Wed Nov 16, 2011 22:48

overlay was split into sabayon and sabayon-distro. When synced I got message to remove and re-add sabayon you would want to add sabayon-distro too if your using sabayon. You sync command isn't right from what I see

Code: Select all
emerge --sync && layman -s sabayon

or if you want to sync all your overlays

Code: Select all
emerge --sync && layman -S
res0r9lm2
Simple Hen
 
Posts: 44
Joined: Mon Oct 24, 2011 17:52

Re: Seeking help installing latest darktable (newbie here)

Postby svantoviit » Wed Nov 16, 2011 23:08

There is no 0.8r1 in entropy nor in portage... seems you are not updated.
sabayon-weekly: media-gfx/darktable-0.9.2-r2
portage: media-gfx/darktable Available versions: (~)0.9.2-r1 (~)0.9.2-r2 (~)0.9.3

Try
Code: Select all
equo update --force
equo install entropy sulfur equo  --relaxed
equo conf update
equo update && equo upgrade --ask

and then install darktable.
svantoviit
Old Dear Hen
 
Posts: 642
Joined: Sun Feb 28, 2010 17:55

Re: Seeking help installing latest darktable (newbie here)

Postby yaeld » Wed Nov 16, 2011 23:56

I did both solution and I'm still with the same problem even after a reboot.
I downloaded the x86 version, I'm sure that has nothing to do with it but I might try a new install of the OS again just for sure.
I do need to get the weekly build right?
yaeld
Baby Hen
 
Posts: 9
Joined: Wed Nov 16, 2011 18:24

Re: Seeking help installing latest darktable (newbie here)

Postby svantoviit » Thu Nov 17, 2011 0:01

yaeld wrote:I do need to get the weekly build right?

Do you mean "Daily"? It ca save you a lot of updating after install...
svantoviit
Old Dear Hen
 
Posts: 642
Joined: Sun Feb 28, 2010 17:55

Re: Seeking help installing latest darktable (newbie here)

Postby sabayonino » Thu Nov 17, 2011 1:08

res0r9lm2 wrote:overlay was split into sabayon and sabayon-distro. When synced I got message to remove and re-add sabayon you would want to add sabayon-distro too if your using sabayon. You sync command isn't right from what I see

Code: Select all
emerge --sync && layman -s sabayon

or if you want to sync all your overlays

Code: Select all
emerge --sync && layman -S



Hi

Sabayon's Overlay was spllitted

Please see http://www.sabayon.org/article/splittin ... on-overlay

Now Entropy/Equo are in sabayon-distro overlay. please sync this
User avatar
sabayonino
Sagely Hen
 
Posts: 2439
Joined: Sun Sep 21, 2008 1:12
Location: Italy

Re: Seeking help installing latest darktable (newbie here)

Postby yaeld » Thu Nov 17, 2011 15:06

I tried to type layman -fa sabayon-distro but it didn't work. What am I suppose to do really?

Code: Select all
sabayon yaeld # layman -fa sabayon-distro

 * Fetching remote list,...
 * RemoteDB.cache(); Failed to update the overlay list from: http://www.gentoo.org/proj/en/overlays/repositories.xml
 * IOError was:<urlopen error [Errno -2] Name or service not known>
 *

 * Adding overlay,...
 * Adding repository "sabayon-distro" failed!

 * CLI: Errors occured processing action fetch
 * RemoteDB.cache(); Failed to update the overlay list from: http://www.gentoo.org/proj/en/overlays/repositories.xml
 * IOError was:<urlopen error [Errno -2] Name or service not known>
 *

 * CLI: Errors occured processing action add
 * Adding repository "sabayon-distro" failed!

sabayon yaeld # layman -s abayon-distro

 * Fetching remote list,...
 * Remote list already up to date: http://www.gentoo.org/proj/en/overlays/repositories.xml
 * Last-modified: Tue, 15 Nov 2011 17:15:13 GMT
 * Fetch Ok

 * Syncing selected overlays,...
 *
 * Errors:
 * ------
 * Failed to select overlay "abayon-distro".
 * Error was: Exception: Overlay "abayon-distro" does not exist.
 *

 * CLI: Errors occured processing action sync
 *
 * Errors:
 * ------
 * Failed to select overlay "abayon-distro".
 * Error was: Exception: Overlay "abayon-distro" does not exist.
 *

sabayon yaeld # layman -fa sabayon-distro

 * Fetching remote list,...
 * Remote list already up to date: http://www.gentoo.org/proj/en/overlays/repositories.xml
 * Last-modified: Tue, 15 Nov 2011 17:15:13 GMT
 * Fetch Ok

 * Adding overlay,...
 * Adding repository "sabayon-distro" failed!

 * CLI: Errors occured processing action add
 * Adding repository "sabayon-distro" failed!
yaeld
Baby Hen
 
Posts: 9
Joined: Wed Nov 16, 2011 18:24

Next

Return to Entropy|Equo|Rigo Package Managers

Who is online

Users browsing this forum: No registered users and 1 guest