Page 1 of 1

[solved] nmap needs Python 2.6

Posted: Tue Jul 12, 2011 15:16
by aTan
I can't install nmap because it needs Python 2.6 and a fresh updated Sabayon 6 has Python 2.7. Is there a solution withou portage?

Code: Select all

 ~ # equo install nmap
>>  @@ Calculating dependencies ...
>>  ## [R] [sabayon-weekly] net-analyzer/nmap-5.51|1   [5.51|1]
>>  @@ Packages needing to be installed/updated/downgraded: 1
>>  @@ Packages needing to be removed: 0
>>  @@ Download size: 0b
>>  @@ Freed disk space: 0.0b
>>  @@ You need at least: 4.4MB of free space
>>  :: (1/1) >>> 1 packages
>>    ## Package checksum matches: net-analyzer:nmap-5.51~1.tbz2
>>  ++ (1/1) >>> net-analyzer/nmap-5.51
>>    ## Unpacking package: net-analyzer:nmap-5.51~1.tbz2
>>    ## SPM: setup phase
 * Package:    net-analyzer/nmap-5.51
 * Repository: sabayon
 * USE:        amd64 elibc_glibc kernel_linux multilib ssl userland_GNU
 * FEATURES:   preserve-libs sandbox splitdebug
>>> cfg-update-1.8.2-r1: Checksum index is up-to-date ...
 * ERROR: net-analyzer/nmap-5.51 failed (setup phase):
 *   dev-lang/python:2.6 is not installed
 * 
 * Call stack:
 *     ebuild.sh, line   56:  Called pkg_setup
 *   environment, line 3001:  Called python_set_active_version '2'
 *   environment, line 4736:  Called _python_final_sanity_checks
 *   environment, line  792:  Called die
 * The specific snippet of code:
 *                   die "$(python_get_implementational_package) is not installed";
 * 
 * If you need support, post the output of 'emerge --info =net-analyzer/nmap-5.51',
 * the complete build log and the output of 'emerge -pqv =net-analyzer/nmap-5.51'.
 * The complete build log is located at '/var/tmp/entropy/packages/amd64/5/net-analyzer_nmap-5.51_1.tbz2/portage/net-analyzer/nmap-5.51/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/entropy/packages/amd64/5/net-analyzer_nmap-5.51_1.tbz2/portage/net-analyzer/nmap-5.51/temp/environment'.
 * S: '/var/tmp/entropy/packages/amd64/5/net-analyzer_nmap-5.51_1.tbz2/portage/net-analyzer/nmap-5.51/work/nmap-5.51'
>>    ## Installing package: net-analyzer/nmap-5.51
>>    ## [A utility for network exploration or security auditing]
>>    ## Updating database: net-analyzer/nmap-5.51
>>    ## Cleaning previously installed application data.
>>    ## Cleaning: net-analyzer/nmap-5.51
>>  @@ Installation complete.
>>  @@ Configuration files scan complete.

Re: nmap needs Python 2.6

Posted: Wed Jul 13, 2011 12:30
by Thev00d00
Please file a bug Bug

Re: nmap needs Python 2.6

Posted: Thu Jul 14, 2011 9:17
by aTan