Unable to install/update w/equo [Solved]

Anything that pertains to Entropy, Equo or Sulfur

Moderator: Moderators

Unable to install/update w/equo [Solved]

Postby Gremnon » Mon May 02, 2011 10:36

I just installed Sabayon, and being new to it, the first thing that came naturally was to update, then pull in what I use.
Except I can't seem to do any package management. Sulfur doesn't start unless launched from Konsole (Using the 5.5 K edition), and in any case gives the same issues as 'sudo equo upgrade'

Namely, the below (warning, quite a bit of it here):

Code: Select all
>>  @@ Cannot find needed dependencies:
>>     # Not found: >=kde-base/kde-l10n-4.4[-aqua,linguas_sl(+)]
>>       # Probably needed by:
>>         #  [from:sabayonlinux.org] net-wireless/bluedevil-1.1-r1
>>         #  [from:sabayonlinux.org] dev-util/kdevelop-4.2.2
>>     # Not found: >=kde-base/kde-l10n-4.4[-aqua,linguas_eo(+)]
>>       # Probably needed by:
>>         #  [from:sabayonlinux.org] net-wireless/bluedevil-1.1-r1
>>     # Not found: >=kde-base/kde-l10n-4.4[-aqua,linguas_et(+)]
>>       # Probably needed by:
>>         #  [from:sabayonlinux.org] net-wireless/bluedevil-1.1-r1
>>         #  [from:sabayonlinux.org] dev-util/kdevelop-4.2.2
>>     # Not found: >=kde-base/kde-l10n-4.4[-aqua,linguas_de(+)]
>>       # Probably needed by:
>>         #  [from:sabayonlinux.org] net-wireless/bluedevil-1.1-r1
>>         #  [from:sabayonlinux.org] dev-util/kdevelop-4.2.2
>>     # Not found: >=kde-base/kde-l10n-4.4[-aqua,linguas_cs(+)]
>>       # Probably needed by:
>>         #  [from:sabayonlinux.org] net-wireless/bluedevil-1.1-r1
>>     # Not found: >=kde-base/kde-l10n-4.4[-aqua,linguas_es(+)]
>>       # Probably needed by:
>>         #  [from:sabayonlinux.org] net-wireless/bluedevil-1.1-r1
>>         #  [from:sabayonlinux.org] dev-util/kdevelop-4.2.2
>>     # Not found: >=kde-base/kde-l10n-4.4[-aqua,linguas_nds(+)]
>>       # Probably needed by:
>>         #  [from:sabayonlinux.org] net-wireless/bluedevil-1.1-r1
>>         #  [from:sabayonlinux.org] dev-util/kdevelop-4.2.2
>>     # Not found: >=kde-base/kde-l10n-4.4[-aqua,linguas_sk(+)]
>>       # Probably needed by:
>>         #  [from:sabayonlinux.org] net-wireless/bluedevil-1.1-r1
>>     # Not found: >=kde-base/kde-l10n-4.4[-aqua,linguas_el(+)]
>>       # Probably needed by:
>>         #  [from:sabayonlinux.org] net-wireless/bluedevil-1.1-r1
>>     # Not found: >=kde-base/kde-l10n-4.4[-aqua,linguas_uk(+)]
>>       # Probably needed by:
>>         #  [from:sabayonlinux.org] net-wireless/bluedevil-1.1-r1
>>         #  [from:sabayonlinux.org] dev-util/kdevelop-4.2.2
>>     # Not found: >=kde-base/kde-l10n-4.4[-aqua,linguas_pt(+)]
>>       # Probably needed by:
>>         #  [from:sabayonlinux.org] net-wireless/bluedevil-1.1-r1
>>         #  [from:sabayonlinux.org] dev-util/kdevelop-4.2.2
>>     # Not found: >=kde-base/kde-l10n-4.4[-aqua,linguas_ru(+)]
>>       # Probably needed by:
>>         #  [from:sabayonlinux.org] net-wireless/bluedevil-1.1-r1
>>         #  [from:sabayonlinux.org] dev-util/kdevelop-4.2.2
>>     # Not found: >=kde-base/kde-l10n-4.4[-aqua,linguas_ja(+)]
>>       # Probably needed by:
>>         #  [from:sabayonlinux.org] net-wireless/bluedevil-1.1-r1
>>     # Not found: >=kde-base/kde-l10n-4.4[-aqua,linguas_pl(+)]
>>       # Probably needed by:
>>         #  [from:sabayonlinux.org] net-wireless/bluedevil-1.1-r1
>>     # Not found: >=kde-base/kde-l10n-4.4[-aqua,linguas_pa(+)]
>>       # Probably needed by:
>>         #  [from:sabayonlinux.org] net-wireless/bluedevil-1.1-r1
>>     # Not found: >=kde-base/kde-l10n-4.4[-aqua,linguas_ms(+)]
>>       # Probably needed by:
>>         #  [from:sabayonlinux.org] net-wireless/bluedevil-1.1-r1
>>     # Not found: >=kde-base/kde-l10n-4.4[-aqua,linguas_fr(+)]
>>       # Probably needed by:
>>         #  [from:sabayonlinux.org] net-wireless/bluedevil-1.1-r1
>>         #  [from:sabayonlinux.org] dev-util/kdevelop-4.2.2
>>     # Not found: >=kde-base/kde-l10n-4.4[-aqua,linguas_ca(+)]
>>       # Probably needed by:
>>         #  [from:sabayonlinux.org] net-wireless/bluedevil-1.1-r1
>>         #  [from:sabayonlinux.org] dev-util/kdevelop-4.2.2
>>     # Not found: >=kde-base/kde-l10n-4.4[-aqua,linguas_nb(+)]
>>       # Probably needed by:
>>         #  [from:sabayonlinux.org] net-wireless/bluedevil-1.1-r1
>>         #  [from:sabayonlinux.org] dev-util/kdevelop-4.2.2
>>     # Not found: >=kde-base/kde-l10n-4.4[-aqua,linguas_zh_TW(+)]
>>       # Probably needed by:
>>         #  [from:sabayonlinux.org] net-wireless/bluedevil-1.1-r1
>>         #  [from:sabayonlinux.org] dev-util/kdevelop-4.2.2
>>     # Not found: >=kde-base/kde-l10n-4.4[-aqua,linguas_ro(+)]
>>       # Probably needed by:
>>         #  [from:sabayonlinux.org] net-wireless/bluedevil-1.1-r1
>>     # Not found: >=kde-base/kde-l10n-4.4[-aqua,linguas_pt_BR(+)]
>>       # Probably needed by:
>>         #  [from:sabayonlinux.org] net-wireless/bluedevil-1.1-r1
>>         #  [from:sabayonlinux.org] dev-util/kdevelop-4.2.2
>>     # Not found: >=kde-base/kde-l10n-4.4[-aqua,linguas_nl(+)]
>>       # Probably needed by:
>>         #  [from:sabayonlinux.org] net-wireless/bluedevil-1.1-r1
>>         #  [from:sabayonlinux.org] dev-util/kdevelop-4.2.2
>>     # Not found: >=kde-base/kde-l10n-4.4[-aqua,linguas_eu(+)]
>>       # Probably needed by:
>>         #  [from:sabayonlinux.org] net-wireless/bluedevil-1.1-r1
>>     # Not found: >=kde-base/kde-l10n-4.4[-aqua,linguas_fi(+)]
>>       # Probably needed by:
>>         #  [from:sabayonlinux.org] net-wireless/bluedevil-1.1-r1
>>     # Not found: >=kde-base/kde-l10n-4.4[-aqua,linguas_da(+)]
>>       # Probably needed by:
>>         #  [from:sabayonlinux.org] net-wireless/bluedevil-1.1-r1
>>         #  [from:sabayonlinux.org] dev-util/kdevelop-4.2.2
>>     # Not found: >=kde-base/kde-l10n-4.4[-aqua,linguas_it(+)]
>>       # Probably needed by:
>>         #  [from:sabayonlinux.org] net-wireless/bluedevil-1.1-r1
>>         #  [from:sabayonlinux.org] dev-util/kdevelop-4.2.2
>>     # Not found: >=kde-base/kde-l10n-4.4[-aqua,linguas_en_GB(+)]
>>       # Probably needed by:
>>         #  [from:sabayonlinux.org] net-wireless/bluedevil-1.1-r1
>>         #  [from:sabayonlinux.org] dev-util/kdevelop-4.2.2
>>     # Not found: >=kde-base/kde-l10n-4.4[-aqua,linguas_sv(+)]
>>       # Probably needed by:
>>         #  [from:sabayonlinux.org] net-wireless/bluedevil-1.1-r1
>>         #  [from:sabayonlinux.org] dev-util/kdevelop-4.2.2
>>     # Not found: >=kde-base/kde-l10n-4.4[-aqua,linguas_hu(+)]
>>       # Probably needed by:
>>         #  [from:sabayonlinux.org] net-wireless/bluedevil-1.1-r1
>>     # Not found: >=kde-base/kde-l10n-4.4[-aqua,linguas_lt(+)]
>>       # Probably needed by:
>>         #  [from:sabayonlinux.org] net-wireless/bluedevil-1.1-r1
>>     # Not found: >=kde-base/kde-l10n-4.4[-aqua,linguas_ko(+)]
>>       # Probably needed by:
>>         #  [from:sabayonlinux.org] net-wireless/bluedevil-1.1-r1
>>     # Not found: >=kde-base/kde-l10n-4.4[-aqua,linguas_tr(+)]
>>       # Probably needed by:
>>         #  [from:sabayonlinux.org] net-wireless/bluedevil-1.1-r1


I have verified I have a working internet connection (otherwise I'd love to know how I'm posting this from Sabayon...).
There's been no changes to the system at all since rebooting into the freshly installed environment.
I did opt to remove the additional languages at the end of the install process, as I've no need for any but British English, and given that all of these entries refer to 'l10n' I'm given to wonder if that's the cause.

In any case, can anyone help a disgruntled Arch user get this little issue solved?
Last edited by Gremnon on Mon May 02, 2011 12:06, edited 1 time in total.
To err is human, but to completely f' it up requires a computer.
Gremnon
Baby Hen
 
Posts: 6
Joined: Mon May 02, 2011 10:31
Location: UK

Re: Unable to install/update w/equo

Postby joost » Mon May 02, 2011 10:42

Try this:
Code: Select all
equo update --force


Then whatever you was trying todo.
joost
Sagely Hen
 
Posts: 2605
Joined: Fri Nov 17, 2006 12:11
Location: The Netherlands

Re: Unable to install/update w/equo

Postby Gremnon » Mon May 02, 2011 10:48

Well, it updated... but 'sudo equo upgrade' afterwards still chucks out the same list of Not founds I was getting before, and trying to install any package also still results in the same.
To err is human, but to completely f' it up requires a computer.
Gremnon
Baby Hen
 
Posts: 6
Joined: Mon May 02, 2011 10:31
Location: UK

Re: Unable to install/update w/equo

Postby joost » Mon May 02, 2011 11:56

I noticed that kdevelop and bluedevil should not pull all those language packages at all.
Correcting this in the tree.
joost
Sagely Hen
 
Posts: 2605
Joined: Fri Nov 17, 2006 12:11
Location: The Netherlands

Re: Unable to install/update w/equo

Postby Gremnon » Mon May 02, 2011 12:00

So... I guess I just have to wait a bit and then do another update/upgrade?
I think I figured out how to search installed packages though, and found neither of those packages installed - at least, it tells me they're not there if I issue a remove command for them.
So I'm sort of guessing unlike Arch, stuff like would show up even if the packages aren't installed?
To err is human, but to completely f' it up requires a computer.
Gremnon
Baby Hen
 
Posts: 6
Joined: Mon May 02, 2011 10:31
Location: UK

Re: Unable to install/update w/equo

Postby joost » Mon May 02, 2011 12:04

Yep its our fault.
We had to make some changes to adopt changes made upstream (regarding linguas) and something didn't get worked as it should.
joost
Sagely Hen
 
Posts: 2605
Joined: Fri Nov 17, 2006 12:11
Location: The Netherlands

Re: Unable to install/update w/equo [Solved]

Postby Gremnon » Mon May 02, 2011 12:06

Ah, gotcha. Could happen to anyone :D
Marked the thread as solved.
To err is human, but to completely f' it up requires a computer.
Gremnon
Baby Hen
 
Posts: 6
Joined: Mon May 02, 2011 10:31
Location: UK

Re: Unable to install/update w/equo [Solved]

Postby joost » Mon May 02, 2011 12:24

Fixed in Entropy now. (run equo update once again)
joost
Sagely Hen
 
Posts: 2605
Joined: Fri Nov 17, 2006 12:11
Location: The Netherlands


Return to Entropy|Equo|Rigo Package Managers

Who is online

Users browsing this forum: No registered users and 2 guests