equo broken [Solved]

Anything that pertains to Entropy, Equo or Sulfur

Moderator: Moderators

equo broken [Solved]

Postby manifesto » Sat Apr 30, 2011 16:05

Hi,

I did an update today and python 2.7 looks to have been removed from my system.
now I cant use equo anymore.
I link python2 to python2.6 but of course it dont work.

Code: Select all
sabayon bin #  ls -ltr pyth*
-rwxr-xr-x 1 root root 10328 17 avril  2010 python-wrapper
-rwxr-xr-x 1 root root  1200 17 févr. 01:34 python-config-2.6
-rwxr-xr-x 1 root root  6200 17 févr. 01:34 python2.6
lrwxrwxrwx 1 root root    14 30 avril 16:12 python -> python-wrapper
-rwxr-xr-x 1 root root   217 30 avril 16:12 python-config
lrwxrwxrwx 1 root root    15 30 avril 16:43 python2 -> /usr/bin/python



Any idea how to solve ?
Last edited by manifesto on Sun May 01, 2011 21:16, edited 2 times in total.
manifesto
Growing Hen
 
Posts: 168
Joined: Mon Jul 19, 2010 22:21

Re: equo broken

Postby genfool » Sat Apr 30, 2011 16:34

what does eselect python list show?

Available Python interpreters:
[1] python2.6
[2] python2.7 *
genfool
Technological Hen
 
Posts: 342
Joined: Fri Apr 03, 2009 17:56
Location: Albuquerque, NM

Re: equo broken

Postby manifesto » Sat Apr 30, 2011 18:02

Unfortunatly 2.7 disapeard :

Code: Select all
sabayon bin # eselect python list
Available Python interpreters:
  [1]   python2.6
Last edited by manifesto on Sun May 01, 2011 21:15, edited 1 time in total.
manifesto
Growing Hen
 
Posts: 168
Joined: Mon Jul 19, 2010 22:21

Re: equo broken

Postby gabvil » Sat Apr 30, 2011 19:19

Try this:

Code: Select all
#eselect python update


That should link again your python2.

Check your Python bin is working and properly linked. Choose your Python version if needed. (seems that new entropy revision pull the 2.7)

Code: Select all
#equo update
#equo upgrade
#equo conf update
#equo deptest
#equo libtest                       < if needed equo conf update
#eselect python list              < could give you the python 2.7
#eselect python set *            < set the number you need in *
#eselect python update


If this works put [SOLVED] !
Regards !
·Intel e2180@2.0/2Gb Ram/160Gb/82945GZ/Sabayon Mate 13.07 x64 @work X2
·Intel e2130@1.7/2Gb Ram/250Gb/x3100 GM965/Sabayon Mate 13.07 x64 @lappy
·Intel e5200@2.5/2Gb Ram/800 Gb/Zotac 8400GS-512Mb-HDMI/Sabayon Mate 13.07 x64 @HTPC
gabvil
Growing Hen
 
Posts: 119
Joined: Tue Sep 28, 2010 22:27
Location: Canelones, Uruguay

Re: equo broken [Solved]

Postby manifesto » Sat Apr 30, 2011 19:37

It looks like it works ! Thanks.
But which did python 2.7 went out ???


Code: Select all
sabayon bin # eselect python update
Switching to python2.6
sabayon bin # equo update
>>  @@ Synchronisation des dépôts ...
>>   # Sabayon Linux Official Repository
>>   # Repository URL: http://pkg.sabayon.org/standard/sabayonlinux.org/database/amd64/5
...
Last edited by manifesto on Sun May 01, 2011 21:16, edited 1 time in total.
manifesto
Growing Hen
 
Posts: 168
Joined: Mon Jul 19, 2010 22:21

Re: equo broken [Solved]

Postby gabvil » Sat Apr 30, 2011 19:43

I have a cutted down log from your post.

Were it goes?

Well did you put:

Code: Select all
#eselect python list


This should show your python versions.
·Intel e2180@2.0/2Gb Ram/160Gb/82945GZ/Sabayon Mate 13.07 x64 @work X2
·Intel e2130@1.7/2Gb Ram/250Gb/x3100 GM965/Sabayon Mate 13.07 x64 @lappy
·Intel e5200@2.5/2Gb Ram/800 Gb/Zotac 8400GS-512Mb-HDMI/Sabayon Mate 13.07 x64 @HTPC
gabvil
Growing Hen
 
Posts: 119
Joined: Tue Sep 28, 2010 22:27
Location: Canelones, Uruguay

Re: equo broken [Solved]

Postby manifesto » Sun May 01, 2011 21:38

I did again an update today and pythin 2.7 appears again.
I saw another post on this subject in the forum. Python version looks a bit unstable this days.
I hope this time everything will stay ok.

Code: Select all
sabayon ~ # eselect python list
Available Python interpreters:
  [1]   python2.6
  [2]   python2.7 *


Before today update I got just one 2.6.
manifesto
Growing Hen
 
Posts: 168
Joined: Mon Jul 19, 2010 22:21

Re: equo broken [Solved]

Postby gabvil » Sun May 01, 2011 23:34

Weird, before the updates with Entropy Beta 5 the Python 2.7 was pulled to my sys.
Now i have the 2 pythons, eselected the latest one. I have some compatibility issues regarding some 2.6 scripts, example some Deluge plugins. I can live with it ! :mrgreen:

Fully updated sys, Entropy Beta 8, some alsa-utils packages and still Python 2.6 and 2.7.
·Intel e2180@2.0/2Gb Ram/160Gb/82945GZ/Sabayon Mate 13.07 x64 @work X2
·Intel e2130@1.7/2Gb Ram/250Gb/x3100 GM965/Sabayon Mate 13.07 x64 @lappy
·Intel e5200@2.5/2Gb Ram/800 Gb/Zotac 8400GS-512Mb-HDMI/Sabayon Mate 13.07 x64 @HTPC
gabvil
Growing Hen
 
Posts: 119
Joined: Tue Sep 28, 2010 22:27
Location: Canelones, Uruguay


Return to Entropy|Equo|Rigo Package Managers

Who is online

Users browsing this forum: No registered users and 1 guest