Not found: >=media-sound/phonon-4.4.4

Anything that pertains to Entropy, Equo or Sulfur

Moderator: Moderators

Not found: >=media-sound/phonon-4.4.4

Postby cyclones » Mon Mar 28, 2011 22:02

I noticed some strangeness in entropy today. When I tried to upgrade, it told me it was going to upgrade phonon to a new slot but then told me it could not find the phonon dependency with the same version it was trying to upgrade to.

What's going on here, some kind of circular dependency issue? Why can't equo find phonon-4.4.4 when it is already installed?

sabayon root # equo update && equo --ask upgrade
>> @@ Repositories synchronization ...
>> [sabayon.org:1026] Successfully connected to host
>> [sabayon.org:1026] Successfully disconnected from host
>> # Sabayon Linux Official Repository
>> # Repository URL: http://pkg.sabayon.org/standard/sabayon ... se/amd64/5
>> # Repository local path: /var/lib/entropy/client/database/amd64/sabayonlinux.org/standard/amd64/5
>> # Repository API: 3
>> [sabayon.org:1026] Successfully connected to host
>> [sabayon.org:1026] Successfully disconnected from host
>> Attention: repository is already up to date.
>> @@ Notice board: sabayonlinux.org
>> [0] [Thu, 10 Mar 2011 08:51:02 +0000] Title: The libjpeg-turbo library (boosting performance)
>> @@ Calculating System Updates...
>> @@ These are the chosen packages:
>> # (1/2) [sabayonlinux.org] kde-base/dragonplayer-4.6.1
>> Versions: 4.6.1 / NoTag / 0 ===> 4.6.1 / NoTag / 1
>> Action: Upgrade
>> # (2/2) [sabayonlinux.org] media-libs/phonon-4.4.4
>> Versions: 4.4.4 / NoTag / 0 ===> 4.4.4 / NoTag / 1
>> Action: Upgrade

>> @@ Packages involved: 2
Would you like to continue with dependencies calculation ? [Yes/No]
>> @@ Calculating dependencies ...
>> @@ Cannot find needed dependencies:
>> # Not found: >=media-sound/phonon-4.4.4
>> # Probably needed by:
>> # [from:sabayonlinux.org] media-sound/phonon-xine-4.4.4
>> # [from:sabayonlinux.org] media-sound/phonon-vlc-0.3.2
cyclones
Baby Hen
 
Posts: 2
Joined: Tue Apr 27, 2010 1:37

Re: Not found: >=media-sound/phonon-4.4.4

Postby ztico » Tue Mar 29, 2011 0:01

I have exactly the same problem.
I tried to install it via emerge and had no problems but entropy does not recognize the installation...
Any ideas?
ztico
Baby Hen
 
Posts: 10
Joined: Sun Mar 27, 2011 15:22

Re: Not found: >=media-sound/phonon-4.4.4

Postby wolfden » Tue Mar 29, 2011 5:37

Please file a bug http://bugs.sabayon.org/

Thanks
wolfden
Sharecropper
 
Posts: 9050
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA

Re: Not found: >=media-sound/phonon-4.4.4

Postby joost » Tue Mar 29, 2011 7:24

Run equo update again.

It happened because you have testing repository attached (I think).

In this case, phonon package moved from "media-sound" to a different category "media-libs". The limbo end was already aware of it, but the main repository not yet.
joost
Sagely Hen
 
Posts: 2574
Joined: Fri Nov 17, 2006 12:11
Location: The Netherlands

Re: Not found: >=media-sound/phonon-4.4.4

Postby ztico » Tue Mar 29, 2011 14:42

'equo update' works fine but 'equo upgrade' still fails
ztico
Baby Hen
 
Posts: 10
Joined: Sun Mar 27, 2011 15:22

Re: Not found: >=media-sound/phonon-4.4.4

Postby joost » Tue Mar 29, 2011 14:53

joost
Sagely Hen
 
Posts: 2574
Joined: Fri Nov 17, 2006 12:11
Location: The Netherlands

Re: Not found: >=media-sound/phonon-4.4.4

Postby ztico » Tue Mar 29, 2011 19:27

joost wrote:
Try this command:
Code: Select all
equo update --force


It works ;) Thank you! (also for your patience...)
ztico
Baby Hen
 
Posts: 10
Joined: Sun Mar 27, 2011 15:22


Return to Entropy|Equo|Rigo Package Managers

Who is online

Users browsing this forum: No registered users and 1 guest

cron