Cannot update package [Solved]

Anything that pertains to Entropy, Equo or Sulfur

Moderator: Moderators

Cannot update package [Solved]

Postby betrunken affe » Thu Feb 11, 2010 18:08

I just did a fresh install of Sabayon last night and have been struggling to do updates since. It recommended installing updates for equo/sulfur first and then do the others. I tried both command line and graphically to upgrade just these and all but 1 file downloads successfully. I pulled out all the "unnecessary" information like the packages that worked and the duplicate attempts which failed (with same error message).

I tried doing the speedup fix in this forum but it didn't help. Is it just the file downloaded with corruption? How do I force a redownload or resolve the checksum failing issue?

Code: Select all
[email protected] ~ $ sudo equo install sulfur entropy magneto-kde equo entropy-client-services
>>  @@ Calculating dependencies ...
>>  @@ Packages needing to be installed/updated/downgraded: 65
>>  @@ Packages needing to be removed: 6                     
>>  @@ Download size: 0b                                     
>>  @@ Used disk space: 434.1MB                               
>>  @@ You need at least: 842.6MB of free space               
>>  :: (61/65) >>> sys-apps/miscfiles-1.4.2-r1                 
>>    ## Downloading archive: sys-apps:miscfiles-1.4.2-r1.tbz2
>>    ## Checksum does not match. Download attempt #6
>>    ## ( mirror #1 ) Downloading from: na.mirror.garr.it
>>    ## ( mirror #1 ) Error downloading from: na.mirror.garr.it - not found.
>>    ## ( mirror #2 ) Downloading from: ftp.surfnet.nl
>>    ## ( mirror #2 ) Error downloading from: ftp.surfnet.nl - not found.
>>    ## ( mirror #3 ) Downloading from: svn.sabayonlinux.org
>>    ## ( mirror #3 ) Successfully downloaded from: svn.sabayonlinux.org at 0.0b/second
>>    ## Cannot fetch package or checksum does not match.
>>    ## Try to download latest repositories.
>>    ## An error occured. Action aborted.
>>  @@ Download incomplete.
Last edited by betrunken affe on Mon Feb 15, 2010 6:57, edited 1 time in total.
betrunken affe
Baby Hen
 
Posts: 4
Joined: Thu Feb 11, 2010 17:59

Re: Cannot update package

Postby DHalens » Thu Feb 11, 2010 18:52

Probably mirrors weren't synced when you tried to update. Please try again in a few hours.

As a side note, sabayon discourages the use of sudo.
Former Sabayon staff (retired).
For any personal questions or whatever, contact me trough my G+ profile
DHalens
Old Dear Hen
 
Posts: 933
Joined: Thu Apr 10, 2008 23:08
Location: Canary Islands, Spain

Re: Cannot update package

Postby betrunken affe » Thu Feb 11, 2010 20:31

Tried last night and again this morning since I was thinking much the same. I did notice that the version I'm using doesn't seem to do the GPG checksum but does the 2 SHA ones which are apparently no longer in use. I was thinking it might be these that are causing the issue but I don't know how to look into that too much further. I can't use emerge to update the equo version (instructions used: http://wiki.sabayon.org/index.php?title=Entropy) since I get this error (I don't know what masked is)

Code: Select all
!!! All ebuilds that could satisfy "sys-apps/entropy" have been masked.
!!! One of the following masked packages is required to complete your request:
- sys-apps/entropy-0.99.34.1 (masked by: corruption)                         
- sys-apps/entropy-0.99.34 (masked by: corruption)                           
- sys-apps/entropy-0.99.33.6 (masked by: corruption)                         
- sys-apps/entropy-0.99.33.1 (masked by: corruption)                         
- sys-apps/entropy-0.99.33 (masked by: corruption)                           
- sys-apps/entropy-0.99.32.1 (masked by: corruption)                         
- sys-apps/entropy-0.99.32 (masked by: corruption)                           
- sys-apps/entropy-0.99.31.1 (masked by: corruption)                         
- sys-apps/entropy-0.99.30.2 (masked by: corruption)                         
- sys-apps/entropy-0.99.30.1 (masked by: corruption)                         
- sys-apps/entropy-0.99.30 (masked by: corruption)                           
- sys-apps/entropy-0.99.26 (masked by: corruption)                           
- sys-apps/entropy-0.99.25 (masked by: corruption)                           
- sys-apps/entropy-0.99.24.11 (masked by: corruption)                         
- sys-apps/entropy-0.99.24.10 (masked by: corruption)                         
- sys-apps/entropy-0.99.24.9 (masked by: corruption)                         
- sys-apps/entropy-0.99.24.8 (masked by: corruption)                         
- sys-apps/entropy-0.99.24.7 (masked by: corruption)                         
- sys-apps/entropy-0.99.24.6 (masked by: corruption)                         
- sys-apps/entropy-0.99.24.5 (masked by: corruption)                         
- sys-apps/entropy-0.99.24.4 (masked by: corruption)                         
- sys-apps/entropy-0.99.24.3 (masked by: corruption)                         
- sys-apps/entropy-0.99.24.2 (masked by: corruption)                         
- sys-apps/entropy-0.99.24.1 (masked by: corruption)                         
- sys-apps/entropy-0.99.3.8 (masked by: corruption)
- sys-apps/entropy-0.99.3.7 (masked by: corruption)


On sudo: Saves having to prove that I do recognize the need of having root access without extra lines in an already decent length code block.
betrunken affe
Baby Hen
 
Posts: 4
Joined: Thu Feb 11, 2010 17:59

Re: Cannot update package

Postby gnosti » Fri Feb 12, 2010 16:58

I'm having a similar issue, Witht the nvidia-driver package for 2.6.32 kernel
Code: Select all
>>> x11-drivers/nvidia-drivers-190.53-r1#2.6.32-sabayon             
>>    ## Downloading archive: x11-drivers:nvidia-drivers-190.53-r1#2.6.32-sabayon.tbz2
>>    ## ( mirror #1 ) Downloading from: na.mirror.garr.it                           
>>    ## ( mirror #1 ) Successfully downloaded from: na.mirror.garr.it at 0.0b/second
>>    ## Checksum does not match. Download attempt #1
>>    ## ( mirror #1 ) Downloading from: na.mirror.garr.it
>>    ## ( mirror #1 ) Successfully downloaded from: na.mirror.garr.it at 0.0b/second
>>    ## Checksum does not match. Download attempt #2
>>    ## ( mirror #1 ) Downloading from: na.mirror.garr.it
>>    ## ( mirror #1 ) Successfully downloaded from: na.mirror.garr.it at 0.0b/second
>>    ## Checksum does not match. Download attempt #3
>>    ## ( mirror #1 ) Downloading from: na.mirror.garr.it
>>    ## ( mirror #1 ) Successfully downloaded from: na.mirror.garr.it at 0.0b/second
>>    ## Checksum does not match. Download attempt #4
>>    ## ( mirror #1 ) Downloading from: na.mirror.garr.it
>>    ## ( mirror #1 ) Successfully downloaded from: na.mirror.garr.it at 0.0b/second
>>    ## Checksum does not match. Download attempt #5
>>    ## ( mirror #1 ) Downloading from: na.mirror.garr.it
>>    ## ( mirror #1 ) Successfully downloaded from: na.mirror.garr.it at 0.0b/second
>>    ## Checksum does not match. Download attempt #6
>>    ## ( mirror #1 ) Downloading from: na.mirror.garr.it
>>    ## ( mirror #1 ) Successfully downloaded from: na.mirror.garr.it at 0.0b/second
>>    ## Cannot fetch package or checksum does not match.
>>    ## Try to download latest repositories.
>>    ## An error occured. Action aborted.
>>  @@ Download incomplete.
>>  @@ Configuration files scan complete.
gnosti
Baby Hen
 
Posts: 7
Joined: Fri Dec 19, 2008 14:47

Re: Cannot update package

Postby betrunken affe » Fri Feb 12, 2010 20:38

I'm not sure if I should call this solved... I went from 361 upgrades to 1 being available but I didn't install anything.
betrunken affe
Baby Hen
 
Posts: 4
Joined: Thu Feb 11, 2010 17:59

Re: Cannot update package

Postby flameboy » Sun Feb 14, 2010 2:13

I had this problem after installing today. I found that going through this Fresh_Install_-_What_to_do sorted it out. I think the main thing is that it let me update entropy, equo and sulfur through portage, but I followed it all so it could be any part of it that helped. Hope it helps you also.
flameboy
Baby Hen
 
Posts: 4
Joined: Sun Feb 14, 2010 2:01

Re: Cannot update package

Postby betrunken affe » Mon Feb 15, 2010 6:56

That officially resolved it.

Edit: My wireless wasn't working when I posted that up so was rushed (running on battery trying to fix :P).. Thank you for the assistance.
Last edited by betrunken affe on Mon Feb 15, 2010 18:23, edited 1 time in total.
betrunken affe
Baby Hen
 
Posts: 4
Joined: Thu Feb 11, 2010 17:59

Re: Cannot update package [Solved]

Postby flameboy » Mon Feb 15, 2010 17:14

Glad it helped you. :D
flameboy
Baby Hen
 
Posts: 4
Joined: Sun Feb 14, 2010 2:01


Return to Entropy|Equo|Rigo Package Managers

Who is online

Users browsing this forum: No registered users and 1 guest

cron