How to install a package with equo, ignoring downgrades?

Anything that pertains to Entropy, Equo or Sulfur

Moderator: Moderators

How to install a package with equo, ignoring downgrades?

Postby colector » Wed Jan 13, 2010 2:55

Hi,
I really enjoy equo, but there's allot of packages in equo's tree, that are a bit older than the same packages in portage.

Whenever I can, I use equo, but sometimes I use portage.
When I update portage, I always perform a "equo database gentoosync".

Unfortunately this does nothing, apparently. =(
For example, I'm trying to install blender using equo, but it asks me to downgrade(?!) kde, gnome, etc.

Well, I wouldn't really like to downgrade these packages, or else why would I install them in the first place?

So, how can I install a package with equo, ignoring downgrades?

ps: there's a similar thread here:
http://forum.sabayonlinux.org/viewtopic ... 76&t=17683
but it apparently provides no solution.
colector
Young Hen
 
Posts: 35
Joined: Wed Aug 06, 2008 5:48

Re: How to install a package with equo, ignoring downgrades?

Postby albfneto » Fri Jan 15, 2010 15:28

the solution is simple....

as root, edit the /etc/entropy/client.conf and in the last line "ignore pseudo-downgrades" modify "disable" to "enable"

Save the file...

see also: http://forum.sabayon.org/viewtopic.php?f=54&t=19554

then, reorganize all your system, making the following commands, IN THE GIVEN ORDER (portage first!):

Code: Select all
su and password
emerge --sync
emerge portage
layman -S
equo update --force
equo upgrade
equo database gentoosync
equo libtest && equo deptest


attention to messages of the system...only if required, properly runs the commands; "etc-update" (or alternatives "dispatch conf" or "etc-proposals") and "equo conf update"....
in "equo conf update" command, attention to NOT OVERWRITE "client.conf"...


For mantain the working system,

attention to NOT USE "emerge entropy equo", but only use "equo install entropy equo"..
in all instance that "revdep-rebuild" command is requested, prefer to use "equo libtest && equo deptest".

never , not carry out (only for experimental purposes, but is difficult to control) emerge with any "world" options, except !"emerge -e world", in Sabayons systems...
ALBERTO FEDERMAN NETO
albfneto
albfneto@fcfrp.usp.br
Favorite Distros: Sabayon, Gentoo, Mageia and OpenSUSE
User avatar
albfneto
Sagely Hen
 
Posts: 1689
Joined: Fri Nov 16, 2007 1:15
Location: Ribeirão Preto City, São Paulo State, Brazil

Re: How to install a package with equo, ignoring downgrades?

Postby colector » Sat Jan 23, 2010 9:02

Hi,
thanks for your help.
Unfortunately the line
equo upgrade

will output
>> Action: Downgrade
>> @@ Packages involved: 357
Which is exactly what I'm trying to avoid... =(
colector
Young Hen
 
Posts: 35
Joined: Wed Aug 06, 2008 5:48

Re: How to install a package with equo, ignoring downgrades?

Postby albfneto » Mon Jan 25, 2010 19:43

you edited the client.conf file?
and run the other commands that i said?
ALBERTO FEDERMAN NETO
albfneto
albfneto@fcfrp.usp.br
Favorite Distros: Sabayon, Gentoo, Mageia and OpenSUSE
User avatar
albfneto
Sagely Hen
 
Posts: 1689
Joined: Fri Nov 16, 2007 1:15
Location: Ribeirão Preto City, São Paulo State, Brazil

Re: How to install a package with equo, ignoring downgrades?

Postby albfneto » Mon Jan 25, 2010 19:47

you may also TEST the equo upgrade, without real install.

you may use for this:

Code: Select all
sudo equo --pretend --verbose upgrade ( the antique equo world is not deprecated)
ALBERTO FEDERMAN NETO
albfneto
albfneto@fcfrp.usp.br
Favorite Distros: Sabayon, Gentoo, Mageia and OpenSUSE
User avatar
albfneto
Sagely Hen
 
Posts: 1689
Joined: Fri Nov 16, 2007 1:15
Location: Ribeirão Preto City, São Paulo State, Brazil

Re: How to install a package with equo, ignoring downgrades?

Postby colector » Thu Jan 28, 2010 15:41

I edited the file and copy pasted the other commands one by one.
Unfortunately it still doesn't work. (I tried it twice)
Shouldn't there be some documentation about this?
As time passes I get more and more packages that "should" be downgraded?!?! wtf?
colector
Young Hen
 
Posts: 35
Joined: Wed Aug 06, 2008 5:48

Re: How to install a package with equo, ignoring downgrades?

Postby colector » Thu Jan 28, 2010 15:44

And does it make sense that an upgrade command to be composed of more than 95% of downgrades???
Hummmm...
colector
Young Hen
 
Posts: 35
Joined: Wed Aug 06, 2008 5:48


Return to Entropy|Equo|Rigo Package Managers

Who is online

Users browsing this forum: No registered users and 1 guest