Updated and now Magneto no longer works [Solved]

Anything that pertains to Entropy, Equo or Sulfur

Moderator: Moderators

Updated and now Magneto no longer works [Solved]

Postby cmost » Mon Nov 23, 2009 0:57

Just a quick heads up: I installed updates over the weekend (Limbo repository enabled) onto my fully up-to-date Sabayon 5.x KDE edition and now Magneto no longer works. There is no Magneto update notifier in the system tray and attempting to start Magneto from the command line yields the following:

[email protected] ~ $ magneto
Traceback (most recent call last):
File "/usr/lib/entropy/magneto/magneto.py", line 34, in <module>
from magneto.kde.interfaces import Magneto
File "/usr/lib64/entropy/magneto/magneto/kde/interfaces.py", line 18, in <module>
from PyKDE4.kdecore import KAboutData, KCmdLineArgs, ki18n
RuntimeError: the sip module implements API v6.0 but the PyKDE4.kdecore module requires API v5.0

Any ideas here? While I can get along quite happily without Magneo (I usually use the command line anyway for updating) it was kind of nice to know when updates were available. Thanks! :D

**** Edit 11/232009 ***
Solved with today's updates!! Great job Sabayon Team!
cmost
Advanced Hen
 
Posts: 208
Joined: Wed Dec 13, 2006 22:25
Location: Cincinnati, OH

Re: Updated and now Magneto no longer works [Solved]

Postby dunsurfin » Mon Nov 30, 2009 16:07

This has re-occurred with today's update from the standard x86 repository. The only tracebacks I have are these:

Application: Magneto (), signal: Segmentation fault
#0 0xffffe430 in __kernel_vsyscall ()
#1 0xb7d43d90 in nanosleep () from /lib/libc.so.6
#2 0xb7d43bc9 in sleep () from /lib/libc.so.6
#3 0xb556eeca in ?? () from /usr/lib/libkdeui.so.5
#4 0x00000001 in ?? ()
#5 0x00000000 in ?? ()

and

[email protected] ~ $ magneto
/usr/lib/python2.6/site-packages/dbus/connection.py:242: DeprecationWarning: object.__init__() takes no parameters
super(Connection, self).__init__(*args, **kwargs)
KCrash: Application '' crashing...
sock_file=/home/robin/.kde4/socket-robin2/kdeinit4__0

The magneto version is 0.99.11.6 on SL 5.00 x86 K fully updated
Self-righteousness is a loud din raised to drown the voice of guilt within us - Eric Hoffer

Don't believe what it says on the right - I am anything but sagely; More oniony!
dunsurfin
Sagely Hen
 
Posts: 1333
Joined: Sun Jan 07, 2007 21:38
Location: Newcastle upon Tyne UK

Re: Updated and now Magneto no longer works [Solved]

Postby dunsurfin » Mon Nov 30, 2009 16:23

Still broken after update to 0.99.11.6~1

Edit: Submitted as issue 1064
Self-righteousness is a loud din raised to drown the voice of guilt within us - Eric Hoffer

Don't believe what it says on the right - I am anything but sagely; More oniony!
dunsurfin
Sagely Hen
 
Posts: 1333
Joined: Sun Jan 07, 2007 21:38
Location: Newcastle upon Tyne UK

Re: Updated and now Magneto no longer works [Solved]

Postby dunsurfin » Mon Nov 30, 2009 23:07

Now fixed with version 0.99.11.7
Self-righteousness is a loud din raised to drown the voice of guilt within us - Eric Hoffer

Don't believe what it says on the right - I am anything but sagely; More oniony!
dunsurfin
Sagely Hen
 
Posts: 1333
Joined: Sun Jan 07, 2007 21:38
Location: Newcastle upon Tyne UK


Return to Entropy|Equo|Rigo Package Managers

Who is online

Users browsing this forum: No registered users and 3 guests