how to upgrade sabayon-mce?

Anything that pertains to Entropy, Equo or Sulfur

Moderator: Moderators

Post Reply
vampirecoffee
Young Hen
Posts: 37
Joined: Tue Oct 13, 2009 21:32
Contact:

how to upgrade sabayon-mce?

Post by vampirecoffee » Fri Oct 30, 2009 0:42

When I try to equo upgrade, this is what happens:

Code: Select all

>>  @@ Calculating dependencies ...
>>  @@ Cannot find needed dependencies:
>>     # Not found: >=x11-apps/xinit-1.0.8-r10
>>       # Probably needed by:
>>         #  [from:sabayonlinux.org] app-misc/sabayon-mce-1.0-r5
>>  @@ Caching complete.


However, the latest version of xinit in entropy is 1.0.8-r8.

Do I have to move to the limbo repository in order for equo upgrade to work?
Sabayon: Thinkpad T61 w/ Core2Duo 2.4 GHz, nVidia Quadro 140M
Other Sabayon: Homebuilt Intel Core2Duo 3.0 GHz, nVidia GeForce 8600

User avatar
albfneto
Sagely Hen
Posts: 1842
Joined: Fri Nov 16, 2007 1:15
Location: Ribeirão Preto City, São Paulo State, Brazil
Contact:

Re: how to upgrade sabayon-mce?

Post by albfneto » Fri Oct 30, 2009 2:16

if i understood, you cam upgrade the lite MCE ?
If this, seems to me that the Lite MCE is very old!
it is in the Branch 3, the sabayon servers, the packages, are now for branch 4 and 5
the Branch 3 packages were deleted, and the lite MCE is no more supported officially.

The Limbo repo is for the future 5.1! if you activate it, the upgrade will be even more difficult!

The only manner to update MCE Sabayon, lite is using only Portage, but is veru difficult, since also the SLOTs mmay be different...

The more easy method, is to backup important data, download the new sabayon five and install it.

or is the package MCE? if this, try install it with no dependencies:

Code: Select all

sudo equo install sabayon-mce
ALBERTO FEDERMAN NETO
albfneto
[email protected]
Favorite Distros: Sabayon, Gentoo, Mageia and OpenSUSE

vampirecoffee
Young Hen
Posts: 37
Joined: Tue Oct 13, 2009 21:32
Contact:

Re: how to upgrade sabayon-mce?

Post by vampirecoffee » Fri Oct 30, 2009 3:49

I'm already using branch 5. I tried

Code: Select all

sudo equo install sabayon-mce


but it gave me the same message about dependencies that were missing.
Sabayon: Thinkpad T61 w/ Core2Duo 2.4 GHz, nVidia Quadro 140M
Other Sabayon: Homebuilt Intel Core2Duo 3.0 GHz, nVidia GeForce 8600

lonesomecrow
Simple Hen
Posts: 58
Joined: Thu Apr 10, 2008 5:16

Re: how to upgrade sabayon-mce?

Post by lonesomecrow » Fri Oct 30, 2009 5:32

Same thing happens here, it's kinda odd! But maybe it will get fixed soon. Maybe Wolfden or someone can help us!

Rev.Dr.SparkiHooker
Baby Hen
Posts: 1
Joined: Fri Oct 30, 2009 0:20

Re: how to upgrade sabayon-mce?

Post by Rev.Dr.SparkiHooker » Fri Oct 30, 2009 6:03

I had the same problem and just removed the sabayon-mce package and have updated fine.

joost
Sagely Hen
Posts: 2669
Joined: Fri Nov 17, 2006 12:11
Location: The Netherlands
Contact:

Re: how to upgrade sabayon-mce?

Post by joost » Fri Oct 30, 2009 9:55

Fixing it now.

Marius
Simple Hen
Posts: 82
Joined: Thu Nov 01, 2007 5:48
Location: Berkeley, California

Re: how to upgrade sabayon-mce?

Post by Marius » Fri Oct 30, 2009 10:08

Same here: equo world results in the following error:

Code: Select all

>>  @@ Calculating dependencies ...
>>  @@ Cannot find needed dependencies:
>>     # Not found: >=x11-apps/xinit-1.0.8-r10
>>       # Probably needed by:
>>         #  [from:sabayonlinux.org] app-misc/sabayon-mce-1.0-r5
>>  @@ Caching complete.


What is the proper way to proceed? I am reluctant to uninstall sabayon-mce-1.0-r5 until somebody confirms that it is harmless.

joost
Sagely Hen
Posts: 2669
Joined: Fri Nov 17, 2006 12:11
Location: The Netherlands
Contact:

Re: how to upgrade sabayon-mce?

Post by joost » Fri Oct 30, 2009 10:10

equo update
and try again.

Marius
Simple Hen
Posts: 82
Joined: Thu Nov 01, 2007 5:48
Location: Berkeley, California

Re: how to upgrade sabayon-mce?

Post by Marius » Fri Oct 30, 2009 10:22

Thank you very much! equo upgrade now proceeds without error.

lonesomecrow
Simple Hen
Posts: 58
Joined: Thu Apr 10, 2008 5:16

Re: how to upgrade sabayon-mce?

Post by lonesomecrow » Fri Oct 30, 2009 19:11

Thanks Joost. We need a thanks button like in other forums, that way we can just click thanks whenever someone helps us.

Post Reply