Updated version of a program in Branch 5 not in 4

Anything that pertains to Entropy, Equo or Sulfur

Moderator: Moderators

Updated version of a program in Branch 5 not in 4

Postby almigi » Fri Jul 24, 2009 17:53

Hello everyone,

I've noticed from going to "www.sabayonlinux.org/packages" that there are a few programs (well, more then a few maybe) in Branch 5 that are more up to date then in Branch 4.

For the sake of example, let's look at Wine. In Branch 4 it's Wine 1.1.23 and in Branch 5 it's Wine 1.1.26. Let's say for example someone who was using Branch 4 wanted a more up to date version of Wine.

What would be the best way to get the more up to date version?

Would it be wise to do a
Code: Select all
equo hop 5
to get the updated program, and then do a
Code: Select all
equo hop 4
to get back to branch 4?

Would it be wise to use portage to get the updated version of Wine? If so, would you need to remove the version of Wine currently installed using entropy, and then install the one from portage to avoid conflicts? If a newer version of Wine appeared in Entropy later on, would you remove the version installed with Portage and reinstall with entropy (if you are using entropy to manage world updates)?

Would it be best to just be patient and wait for the official stable release of branch 5?
almigi
Baby Hen
 
Posts: 13
Joined: Wed May 13, 2009 17:48
Location: Fairview Park, Ohio, USA

Re: Updated version of a program in Branch 5 not in 4

Postby almigi » Fri Jul 24, 2009 18:18

Looks like I didn't read the Wiki well enough before asking this question. However, I still do need some clarification...

It seems that you can download packages yourself from www.sabayonlinux.org and have equo install them that way. Keeping with the Wine example:

1. I download the latest version from branch 5 and store it in /var/lib/entropy/packages/ on my drive.

Then what? Would I issue the normal equo install command, but this time give the full name of the file (in this case "wine-1.1.26~0.tbz2") and this will cause equo to look in the /var/lib/entropy/packages directory automatically?

Does doing a "equo update" cause it to scan that directory automatically for a new version of any file already installed on the system. In which case a "equo update && equo world --ask" would result in the new version being installed (along with other updates it in the repositories)?

Thanks.
almigi
Baby Hen
 
Posts: 13
Joined: Wed May 13, 2009 17:48
Location: Fairview Park, Ohio, USA

Re: Updated version of a program in Branch 5 not in 4

Postby Stupot » Fri Jul 24, 2009 18:42

I would suggest emerging that particular package if you really want it right now.

Also, you should ask yourself how important it really is to update this package right now, instead of waiting until the official release of Branch 5. If it is really important, you should request that the package be added to Branch 4. You should NOT attempt to install a few Branch 5 packages on a Branch 4 system. There are reasons that they are different branches, after all.

As soon as Branch 5 is ready, the dev's will let you know how to update to it (and they'll make it as easy as possible). Until then, everybody needs to fight the mentality that they are not up to date. If an application is working correctly for everything you need it for, then don't worry about it not being completely up to date on branch 4.
Stupot
Sagely Hen
 
Posts: 1518
Joined: Wed Feb 14, 2007 3:44
Location: St. Louis, MO, USA


Return to Entropy|Equo|Rigo Package Managers

Who is online

Users browsing this forum: No registered users and 1 guest