Page 1 of 1

Cannot upgrade portage when upgrading entropy

Posted: Tue Mar 17, 2009 15:46
by javi
Hello all,

I just tried an "equo install entropy" and after downloading all packages and attempting to install the latest portage, I get the following:

Code: Select all

>>  ++ (1/6) >>> dev-lang/python-2.5.4-r2
>>    ## Ebuild: pkg_prerm()
>>    ## Ebuild: pkg_postrm()
 * Linking /usr/bin/python2.5 to /usr/bin/python (relative)
 * Linking /usr/bin/python2.5 to /usr/bin/python2 (relative)
 * Linking /usr/bin/idle2.5 to /usr/bin/idle (relative)
 * Linking /usr/bin/pydoc2.5 to /usr/bin/pydoc (relative)
 * Linking /usr/bin/python-config-2.5 to /usr/bin/python-config (relative)
 * Linking /usr/share/man/man1/python2.5.1.bz2 to /usr/share/man/man1/python.1.bz2 (relative)
 * Cleaning orphaned Python bytecode from /usr/lib/python2.5 ..
>>    ## Unpacking package: dev-lang:python-2.5.4-r2~0.tbz2
>>    ## Ebuild: pkg_preinst()
>>    ## Installing package: dev-lang/python-2.5.4-r2
/usr/bin/equo: line 4:  4036 Bus error               python /usr/lib/entropy/client/equo.py "[email protected]"
Which of course, breaks python. I installed python by simply extracting a copy found in this link:

http://virtb.visibleassets.com:2080/gee ... kages/All/

But no matter how many times I re-try installing python it fails. I also see no way of "injecting" the python package, although I would rather not have to do that since python is an important package. Any suggestions?

Thanks,

javi

Re: Cannot upgrade portage when upgrading entropy

Posted: Tue Mar 17, 2009 16:29
by WarraWarra
This might help.

After update install equo using equo to install itself + spritz
Same steps as with portage that we used to do.
emerge --sync && emerge portage layman

Once you have it updated and latest copy installed you could either --sync or equo update just for fun and then install all other packages.

This way your latest equo with fixes can install portage.

Now if it still fails on python you can try some options in equo say like deptest and libtest to fix broken dependency's then try installing portage again.

By now it has to work or you might have to manually force the re-creation of the tree / database. This sometimes work if something went south during another install that might have corrupted say python.

Check pygtk as well as gcc and install them with full dependency's similar to emerge -D .....

Please note there is a huge difference between "update" and "forced re-install"

equo install package
versus
equo update package
same with emerge
emerge package
versus
emerge -u package

Install = build / install as if it was never there.
Update = renovated with possibly termites and defective foundation of a house or similar in LINUX terms.

Hope this helps.

PS> Running deptest and libtest every once in a while is like taking your car for a service just a good thing to do and sometimes necessary so why not crontab it and you knows she will run fine.

[Solved] Re: Cannot upgrade portage when upgrading entropy

Posted: Wed Mar 18, 2009 5:13
by javi
Whew, very helpful indeed. Thanks for your time! I must admit that since Sabayon is so easy I have not done a lot of reading of the manual.
I tried doing an "equo update python" but that just did a regular "equo update" as far as I am concerned. According to "equo --help" the "update" functionality takes no arguments (other than --force) and is just for updating the repositories, maybe you are mistaken. I then tried to do an "equo deptest", which tried pulling in the new python, which led to the same error. I hypothesized that this is an equo/entropy bug, so I did an "equo install --nodeps equo". This installed equo fine, but when I tried to install python after I got the same error. So I then did an "equo install --nodeps entropy". This went through fine as well. I followed that with an "equo deptest", which installed a couple of packages (but not python, go figure). I then did an "equo install python" and it worked! So I guess entropy was the culprit. I am glad I did not have to mess with portage, since it is one reason I switched to Sabayon :)

Re: Cannot upgrade portage when upgrading entropy

Posted: Wed Mar 18, 2009 15:45
by WarraWarra
Yup the update only has that options.

The difference between update and install = using duck tape / spit and glue to fix something or with install = brand new part so failure is minimized.

Also after --nodep used mostly to bypass problems / blocks remember to run install of the same program that then install it over again + previous excluded deps as --nodeps is just a temp cheat to bypass blockages.

Would be a good idea to do a full install of world now ie:

Code: Select all

# equo install world
This then gets latest of everything and forces past errors or broken anything so you know all is well again and no nasty stuff lies beneath the surface.

Weekly run:

Code: Select all

# equo deptest && equo libtest
or once a month just as good maintenance routine.