Spritz won't install drivers

Anything that pertains to Entropy, Equo or Sulfur

Moderator: Moderators

Big_Dog1968
Baby Hen
Posts: 16
Joined: Thu Feb 21, 2008 8:45

Spritz won't install drivers

Post by Big_Dog1968 » Sun Aug 03, 2008 19:45

I have an ATI HD3850 card on my PC. When I installed Sabayon 3.5, it did not properly install the ATI driver. I had to use the xdriver=vesa switch to get it to install to begin with. Now when I tried to use Spritz, it said I already had the driver installed, but the catalyst controll center says it is not and I have no 3d acceleration so I know it is not working.

I tried to purge the package and then re-install it, but when it asks me to accept the ATI license, it freezes. I click the read and accept button to no avail.

Does Sabayon have an "Envy" like installer like Mint/Ubuntu does that would make this a bit easier? :)

Thanks in advance for the help.

dunsurfin
Sagely Hen
Posts: 1333
Joined: Sun Jan 07, 2007 21:38
Location: Newcastle upon Tyne UK
Contact:

Re: Spritz won't install drivers

Post by dunsurfin » Sun Aug 03, 2008 21:17

Big_Dog1968 wrote: I tried to purge the package and then re-install it, but when it asks me to accept the ATI license, it freezes. I click the read and accept button to no avail.
The read and accept button can be a bit confusing. You need to highlight the package category, not the exact package itself, before you can click the accept button. Is that the problem?
Self-righteousness is a loud din raised to drown the voice of guilt within us - Eric Hoffer

Don't believe what it says on the right - I am anything but sagely; More oniony!

Big_Dog1968
Baby Hen
Posts: 16
Joined: Thu Feb 21, 2008 8:45

Re: Spritz won't install drivers

Post by Big_Dog1968 » Sun Aug 03, 2008 21:46

I believe I tried all the combos, but I will try again and pay attention to what you said to see if makes a difference. Thanks.

dunsurfin
Sagely Hen
Posts: 1333
Joined: Sun Jan 07, 2007 21:38
Location: Newcastle upon Tyne UK
Contact:

Re: Spritz won't install drivers

Post by dunsurfin » Sun Aug 03, 2008 21:59

Otherwise use the command line and, as root, "equo" "install" "package name"
Self-righteousness is a loud din raised to drown the voice of guilt within us - Eric Hoffer

Don't believe what it says on the right - I am anything but sagely; More oniony!

Big_Dog1968
Baby Hen
Posts: 16
Joined: Thu Feb 21, 2008 8:45

Re: Spritz won't install drivers

Post by Big_Dog1968 » Mon Aug 04, 2008 0:43

The installer worked (thanks for the suggestion), and installed the driver. Even though it didn't tell me to, I rebooted after it completed (seems you always have to when you install ATI drivers in Mint). When the login screen came up, I went to the acceleration manager and it said the driver is not working. It properly detected my card though.

Is there an easy way to make Sabayon work with ATI? Are there known issues regarding ATI drivers? I am brand new to this distro and very new to Linux so I don't know how to solve my problems without help yet.


Big_Dog1968
Baby Hen
Posts: 16
Joined: Thu Feb 21, 2008 8:45

Re: Spritz won't install drivers

Post by Big_Dog1968 » Mon Aug 04, 2008 1:17

I looked at all three. The instructions are way beyond my knowledge level. I have the patience to try, but I can't even get past the first step in the Sabayon link's instructions (starting after the kernel upgrade since I likely have the latest).

It wants me to "eix xorg". Tried to copy and paste that into a terminal, which returned something like "no such command".

Is there anything that you know of that easier to be done (by a noob)? I am not sure if this is useful info but the Spritz installs the driver (version8.5).

Stupot
Sagely Hen
Posts: 1746
Joined: Wed Feb 14, 2007 3:44
Location: St. Louis, MO, USA

Re: Spritz won't install drivers

Post by Stupot » Mon Aug 04, 2008 1:20

You don't have eix installed. Do a "equo install eix" or "emerge eix" if that doesn't work.

Big_Dog1968
Baby Hen
Posts: 16
Joined: Thu Feb 21, 2008 8:45

Re: Spritz won't install drivers

Post by Big_Dog1968 » Mon Aug 04, 2008 2:52

Stupot wrote:You don't have eix installed. Do a "equo install eix" or "emerge eix" if that doesn't work.
Thanks it is installed.

The guide wants me to look an entry like this:
x11-base/xorg-x11
Available versions: 7.2 (~)7.3
Installed versions: 7.2(02:39:00 PM 10/28/2007)
Homepage: http://xorg.freedesktop.org
Description: An X11 implementation maintained by the X.Org Foundation (meta package)


When I run the that entry does not exist. All I got was the following:
localhost daddy # eix xorg
x11-base/xorg-server [1]
Available versions: (~)1.4.2 {3dfx dmx dri hal input_devices_acecad input_devices_aiptek input_devices_calcomp input_devices_citron input_devices_digitaledge input_devices_dmc input_devices_dynapro input_devices_elo2300 input_devices_elographics input_devices_evdev input_devices_fpit input_devices_hyperpen input_devices_jamstudio input_devices_joystick input_devices_keyboard input_devices_magellan input_devices_microtouch input_devices_mouse input_devices_mutouch input_devices_palmax input_devices_penmount input_devices_spaceorb input_devices_summa input_devices_synaptics input_devices_tek4957 input_devices_ur98 input_devices_vmmouse input_devices_void input_devices_wacom ipv6 kdrive minimal nptl sdl video_cards_apm video_cards_ark video_cards_chips video_cards_cirrus video_cards_cyrix video_cards_dummy video_cards_epson video_cards_fbdev video_cards_fglrx video_cards_geode video_cards_glint video_cards_i128 video_cards_i740 video_cards_i810 video_cards_impact video_cards_imstt video_cards_mach64 video_cards_mga video_cards_neomagic video_cards_newport video_cards_nsc video_cards_nv video_cards_nvidia video_cards_r128 video_cards_radeon video_cards_rendition video_cards_s3 video_cards_s3virge video_cards_savage video_cards_siliconmotion video_cards_sis video_cards_sisusb video_cards_sunbw2 video_cards_suncg14 video_cards_suncg3 video_cards_suncg6 video_cards_sunffb video_cards_sunleo video_cards_suntcx video_cards_tdfx video_cards_tga video_cards_trident video_cards_tseng video_cards_v4l video_cards_vermilion video_cards_vesa video_cards_vga video_cards_via video_cards_vmware video_cards_voodoo video_cards_xgi xorg xprint}
Installed versions: 1.4.2(03:25:10 AM 08/03/2008)(3dfx dri hal input_devices_evdev input_devices_keyboard input_devices_mouse input_devices_void sdl video_cards_dummy video_cards_fbdev video_cards_vesa video_cards_vga xorg xprint -debug -dmx -input_devices_acecad -input_devices_aiptek -input_devices_calcomp -input_devices_citron -input_devices_digitaledge -input_devices_dmc -input_devices_dynapro -input_devices_elo2300 -input_devices_elographics -input_devices_fpit -input_devices_hyperpen -input_devices_jamstudio -input_devices_joystick -input_devices_magellan -input_devices_microtouch -input_devices_mutouch -input_devices_palmax -input_devices_penmount -input_devices_spaceorb -input_devices_summa -input_devices_synaptics -input_devices_tek4957 -input_devices_ur98 -input_devices_vmmouse -input_devices_wacom -ipv6 -kdrive -minimal -nptl -video_cards_apm -video_cards_ark -video_cards_chips -video_cards_cirrus -video_cards_cyrix -video_cards_epson -video_cards_fglrx -video_cards_geode -video_cards_glint -video_cards_i128 -video_cards_i740 -video_cards_i810 -video_cards_impact -video_cards_imstt -video_cards_mach64 -video_cards_mga -video_cards_neomagic -video_cards_newport -video_cards_nsc -video_cards_nv -video_cards_nvidia -video_cards_r128 -video_cards_radeon -video_cards_rendition -video_cards_s3 -video_cards_s3virge -video_cards_savage -video_cards_siliconmotion -video_cards_sis -video_cards_sisusb -video_cards_sunbw2 -video_cards_suncg14 -video_cards_suncg3 -video_cards_suncg6 -video_cards_sunffb -video_cards_sunleo -video_cards_suntcx -video_cards_tdfx -video_cards_tga -video_cards_trident -video_cards_tseng -video_cards_v4l -video_cards_vermilion -video_cards_via -video_cards_vmware -video_cards_voodoo -video_cards_xgi)
Description: X.Org X servers

[1] "sabayon" /usr/portage/local/layman/sabayon

wolfden
Sharecropper
Posts: 9051
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA
Contact:

Re: Spritz won't install drivers

Post by wolfden » Mon Aug 04, 2008 3:53

x11-base/xorg-x11 not x11-base/xorg-server

It doesn't matter as that is irrelevant as 7.2 is old now and if you look at http://www.sabayonlinux.org/sabayon/pkg ... 86-3.5.txt you will see:
x11-base/xorg-x11-7.3

so your version is newer and should be fine

You got to be able to think out side of the box when using linux. The wikis are great, but you have to use what is relevant and keep on moving. If you get stuck, always turn towards the official documentation to help.

You really should spend some time getting to know the package managers before using them. Our wiki explains using entropy and portage. Another thing you are gonna want to look at is the gentoo handbook located on gentoo.org. It goes through the entire operating system and very well documented. Gentoo itself is very well documented and all the user has to do is take some time and read through them. I say this as you are very new and it will benefit you greatly and save you a lot of time posting and waiting for a reply. This distro isn't the easiest for people new to it, not "newb" friendly, but highly learnable. ATI issues with linux go back a long ways, but has improved.

Using a gentoo based distro will teach more about linux and hardware than any other distro.

Post Reply