dev-python/notebook-5.2.1 incompatible with www-servers/tornado-5.1

Discussions Regarding Software

Moderator: Moderators

Post Reply
welele
Baby Hen
Posts: 12
Joined: Sat Mar 31, 2018 15:01

dev-python/notebook-5.2.1 incompatible with www-servers/tornado-5.1

Post by welele » Sat Feb 01, 2020 15:30

notebook-5.2.1 is broken since 2019-12-31 and update of www-servers/tornado-5.1

jupyter-notebook fail with :
TypeError: __init__() got an unexpected keyword argument 'io_loop'

This is a incompatibility between version, as stated in : https://github.com/jupyter/help/issues/324

Notebook is compatible with tornado-5.x since version 5.5.0, as stated in :
https://github.com/jupyter/notebook/blo ... ngelog.rst

Way to reproduice :
A a fresh system, install notebook with "equo i dev-python/notebook" and launch with "jupyter-notebook". Then launch a new kernel with "new" button top right.
Connection to the ipython-kernel is never established and terminal will print error message.

Way to solve : upgrade to notebook-5.7.8 or either downgrade to tornado-4.4.2-r1
emerge notebook-5.7.8 solved the issue for me and seems a longer-term solution.

Filled a bug today, but previous bug filled were never read... So i post here too.

joost
Sagely Hen
Posts: 2817
Joined: Fri Nov 17, 2006 12:11
Location: The Netherlands
Contact:

Re: dev-python/notebook-5.2.1 incompatible with www-servers/tornado-5.1

Post by joost » Sat Feb 01, 2020 21:32

should be fixed soon. I closed your bug.
My blog | Mastodon | Please support Sabayon: Become a Patron

Post Reply