what can i do if i see an outdated package?

Discussions Regarding Software

Moderator: Moderators

Post Reply
User avatar
Alexander88207
Simple Hen
Posts: 46
Joined: Tue Dec 11, 2018 19:10
Location: Germany

what can i do if i see an outdated package?

Post by Alexander88207 » Sat Jan 19, 2019 17:28

Hello

what can i do if i see an outdated packages?

- Report it somewhere if yes then where?
How to create a sabayon uefi usb device: https://github.com/linuxerus/sabayon-st ... -device.md

User avatar
albfneto
Sagely Hen
Posts: 1910
Joined: Fri Nov 16, 2007 1:15
Location: Ribeirão Preto City, São Paulo State, Brazil
Contact:

Re: what can i do if i see an outdated package?

Post by albfneto » Sat Jan 19, 2019 23:34

Generally, Sabayon is Rolling Release. It upgrade all...
Ocasionally, if the system needs, the Sabayon itself make an "outdated" package...

Is you tried to working with one package thar you dont want to upgrade? Is this or your system had mixed old and new packages?
If this is the case:

You mixed Entropy with Portage? You need to edit /etc/entropy/client.conf and in the line "ignore pseudodowngrades" you need change "disable" to "enable".
ALBERTO FEDERMAN NETO
albfneto
[email protected]
Favorite Distros: Sabayon, Gentoo, Mageia and OpenSUSE

User avatar
Alexander88207
Simple Hen
Posts: 46
Joined: Tue Dec 11, 2018 19:10
Location: Germany

Re: what can i do if i see an outdated package?

Post by Alexander88207 » Sat Jan 19, 2019 23:42

No i always use entropy i mean outdated like this for example:


Image
Image
How to create a sabayon uefi usb device: https://github.com/linuxerus/sabayon-st ... -device.md

User avatar
albfneto
Sagely Hen
Posts: 1910
Joined: Fri Nov 16, 2007 1:15
Location: Ribeirão Preto City, São Paulo State, Brazil
Contact:

Re: what can i do if i see an outdated package?

Post by albfneto » Mon Jan 21, 2019 18:33

The version 1.1.92.1, is the version in the Gentoo database:

https://packages.gentoo.org/packages/me ... kan-loader

It is not in Entropy, because the Sabayon team not "made" the package for Sabayon. Because the "source" of Sabayon packages is ther Gentoo packages,

also, the packages marked "9999" are masked, because they are in testing....

If you want that the team Sabayon upgrade a package for Sabayon users, you may use the session of "package request" in the Sabayon Bugzilla. Acess:

https://bugs.sabayon.org

make a Login for you, Log in the Bugzilla, Choose "new bug", "Entropy", "Request".
ALBERTO FEDERMAN NETO
albfneto
[email protected]
Favorite Distros: Sabayon, Gentoo, Mageia and OpenSUSE

Fitzcarraldo
Sagely Hen
Posts: 8195
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom
Contact:

Re: what can i do if i see an outdated package?

Post by Fitzcarraldo » Thu Jan 24, 2019 11:44

Or wait a week for the next update to the Sabayon Weekly Entropy repository to see if the latest version of the desired package has been built for Entropy:

https://packages.sabayon.org/quicksearc ... kan-loader
Results found: 2 (0.0271 seconds)
Architecture: All amd64 armv7l
View: default compact
package icon
Star rating 1 Star rating 2 Star rating 3 Star rating 4 Star rating 5
65 downloads
media-libs/vulkan-loader-1.1.92.1
Vulkan Installable Client Driver (ICD) Loader
binary → standard → sabayon-weekly → amd64 → 5 | revision: 0 | date: 2019-01-23
Show package details Details Visit package homepage Homepage Show package dependencies Dependencies Show user-generated content Comments and Documents
package icon
Star rating 1 Star rating 2 Star rating 3 Star rating 4 Star rating 5
65 downloads
media-libs/vulkan-loader-1.1.92.1
Vulkan Installable Client Driver (ICD) Loader
binary → standard → sabayonlinux.org → amd64 → 5 | revision: 0 | date: 2019-01-23
Show package details Details Visit package homepage Homepage Show package dependencies Dependencies Show user-generated content Comments and Documents

Post Reply