Page 1 of 1

Blender startup failure

Posted: Thu Nov 01, 2018 2:23
by stratokaztr
With NVIDIA 410.57, Blender locked up with a black page on startup. Solved by using eselect opencl set ocl-icd instead of nvidia.

Re: Blender startup failure

Posted: Thu Nov 01, 2018 10:26
by sabayonino
I think Blender must be recompiled with "opencl" useflag .

Code: Select all

# equo q installed blender -v

Code: Select all

[...]
USE flag:         -colorio -cuda -debug -headless 
╠                            -jemalloc -libav -llvm -man -ndof 
╠                            -opencl 
[...]
USE flag description :
opencl : Allow OpenCL Graphics Acceleration. This may require extra graphics card drivers.
You can file a bug/request
https://bugs.sabayon.org/

Re: Blender startup failure

Posted: Fri Nov 02, 2018 11:11
by joost
I think Blender must be recompiled with "opencl" useflag .
You think this and then tell somebody, who doesn't have a problem at all but just shared a solution, to open a bug?

:|

Re: Blender startup failure

Posted: Fri Nov 02, 2018 12:55
by sabayonino
His "solution" solved the lock 'cause nvidia opencl implementation is not installed (useflag required) but the performance could be bad or not work.
Ocl-icd may not work for some Nvidia cards and blender could not run opencl properly.
if stratok. Doesn't care about OpenCL then this is another story..