Page 1 of 1

Can't switch to Cinnamon?

Posted: Tue Jan 23, 2018 0:39
by Idinix
I haven't used Sabayon in a while. I remembered how to install it. I installed Cinnamon and all dependencies via terminal. Logged off, selected Cinnamon, and I can not boot to Cinnamon.

I tried another time with the Cinnamon software rendering option, and still can't start Cinnamon. Either option just takes me to the MATE desktop.

I am using Sabayon 16.11 MATE edition. I figured I would just be able to install Cinnamon and use it later. I have already completed the update and upgrade process before everything else, of course.

What am I missing?

Re: Can't switch to Cinnamon?

Posted: Wed Jan 24, 2018 1:46
by Idinix
Adding a little detail, it looks like the right Cinnamon login menu shows, but it goes straight to MATE without skipping a beat when I actually enter my password.

Will I need to switch to LightDM or something? I don't know that it would cause issues but idk why else it's not going to Cinnamon.

Re: Can't switch to Cinnamon?

Posted: Wed Jan 24, 2018 4:15
by gentmixer
Hi...
The lightdm is frequently used desktop manager in Cinnamon at this moment (not only in LightDM desktop) so maybe will work better... What is your manager actually? (The "mdm" is obsolete now and blocks the lightdm manager). Check your managers once more and choose appropriate one. Check lightdm.conf and lightdm.conf.d files in /etc and files in /usr/share and default session in /usr/share/xsession... The Cinnamon is prefered desktop in Ubuntu, so you should read Ubuntu Wiki also... Sorry, I'm not using Mate or Cinnamon or lightdm at all, so no detailed advices...

Re: Can't switch to Cinnamon?

Posted: Wed Jan 24, 2018 5:23
by Idinix
Well, a quick check and apparently I am using LightDM already (I thought MDM was default with Mate desktops). I ran equo i lightdm assuming it would give me the option to switch. It downloaded some packages but no options and apparently I am already using it ???

Image

I've literally never used MATE so I'm kinda lost with this one.

I have tried searching and so far nothing that corrects my issue. :(