vim +lua

Discussions Regarding Software

Moderator: Moderators

Post Reply
abadonna
Young Hen
Posts: 24
Joined: Mon Jun 21, 2010 5:49

vim +lua

Post by abadonna » Thu Sep 24, 2015 3:10

Can we have vim with lua support in repos?

spylinux
Baby Hen
Posts: 5
Joined: Tue Oct 27, 2015 22:57

Re: vim +lua

Post by spylinux » Tue Oct 27, 2015 23:21

I try to install Vim with lua support, using this method:

Install lua and luajit, after, i try, like in calculate or funtoo:

Code: Select all

$ sudo USE="lua" emerge vim
But sabayon tell me about some masked lines...and i can't unmask this lines, related to ruby, rake and some libs.
In gentoo, funtoo and calculate i can install just using the USE="lua", but in sabayon i have problems.

If any can help us, its great!
Sorry about my bad english, in brazilian!

Best regards
spylinux

spylinux
Baby Hen
Posts: 5
Joined: Tue Oct 27, 2015 22:57

Re: vim +lua

Post by spylinux » Tue Oct 27, 2015 23:23

i see in Zugaina site, some gentoo overlays, vim with Lua support, but i don't know how can i add this overlay and install this especific Vim.

Zugaina Vim

joost
Sagely Hen
Posts: 2818
Joined: Fri Nov 17, 2006 12:11
Location: The Netherlands
Contact:

Re: vim +lua

Post by joost » Wed Oct 28, 2015 8:19

Will be in Entropy soon.
https://github.com/Sabayon/build/commit ... c72e690982

Next time file a bug.
My blog | Mastodon | Please support Sabayon: Become a Patron

spylinux
Baby Hen
Posts: 5
Joined: Tue Oct 27, 2015 22:57

Re: vim +lua

Post by spylinux » Wed Oct 28, 2015 16:32

joost wrote:Will be in Entropy soon.
https://github.com/Sabayon/build/commit ... c72e690982

Next time file a bug.
Thanks for your help @joost, and sorry about don't create a bug report, next time i will.

Best regards
spylinux

Post Reply