Scribus: Can't change language [Solved]

Discussions Regarding Software

Moderator: Moderators

Scribus: Can't change language [Solved]

Postby linuxfluesterer » Tue Aug 19, 2014 16:40

Hallo guys.
I've installed Scribus from Sabayon repo for my KDE 4.13 with Kernel 3.15.6. So fine, so good. I can launch it, but in 'File, Preferences, General' there is only an empty field and 'English' possible to select. How can I add another language (German)? There is no button to add a language in the settings.
I've also tried to do this (as user):
Code: Select all
scribus -l de-DE
It didn't help also. Scribus is still in English. I've read before, it would read the locale settings and then use it. But my locale is de-DE.

Any idea? Thank you in advance.

-Linuxfluesterer (I love KDE ...)
Last edited by linuxfluesterer on Wed Aug 27, 2014 21:47, edited 2 times in total.
I really hope, that by the Brexit (poor Britain), TTIP will be finally prevented. But don't get tired to talk to your local politician to open eyes for danger to democracy because of TTIP
User avatar
linuxfluesterer
Old Dear Hen
 
Posts: 702
Joined: Thu Sep 20, 2012 19:47
Location: Germany

Re: Scribus: Can't change language

Postby albfneto » Sat Aug 23, 2014 18:28

certain that your version of Scribus is translated?
My installation is also in English, i live in Brasil.
I dont find translation to Brazilian Portuguese.
ALBERTO FEDERMAN NETO
albfneto
[email protected]
Favorite Distros: Sabayon, Gentoo, Mageia and OpenSUSE
User avatar
albfneto
Sagely Hen
 
Posts: 1705
Joined: Fri Nov 16, 2007 1:15
Location: Ribeirão Preto City, São Paulo State, Brazil

Re: Scribus: Can't change language

Postby linuxfluesterer » Mon Aug 25, 2014 12:05

Yes, Alberto, there is, but it seems not be available in Sabayon. The problem is the language translation. I've found on some websites, that there are multiple language versions, for linux also.
So, I've downloaded this
http://www.computerbase.de/downloads/foto-und-grafik/scribus/72491/?download&gcs=1&uniqueid=ead3c8783e1d29ca99a0432ab3a1eb7c
by a link from a German website. It is a source code, you need to build it yourself with
-Download
-Unpack
-change to unpack directory
-execute cmake
-execute make
-execute make install (as root)
As long you don't execute make install nothing will affect your system. In my case, everything necessary (gcc, libs, python and so on) I had intalled in earlier times, so that the process of creating scribus 1.4.4 with language support was finally successful. And I've checked, Brazilian Portuguese is offered also.
The only thing is, you should deinstall your actual scribus (with Rigo) after backup your work data. Oh, and the new executable 'scribus' is in subdirectory scribus of your target unpacking directory, provided you won't receive errors.
I know, that is not conform to Rigo, equo or Sabyon at all, but for this case it may help you. And, without extra adoption, 'scribus' is not in your execute path (you can copy it) and there is no default symbol for 'scribus' when you search in 'Kicker' or 'Start-Menu'. But it's easy to do. You can launch 'scribus' from console as user.

-Linuxfluesterer (I love KDE ...)
I really hope, that by the Brexit (poor Britain), TTIP will be finally prevented. But don't get tired to talk to your local politician to open eyes for danger to democracy because of TTIP
User avatar
linuxfluesterer
Old Dear Hen
 
Posts: 702
Joined: Thu Sep 20, 2012 19:47
Location: Germany

Re: Scribus: Can't change language [somehow Solved]

Postby Fitzcarraldo » Mon Aug 25, 2014 16:30

Easier to use Portage, which has the appropriate language flags. See, for example, the Calculate Linux Forums thread [SOLVED]Scribus where a user wanted Scribus to be localised in Italian (Calculate Linux is pre-canned Gentoo). Given that albfneto has mentioned previously that he uses Portage as well as Entropy, he would just need to disable all the unwanted LINGUAS flags and just enable the Brazilian Portuguese LINGUAS flag like so:

Code: Select all
# LINGUAS="-af -ar -bg -br -ca -cs_CZ -cy -da_DK -de -de_1901 -de_CH -el -en_AU -en_GB -en_US -es_ES -et -eu -fi -fr -gl -hu -id -it -ja -ko -lt_LT -nb_NO -nl -pl_PL -pt pt_BR -ru -sa -sk_SK -sl -sq -sr -sv -th_TH -tr -uk -zh_CN -zh_TW" emerge scribus

or, alternatively,

Code: Select all
# USE="-linguas_af -linguas_ar -linguas_bg -linguas_br -linguas_ca -linguas_cs_CZ -linguas_cy -linguas_da_DK -linguas_de -linguas_de_1901 -linguas_de_CH -linguas_el -linguas_en_AU -linguas_en_GB -linguas_en_US -linguas_es_ES -linguas_et -linguas_eu -linguas_fi -linguas_fr -linguas_gl -linguas_hu -linguas_id -linguas_it -linguas_ja -linguas_ko -linguas_lt_LT -linguas_nb_NO -linguas_nl -linguas_pl_PL -linguas_pt linguas_pt_BR -linguas_ru -linguas_sa -linguas_sk_SK -linguas_sl -linguas_sq -linguas_sr -linguas_sv -linguas_th_TH -linguas_tr -linguas_uk -linguas_zh_CN -linguas_zh_TW" emerge scribus
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7981
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: Scribus: Can't change language [somehow Solved]

Postby albfneto » Mon Aug 25, 2014 21:41

Is there another simplified way,

you may recompile scribus with portage, direct in German language:

1) edit the file: /etc/entropy/client.conf in the line called "ignore spmdowngrades", change from "disable" to "enable". If you plain to use Portage and Entropy, keep the line "edited".

2) After, you should upgrade Portage's database:

Code: Select all
# emerge --sync


If you is begginer in Portage, i suggest not upgrade the portage's package (NOT execute "emerge --oneshot portage").

3) Locate and try to install the latest Scribus version, direct compiling it in German:

Code: Select all
# LINGUAS="de" emerge -av app-office/scribus


4) If well compiled, and installed, working, please execute this command:

Code: Select all
# equo rescue spmsync
ALBERTO FEDERMAN NETO
albfneto
[email protected]
Favorite Distros: Sabayon, Gentoo, Mageia and OpenSUSE
User avatar
albfneto
Sagely Hen
 
Posts: 1705
Joined: Fri Nov 16, 2007 1:15
Location: Ribeirão Preto City, São Paulo State, Brazil

Re: Scribus: Can't change language [somehow Solved]

Postby albfneto » Mon Aug 25, 2014 21:56

Two other things:

I tried the above procedure, compiling with "LINGUAS" variable, bu instead or German ("de) i used Brazilian Portoguese ("pt_BR") . it worked for me. My Scribus is now in Brazilian Portoguese.

I have in mind that this will work for you, with German.

Other Thing, since Scribus is an important package, i suggest to the Team, in the Bugzilla, to recompile Scribus with full language support:

https://bugs.sabayon.org/show_bug.cgi?id=4153
ALBERTO FEDERMAN NETO
albfneto
[email protected]
Favorite Distros: Sabayon, Gentoo, Mageia and OpenSUSE
User avatar
albfneto
Sagely Hen
 
Posts: 1705
Joined: Fri Nov 16, 2007 1:15
Location: Ribeirão Preto City, São Paulo State, Brazil

Re: Scribus: Can't change language [Solved]

Postby linuxfluesterer » Wed Aug 27, 2014 21:54

Thank you both, Alberto and especially you, Fitz. The solution is often found in portage.
I have followed your solution, exactly to learn more about portage.
I have a German language supported version of scribus installed now. I close this thread as 'Solved'...

-Linuxfluesterer (I love KDE ...)
I really hope, that by the Brexit (poor Britain), TTIP will be finally prevented. But don't get tired to talk to your local politician to open eyes for danger to democracy because of TTIP
User avatar
linuxfluesterer
Old Dear Hen
 
Posts: 702
Joined: Thu Sep 20, 2012 19:47
Location: Germany

Re: Scribus: Can't change language [Solved]

Postby albfneto » Thu Aug 28, 2014 19:27

I advise to the user, in order to mask the Scribus package:

Code: Select all
# equo mask scribus


Because new Scribus version is in the Limbo ,Entropy repository, bu only in English.

If you upgrade Scribus, it will return to a version only in English
ALBERTO FEDERMAN NETO
albfneto
[email protected]
Favorite Distros: Sabayon, Gentoo, Mageia and OpenSUSE
User avatar
albfneto
Sagely Hen
 
Posts: 1705
Joined: Fri Nov 16, 2007 1:15
Location: Ribeirão Preto City, São Paulo State, Brazil

Re: Scribus: Can't change language [Solved]

Postby linuxfluesterer » Thu Aug 28, 2014 20:08

You are right, masking will stop upgrading
Code: Select all
# equo mask scribus

Hopefully, scribus will be offered in multi language soon, due that you have posted a bug in your post before...

-Linuxfluesterer (I love KDE ...)
I really hope, that by the Brexit (poor Britain), TTIP will be finally prevented. But don't get tired to talk to your local politician to open eyes for danger to democracy because of TTIP
User avatar
linuxfluesterer
Old Dear Hen
 
Posts: 702
Joined: Thu Sep 20, 2012 19:47
Location: Germany


Return to Software in General

Who is online

Users browsing this forum: No registered users and 5 guests

cron