Machine always running process's...? [Solved]

Discussions Regarding Software

Moderator: Moderators

Post Reply
greendave8
Growing Hen
Posts: 152
Joined: Thu Aug 02, 2007 12:23

Machine always running process's...? [Solved]

Post by greendave8 » Sun Jun 22, 2014 9:39

Hi All,

Recently my machine has developed a habit of running unknown (to me) processes....
This means the temperature rises up to 70-80 degrees, sometimes higher. The machine gets noisier....

If I use htop to identify which process is using the resources, inevitabley it is someting I dont understand. This morning the PID is 19565, which is command "biof --root", running 99% of cpu... so try to kill it, with command "kill 19565", nothing happens.... This is driving me crazy....



I have all the latest updates, kernel 3.14.6 installed, kde 4.13. This issue has been happening for the last couple of months on and off, depending on the Saturday nigh updates....

Hellp

dave :oops: :oops: :oops: :cry:
Last edited by greendave8 on Sat Jun 28, 2014 13:26, edited 3 times in total.

greendave8
Growing Hen
Posts: 152
Joined: Thu Aug 02, 2007 12:23

Re: Machine always running process's...?

Post by greendave8 » Sun Jun 22, 2014 10:10

I just updated kernel to 3.15.... I'll see if anything changes....

gd8 :?

User avatar
sabayonino
Sagely Hen
Posts: 3539
Joined: Sun Sep 21, 2008 1:12
Location: Italy
Contact:

Re: Machine always running process's...?

Post by sabayonino » Sun Jun 22, 2014 11:40

Hi ...

kernel issue ? :!:

"biof" is a part of rss-glx (and xscreensaver)

Code: Select all

equo s rss-glx
╠  @@ Cercando...
╠      @@ Pacchetto: x11-misc/rss-glx-0.9.1 branch: 5, [sabayon-weekly] 
╠          Disponibile:   versione: 0.9.1 ~ tag: NoTag ~ revisione: 9
╠          Installato:    versione: Non installato ~ tag: n/d ~ revisione: n/d
╠          Slot:          0
╠          Homepage:      http://rss-glx.sourceforge.net 
╠          Descrizione:   Really Slick OpenGL Screensavers 
╠                         for XScreenSaver 
╠          Licenza:       GPL-2
╠   Keyword:  rss-glx
╠   Trovati:  1 voce
see https://packages.sabayon.org/show/rss-g ... -show-what
/usr/share/man
/usr/share/man/man1
/usr/share/man/man1/biof.1.bz2

greendave8
Growing Hen
Posts: 152
Joined: Thu Aug 02, 2007 12:23

Re: Machine always running process's...?

Post by greendave8 » Mon Jun 23, 2014 20:33

Yes it seems related to Xscreensaver...

I have nVidia driver 337.25 loaded for the 3.15 Kernel, every few hours this process starts, and ramps up the fans and noise on the computer. My laptop does not suffer this, and the desktop machine has only recently started doing it. I thought it was kernel related, but not sure now.....

Any thought on what to look at, would be appreciated....

gd8

Fitzcarraldo
Sagely Hen
Posts: 8218
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom
Contact:

Re: Machine always running process's...?

Post by Fitzcarraldo » Tue Jun 24, 2014 14:08

Try uninstalling rss-glx and/or xscreensaver?

greendave8
Growing Hen
Posts: 152
Joined: Thu Aug 02, 2007 12:23

Re: Machine always running process's...?

Post by greendave8 » Sat Jun 28, 2014 13:25

OK, I think this is now solved (still checking it out as I have been away for a few days....)

I uninstalled rss-glx and/or xscreensaver, and then re-installed them..... seems ok so far....

gd8

Post Reply