Amuleadu don't start, again. [Solved]

Discussions Regarding Software

Moderator: Moderators

Amuleadu don't start, again. [Solved]

Postby Burno Sauri » Tue Jun 17, 2014 8:34

Once installed amuleadu, the problem returns, just like the previous times:
[email protected] ~ $ amuleadu
amuleadu: error while loading shared libraries: libbfd-2.22.so: cannot open shared object file: No such file or directory
[email protected] ~ $

There is no way to have the amule for fastweb users, in the Sabayon distro?
Hope you can help!
Thanks
Last edited by Burno Sauri on Sun Jul 06, 2014 0:17, edited 1 time in total.
Burno Sauri
Simple Hen
 
Posts: 80
Joined: Sat Sep 24, 2011 18:09

Re: Amuleadu don't start, again.

Postby albfneto » Wed Jun 18, 2014 15:03

questo problema e colegatto a binutils. quale versione di binutils il tuo sistema aveva?

Code: Select all
equo s binutils
ALBERTO FEDERMAN NETO
albfneto
[email protected]
Favorite Distros: Sabayon, Gentoo, Mageia and OpenSUSE
User avatar
albfneto
Sagely Hen
 
Posts: 1725
Joined: Fri Nov 16, 2007 1:15
Location: Ribeirão Preto City, São Paulo State, Brazil

Re: Amuleadu don't start, again.

Postby sabayonino » Wed Jun 18, 2014 16:29

Hi burno

as you can see, amuleadu is in Entropy from May 2012

and Binutils-2.23 from July 2013.

Amuleadu must be recompiled with new binutils (2.23) to update libbfd symlink.

please file a bug
User avatar
sabayonino
Sagely Hen
 
Posts: 2584
Joined: Sun Sep 21, 2008 1:12
Location: Italy

Re: Amuleadu don't start, again.

Postby Burno Sauri » Wed Jun 18, 2014 20:43

Dear friends,
this my condition after this command :
[email protected] ~ $ su -
Password:
sabayon ~ # equo s binutils
╠ @@ Cercando...
╠ @@ Pacchetto: sys-devel/binutils-2.23.1 branch: 5, [sabayonlinux.org]
╠ Disponibile: versione: 2.23.1 ~ tag: NoTag ~ revisione: 0
╠ Installato: versione: 2.23.1 ~ tag: NoTag ~ revisione: 0
╠ Slot: 0
╠ Homepage: http://sourceware.org/binutils/
╠ Descrizione: Tools necessary to build programs
╠ Licenza: GPL-3 LGPL-3
╠ @@ Pacchetto: sys-devel/binutils-config-3-r3 branch: 5, [sabayonlinux.org]
╠ Disponibile: versione: 3-r3 ~ tag: NoTag ~ revisione: 2
╠ Installato: versione: 3-r3 ~ tag: NoTag ~ revisione: 2
╠ Slot: 0
╠ Homepage: http://www.gentoo.org/
╠ Descrizione: Utility to change the binutils
╠ version being used
╠ Licenza: GPL-2
╠ Keyword: binutils
╠ Trovati: 2 voci
sabayon ~ #

I have installed the old version of the "binutils".
I have updated the portage tree..
How I can install amuleadu?
There is a "step by step" guide to install it?
Thanks at all of you!
Burno Sauri
Simple Hen
 
Posts: 80
Joined: Sat Sep 24, 2011 18:09

Re: Amuleadu don't start, again.

Postby albfneto » Wed Jun 18, 2014 23:22

You have the latest binutils installed, 2.23.

is there somewhat different manners (small variations) to compíle with portage in Sabayon.

I suggest try this manner. Follow these instructions, step by step. Operate over and upgraded Sabayon, including upgraded Portage

1) first, close amuleadu, when opened.

2) remove the old amuleadu, that you installed, prior, with entropy:

Code: Select all
# equo rm amuleadu --configfiles


3) As Root edit the file /etc/entropy/client.conf and in the line "ignore spmdowngrades", change "disable" to "enable". Save the file, without change their name.

4) Then, update the Portage database:

Code: Select all
# emerge --sync


5) See if you have Sabayon Overlays installed

Code: Select all
$ layman -l


6) If you have the Sabayon Overlays, update them:

Code: Select all
# layman -S


7) See if you have the amuleadu in the Portage's database:

Code: Select all
emerge -s amuleadu


8) Then verify if the amuleadu package can be easily compiled without change many dependencies, without blockers, masks,collisions:

Code: Select all
emerge -p amuleadu


9) If the output of the command 8 is good, you may try to compile amuleadu, directly in Italian language and with the new binutils support. In Conditions that you previously installed the 2,23 version of binutils with entropy, hese command may compile it in a good manner and using the installed binutils:

Code: Select all
# LINGUAS="it" USE="binutils" emerge -av amuleadu


10) if successfull installed, syncronize portage with entropy data:

Code: Select all
# equo rescue spmsync
ALBERTO FEDERMAN NETO
albfneto
[email protected]
Favorite Distros: Sabayon, Gentoo, Mageia and OpenSUSE
User avatar
albfneto
Sagely Hen
 
Posts: 1725
Joined: Fri Nov 16, 2007 1:15
Location: Ribeirão Preto City, São Paulo State, Brazil

Re: Amuleadu don't start, again.

Postby Burno Sauri » Thu Jun 19, 2014 17:23

Hi Alberto,
I thank you, but I don't have Amuleadu in my Portage's database:

* vmalov [Git ] (git://git.o.g.o/user/vmalov.git, ...)
* vmware [Git ] (git://git.o.g.o/proj/vmware.git, ...)
* voip [Git ] (git://git.o.g.o/proj/voip.git, ht...)
* voyageur [Subversion] (https://cafarelli.fr/svn/voyageur...)
* vps [Subversion] (svn://overlays.gentoo.org/proj/vps )
* wacfg [Git ] (git://github.com/nutztherookie/wa...)
* wagnerflo [Mercurial ] (https://bitbucket.org/wagnerflo/p...)
* wavilen [Mercurial ] (https://wavilen.googlecode.com/hg/ )
* wbrana [Git ] (git://git.o.g.o/user/wbrana.git, ...)
* wdzierzan [Git ] (git://git.o.g.o/user/wdzierzan.gi...)
* webapps-experimental [Subversion] (svn://o.g.o/proj/webapps/experime...)
* webos [Git ] (https://github.com/feniksa/webos-...)
* wine-diablo3 [Git ] (git://github.com/simcop2387/wine-...)
* wirelay [Git ] (git://github.com/wired/wirelay.git )
* wish [Git ] (git://git.o.g.o/user/wish.git, ht...)
* wnx [Git ] (git://wnx.wisegears.com/portage/o...)
* wolf31o2 [Git ] (git://git.wolf31o2.org/overlays/w...)
* write2David [Git ] (git://git.o.g.o/user/write2David....)
* wrobel [Subversion] (svn://o.g.o/dev/wrobel/stable )
* wschlich [Git ] (git://git.o.g.o/dev/wschlich, htt...)
* wtk [Git ] (git://tremily.us/wtk-overlay.git,...)
* wuodan [Git ] (git://git.o.g.o/user/wuodan.git, ...)
* x11 [Git ] (git://git.o.g.o/proj/x11, http://...)
* xarthisius [Git ] (git://git.o.g.o/dev/xarthisius.gi...)
* xen [Subversion] (svn://o.g.o/proj/xen/overlay )
* xfce-dev [Git ] (git://git.o.g.o/proj/xfce.git, ht...)
* xgr [Git ] (git://github.com/dgoncharov/xgr.git )
* xhub [Git ] (git://git.o.g.o/user/xhub.git, ht...)
* xmms-zombie [Git ] (git://git.goodpoint.de/overlay-xm...)
* xmw [Git ] (git://git.o.g.o/dev/xmw.git, http...)
* xtreemfs [Git ] (git://github.com/xtreemfs-gentoo/...)
* xwing [Rsync ] (rsync://gentoo.xwing.info/xwing-o...)
* yac [Git ] (git://github.com/yaccz/gentoo-ove...)
* yarik-overlay [Subversion] (http://yarik-overlay.googlecode.c...)
* yngwin [Git ] (git://git.o.g.o/dev/yngwin.git, h...)
* yoreek [Git ] (git://git.o.g.o/user/yoreek.git, ...)
* yporti [Git ] (git://github.com/yporti/overlay.g...)
* zlogene [Git ] (git://git.o.g.o/dev/zlogene.git, ...)
* zugaina [Rsync ] (rsync://gentoo.zugaina.org/zugain...)
* zx2c4 [Git ] (http://git.zx2c4.com/portage, ssh...)

sabayon ~ # layman -S

* Fetching remote list,...
* Remote list already up to date: http://www.gentoo.org/proj/en/overlays/repositories.xml
* Last-modified: Tue, 17 Jun 2014 20:30:04 GMT
* Fetch Ok

* Syncing selected overlays,...

sabayon ~ # emerge -s amuleadu
Searching...
[ Results for search key : amuleadu ]
[ Applications found : 0 ]

sabayon ~ #


The command that you have indicate to me:
# LINGUAS="it" USE="binutils" emerge -av amuleadu

or, in italian, #LINGUA="it".....

Thanks.
Burno Sauri
Simple Hen
 
Posts: 80
Joined: Sat Sep 24, 2011 18:09

Re: Amuleadu don't start, again.

Postby albfneto » Sat Jun 21, 2014 3:45

Seeing the outputs, you dont have the Sabayon Overlays. Necessary to install them:

amuleadu is a package, not an Overlay

in my system, the package

Code: Select all
$ emerge -s amuleadu
Searching...   
[ Results for search key : amuleadu ]
[ Applications found : 1 ]

*  net-p2p/amuleadu
      Latest version available: 2010.1
      Latest version installed: [ Not Installed ]
      Size of files: 5,392 kB
      Homepage:      http://www.adunanza.net/
      Description:   aMule AdunanzA, IL software p2p per la comunita' fastweb
      License:       GPL-2


Install and update the Overlays:

http://gpo.zugaina.org/net-p2p/amuleadu

As in my tutorial, but in the nymber 6),
substitute the command layman -S with these commmands:

Code: Select all
# layman -a sabayon
# layman -a sabayon-distro
# layman -S


About LINGUAS, the name of the variable, for Languages, in make.conf of the Portage, is LINGUAS e non LINGUA... Therefore, use:

Code: Select all
LINGUAS="it"


and not "LINGUA=". For example for me, in Brazil, i use ever times, LINGUAS="pt_BR" for compile in Brazilain Portuguese.

Apologise, in replying the post,i dont take attention that this is the International Forum!
Moderator Edit: Please post in English when using the English-language forums.
Last edited by albfneto on Wed Jun 25, 2014 13:41, edited 1 time in total.
ALBERTO FEDERMAN NETO
albfneto
[email protected]
Favorite Distros: Sabayon, Gentoo, Mageia and OpenSUSE
User avatar
albfneto
Sagely Hen
 
Posts: 1725
Joined: Fri Nov 16, 2007 1:15
Location: Ribeirão Preto City, São Paulo State, Brazil

Re: Amuleadu don't start, again.

Postby Burno Sauri » Sat Jun 21, 2014 22:28

Hi Alberto,
I have followed your advice, but this is the output:
2010.1/temp/environment'.
* Working directory: '/var/tmp/portage/net-p2p/amuleadu-2010.1/work/aMule-AdunanzA-2010.1-2.2.6'
* S: '/var/tmp/portage/net-p2p/amuleadu-2010.1/work/aMule-AdunanzA-2010.1-2.2.6'

>>> Failed to emerge net-p2p/amuleadu-2010.1, Log file:

>>> '/var/tmp/portage/net-p2p/amuleadu-2010.1/temp/build.log'

* Messages for package app-admin/eselect-wxwidgets-20140423:

* This eselect module only controls the version of wxGTK used when
* building packages outside of portage. If you are not doing development
* with wxWidgets or bakefile you will never need to use it.

* Messages for package net-p2p/amuleadu-2010.1:

* ERROR: net-p2p/amuleadu-2010.1::sabayon failed (compile phase):
* emake failed
*
* Call stack:
* ebuild.sh, line 93: Called src_compile
* environment, line 3186: Called __eapi2_src_compile
* phase-helpers.sh, line 695: Called die
* The specific snippet of code:
* emake || die "emake failed"
*
* If you need support, post the output of `emerge --info '=net-p2p/amuleadu-2010.1::sabayon'`,
* the complete build log and the output of `emerge -pqv '=net-p2p/amuleadu-2010.1::sabayon'`.
* The complete build log is located at '/var/tmp/portage/net-p2p/amuleadu-2010.1/temp/build.log'.
* The ebuild environment file is located at '/var/tmp/portage/net-p2p/amuleadu-2010.1/temp/environment'.
* Working directory: '/var/tmp/portage/net-p2p/amuleadu-2010.1/work/aMule-AdunanzA-2010.1-2.2.6'
* S: '/var/tmp/portage/net-p2p/amuleadu-2010.1/work/aMule-AdunanzA-2010.1-2.2.6'

* Regenerating GNU info directory index...
* Processed 163 info files.

* IMPORTANT: 9 news items need reading for repository 'gentoo'.
* Use eselect news to read news items.

sabayon ~ # equo rescue spmsync
☛ Acquisizione lock esclusivo su /var/lib/entropy/.using_resources ...

And like you can see, the command " equo rescue spmsync" remains "unheeded".
Tomorrow I am sure, it is there again.
I thank you, but amule adunanza in Sabayon is too difficult, for a newbie like me!
Burno Sauri
Simple Hen
 
Posts: 80
Joined: Sat Sep 24, 2011 18:09

Re: Amuleadu don't start, again.

Postby albfneto » Sun Jun 22, 2014 20:04

I also use Amuleadu.

I test to compile, i received EAPI errors,since Amuleadu is an old package

I upgraded binutils with Portage

Code: Select all
sudo emerge -sync
emerge -p binutils
emerge -av binutils


Installed the binutils 2.24-r3 (not 2.23)

Code: Select all
sys-devel/binutils
      Latest version available: 2.24-r3
      Latest version installed: 2.24-r3
      Size of files: 22,201 kB
      Homepage:      http://sourceware.org/binutils/
      Description:   Tools necessary to build programs
      License:       || ( GPL-3 LGPL-3 )


Then installed the AMuleadu from the Portage database:

Code: Select all
sudo equo i amuleadu


See Amuleadu working good:

http://www.casimages.com.br/i/140622090703245036.png.html


Moderator Edit: Please post in English when using the English-language forums.
Last edited by albfneto on Wed Jun 25, 2014 14:06, edited 2 times in total.
ALBERTO FEDERMAN NETO
albfneto
[email protected]
Favorite Distros: Sabayon, Gentoo, Mageia and OpenSUSE
User avatar
albfneto
Sagely Hen
 
Posts: 1725
Joined: Fri Nov 16, 2007 1:15
Location: Ribeirão Preto City, São Paulo State, Brazil

Re: Amuleadu don't start, again.

Postby Burno Sauri » Tue Jun 24, 2014 6:38

Hi ALberto,
I added the three commands :

sudo emerge -sync
emerge -p binutils
emerge -av binutils


but the answer is the same :

[email protected] ~ $ amuleadu
amuleadu: error while loading shared libraries: libbfd-2.22.so: cannot open shared object file: No such file or directory
[email protected] ~ $


I thank you.
Burno Sauri
Simple Hen
 
Posts: 80
Joined: Sat Sep 24, 2011 18:09

Next

Return to Software in General

Who is online

Users browsing this forum: No registered users and 1 guest