Root cannot connect to x server [Partially Solved]

Discussions Regarding Software

Moderator: Moderators

Root cannot connect to x server [Partially Solved]

Postby Ritana » Sat Mar 01, 2014 12:27

Hi Everyone,

Today I had to maintain my LVM2 partition and happened to have a sudden problem:

I don't know why but I'm unable to use GUI apps with root privileges , it's refused by the error message:

Code: Select all
 No protocol specified
kate: cannot connect to X server :0



I've tried to fix it by exporting .XAUTHORITY from my user folder as well as re-setting DISPLAY env variable and so on but the result seems the same :(

Yesterday I could launch any GUI program from root terminal so I don't really know what could be went wrong. Does anyone any idea? Thanks is advance

R

edit: Ok, I managed to fix it by putting into /root/.bashrc the following command then reboot:

Code: Select all
xauth merge /home/ritana/.Xauthority


But still, does anyone know why my root's X window had broken?
(sorry, I'm not really expert in Unix word)
LOVE is the only socially acceptable form of insanity

3.16Ghz Intel(R) Core(TM)2 Duo E8500; 6Gb Kingston DDR2 1066 Mhz,
SAMSUNG 830 SSD, Samsung HD1109 2 Tb, NVIDIA 610gt
Linux 3.12.0-sabayon, KDE 4.12.-64 bit
Ritana
Simple Hen
 
Posts: 94
Joined: Wed Jan 16, 2013 8:19
Location: Hungary

Return to Software in General

Who is online

Users browsing this forum: No registered users and 1 guest

cron