how to install! [Solved]

Anything that pertains to Entropy, Equo or Sulfur

Moderator: Moderators

how to install! [Solved]

Postby noxv » Sat Jul 06, 2013 16:38

helloo

sorry for my english spelling but im from spain

i know how to install by equo emerge by console or terminal and graphical installation by rigo
but i want to learn installing for example the sources packages of entropy store!

when im downloading for example another version of ufw and frontends than the ultimates(pre805) FROM ENTROPY STORE,
how can i do to install 0.33-r2?

when tar.gz is opened this show an directory if i go to the terminal next to the app directory i don't know what the hell have to do! LOL

previoulsy when i used be on ubuntu i use comands like:
./configure
make
make install

and the aplication was installed but here how can install ufw by comands? because firewall manager of pre805 don't run!
Code: Select all
gksu /usr/sbin/ufw-gtk

(gksu:25296): GConf-WARNING **: Client failed to connect to the D-BUS daemon:
Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
GConf Error: No D-BUS daemon running


(gksu:25296): GConf-WARNING **: Client failed to connect to the D-BUS daemon:
Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
GConf Error: No D-BUS daemon running


(gksu:25296): GConf-WARNING **: Client failed to connect to the D-BUS daemon:
Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
GConf Error: No D-BUS daemon running

/usr/lib/python2.7/site-packages/gfw/frontend_gtk.py:68: GtkWarning: Unknown property: GtkMenu.ubuntu-local
  self.ui.add_from_file(path)
Traceback (most recent call last):
  File "/usr/sbin/ufw-gtk-2.7", line 9, in <module>
    main()
  File "/usr/lib/python2.7/site-packages/gfw/frontend_gtk.py", line 743, in main
    ui = GtkFrontend()
  File "/usr/lib/python2.7/site-packages/gfw/frontend_gtk.py", line 93, in __init__
    self._notifier = Notifier(callback)
  File "/usr/lib/python2.7/site-packages/gfw/frontend_gtk.py", line 37, in __init__
    gfw.event.Notifier.__init__(self, callback)
  File "/usr/lib/python2.7/site-packages/gfw/event.py", line 73, in __init__
    self._log = open('/var/log/messages.log', 'r')
IOError: [Errno 2] No such file or directory: '/var/log/messages.log'
Exception AttributeError: "'Notifier' object has no attribute '_log'" in <bound method Notifier.__del__ of <gfw.frontend_gtk.Notifier object at 0xb4269eec>> ignored


i want to learn a lot about this fantastic free OS!
Last edited by noxv on Mon Jul 08, 2013 13:16, edited 1 time in total.
noxv
Baby Hen
 
Posts: 10
Joined: Tue Jul 02, 2013 16:24

Re: how to install!

Postby albfneto » Sun Jul 07, 2013 20:07

Packages in the Entropy Store are not sources, are entropy (RIGO, command equo) packages and are not tar.gz, but bz2 and binaries.

RIGO is not an emerge command GUI, is for entropy, command equo.

manual compilation of packages is not a reccomended procedure in sabayon, but may be carried out.

For install packages: use rigo, or the command "equo i package". If have some expertise, you may also use emerge.

emerge is useful for new versions of packages, you may also carry out a request for a new version of the package in the Sabayon Bugzilla.

Long to be explained here. Details, you may read in the Sabayon Wiki. Use "Entropy" "Portage", "emerge" and "equo" as keywords.
ALBERTO FEDERMAN NETO
albfneto
[email protected]
Favorite Distros: Sabayon, Gentoo, Mageia and OpenSUSE
User avatar
albfneto
Sagely Hen
 
Posts: 1706
Joined: Fri Nov 16, 2007 1:15
Location: Ribeirão Preto City, São Paulo State, Brazil

Re: how to install!

Postby noxv » Mon Jul 08, 2013 11:18

hello sorry if i dont understand all you say me but...

normally i'm installing soft by rigo or

equo install <pakage>

but the version of ufw frontend don't work i don't know if is for dependencies or not

when i do an equo search net-firewall/ufw-0.33-r2 in the console and next the comand install
not found this package! only show the ultimate!

if you go to the entropy store in each package you have the possibility to do the download of package or download "source" to compile

http://imageshack.us/photo/my-images/703/0wxh.png/
http://imageshack.us/photo/my-images/580/7zce.png/

i will go to the wiki sabayon to know more about and sorry because im newbie
perhaps i will post in sabayon bugzilla but i want to know before if its an error of me or not

thanks
noxv
Baby Hen
 
Posts: 10
Joined: Tue Jul 02, 2013 16:24

Re: how to install!

Postby sihox » Mon Jul 08, 2013 12:29

Hello,

Using entropy (command: rigo or equo) you can only install binary packages.
But you can also use portage (command: emerge) to install package from the source.
Of course package version you are looking for must be in repositories (see: http://packages.sabayon.org).

For example - in case you've mentioned (ufw-0.33-r2)

First sync your portage repo:
Code: Select all
emerge --sync


Next install ufw with selected version
Code: Select all
emerge net-firewall/ufw-0.33-r2


If there were no errors it should work fine :)

It is good to do full system upgrade before:
Code: Select all
equo update
equo install equo entropy
equo upgrade
equo conf update


And after properly installing from source it is good to let entropy know about it:
Code: Select all
equo repo spmsync


That's all :) Good luck!
sihox
Young Hen
 
Posts: 22
Joined: Tue Dec 01, 2009 23:22
Location: Poland

Re: how to install!

Postby noxv » Mon Jul 08, 2013 13:15

thanks man another thing that i have learned
very resolutive great post seriously!!

but i haven't had to do this because the ultimate version runs perfecct
was a problem: IOError: [Errno 2] No such file or directory: '/var/log/messages.log'

in other forum they told me that the distro don't have the archive
the solution that a guy gave me was

sudo touch /var/log/messages

regards for the user if he/she is reading me.

and newly sihox thanks because in the future could be very interestant to use altrnative soft that aparently doesent appear.
sorry for my miserly english and people that can be hurt by my destruction of this language..

no more to say only.....

sabayon rules!!
noxv
Baby Hen
 
Posts: 10
Joined: Tue Jul 02, 2013 16:24

Re: how to install! [Solved]

Postby albfneto » Mon Jul 08, 2013 15:04

alternative software thar you said, are the "normal" sources, as package.tar.gz?

the normal procedure (./configure && make && sudo make install) can be used in sabayon also.

Another thing:

if you will use entropy and portage[/i, together, you should prior edit the file [i]/etc/entropy/client.conf and in the line ignore pseudo downgrades, please, change "disable" to "enable".

It is necessary for the entropy , i order to not overwrite your packages, with older (and not newer) versions, viz. if not edited this file, Entropy may will propose downgrades, instead of upgrades
ALBERTO FEDERMAN NETO
albfneto
[email protected]
Favorite Distros: Sabayon, Gentoo, Mageia and OpenSUSE
User avatar
albfneto
Sagely Hen
 
Posts: 1706
Joined: Fri Nov 16, 2007 1:15
Location: Ribeirão Preto City, São Paulo State, Brazil

Re: how to install! [Solved]

Postby noxv » Mon Jul 08, 2013 16:12

when i refer "alternative software" i would say old software that equo don't show.
with the method of sihox with
Code: Select all
emerge --sync


include all software available on the store, old and new and then you can download specified version.

i tried ./configure , make... before all with older version but when message say me don't exist file i thougth that wasn't the correct way,

in ubuntu ever have had an installer file log that explained how to install a program and what file invoke but here don't found this. ( the most similar was setup.py but don't understand this)
THE SOLUTION WAS IN README FILE!!!

Code: Select all


Install
-------
Users can install with:
# python ./setup.py install
$ python ./setup.py install --home=PREFIX


I HAVE TO READ MORE!!

thanks for the IMPORTANT REPORT of downgrades because i doesn't know that for the option enabled disable of entropy
sabayon have a lot of secrets for discover!!

a lot of thanks
noxv
Baby Hen
 
Posts: 10
Joined: Tue Jul 02, 2013 16:24


Return to Entropy|Equo|Rigo Package Managers

Who is online

Users browsing this forum: No registered users and 3 guests

cron