Package version bump request policy

Discussions Regarding Software

Moderator: Moderators

Package version bump request policy

Postby ReemZ » Mon Jun 24, 2013 15:45

I'd like to see two packages updated, but I'm not sure where to file the request.
dev-java/oracle-jdk-bin: from 1.7.0.21 to 1.7.0.25. It's in Portage, but masked.
(Same for dev-java/oracle-jre-bin btw)
dev-java/eclipse-ecj: from 4.2.1 to 4.2.2: Entropy and Portage hold the same version: 4.2.1.

Am I to file the bump requests at our Bugzilla or at Gentoo's?
Handtekening? Zeg...ik ga niet op m'n monitor schrijven!
ReemZ
Old Dear Hen
 
Posts: 701
Joined: Mon Oct 27, 2008 10:50
Location: Here! No, here! Over heeeeeeere!

Re: Package version bump request policy

Postby joost » Mon Jun 24, 2013 16:55

http://data.gpo.zugaina.org/gentoo/dev- ... /ChangeLog

Code: Select all
  22 Jun 2013; Tom Wijsman <[email protected]> +oracle-jdk-bin-1.7.0.25.ebuild,
  oracle-jdk-bin-1.7.0.17.ebuild, oracle-jdk-bin-1.7.0.21.ebuild:
  Version bump to 1.7.0.25 for security bug #473980 reported by Hypnos, fixes 40
  CVEs.


Feel free to open a bump request on our bugzilla.

ooh wait..

http://packages.sabayon.org/show/oracle ... 5,standard

It is in Entropy. :D
joost
Sagely Hen
 
Posts: 2582
Joined: Fri Nov 17, 2006 12:11
Location: The Netherlands

Re: Package version bump request policy

Postby ReemZ » Mon Jun 24, 2013 17:08

lol, ok, in Limbo :lol:

btw, I'm not entirely sure what the difference is between oracle-jdk-bin and oracle-jre-bin, or eclipse-ecj and eclipse-sdk :oops:
Handtekening? Zeg...ik ga niet op m'n monitor schrijven!
ReemZ
Old Dear Hen
 
Posts: 701
Joined: Mon Oct 27, 2008 10:50
Location: Here! No, here! Over heeeeeeere!

Re: Package version bump request policy

Postby Stupot » Mon Jun 24, 2013 17:44

A quick google could answer that for you.

jdk/sdk are development kits. They are necessary if you want to write the applications. jre is a runtime environment. It is needed to run anything in java. ecj is the eclipse compiler (different from the standard javac compiler).

There's lot of information out there if you want to know more/better details. Obviously I'm summarizing and perhaps even slightly wrong in some aspects.
Stupot
Sagely Hen
 
Posts: 1549
Joined: Wed Feb 14, 2007 3:44
Location: St. Louis, MO, USA

Re: Package version bump request policy

Postby ReemZ » Mon Jun 24, 2013 17:50

I did google, just didn't really get it. I blame lack of sleep O:)

Leaves me wondering why eclipse-sdk was kicked from Entropy and why it's masked in Portage...
Handtekening? Zeg...ik ga niet op m'n monitor schrijven!
ReemZ
Old Dear Hen
 
Posts: 701
Joined: Mon Oct 27, 2008 10:50
Location: Here! No, here! Over heeeeeeere!

Re: Package version bump request policy

Postby svantoviit » Thu Jun 27, 2013 15:03

ReemZ wrote:1.7.0.25. It's in Portage, but masked
It is not masked, you just need to download the binary from Oracle on your own because of licensing. Portage actually tells you exactly what to do.

ReemZ wrote:Leaves me wondering why eclipse-sdk was kicked from Entropy and why it's masked in Portage...
Moore googling will definitely do, but a short look into /usr/portage/profiles/package.mask too:
Code: Select all
# Ralph Sennhauser <[email protected]> (18 Jul 2012)
# Unmaintained, multiple vulnarabilities. #351626
# A more recent source build maintained by the community is available in the
# seden overlay. A more recent binary is available in the java-overlay.
<=dev-util/eclipse-sdk-3.5.1-r1
svantoviit
Old Dear Hen
 
Posts: 651
Joined: Sun Feb 28, 2010 17:55

Re: Package version bump request policy

Postby ReemZ » Thu Jun 27, 2013 15:51

svantoviit wrote:
ReemZ wrote:1.7.0.25. It's in Portage, but masked
It is not masked, you just need to download the binary from Oracle on your own because of licensing. Portage actually tells you exactly what to do.

Code: Select all
# emerge -s oracle-jdk-bin
Searching...   
[ Results for search key : oracle-jdk-bin ]
[ Applications found : 1 ]

*  dev-java/oracle-jdk-bin [ Masked ]
      Latest version available: 1.7.0.25
      Latest version installed: 1.7.0.25
      Size of files: 94,059 kB
      Homepage:      http://www.oracle.com/technetwork/java/javase/
      Description:   Oracle's Java SE Development Kit
      License:       Oracle-BCLA-JavaSE examples? ( BSD )
(Installed it from Limbo with equo)
I'm not that good with Portage yet, so there's probably an option or command to pull up the info you just gave me that I still have to learn ;)

svantoviit wrote:
ReemZ wrote:Leaves me wondering why eclipse-sdk was kicked from Entropy and why it's masked in Portage...
Moore googling will definitely do, but a short look into /usr/portage/profiles/package.mask too:
Code: Select all
# Ralph Sennhauser <[email protected]> (18 Jul 2012)
# Unmaintained, multiple vulnarabilities. #351626
# A more recent source build maintained by the community is available in the
# seden overlay. A more recent binary is available in the java-overlay.
<=dev-util/eclipse-sdk-3.5.1-r1

Thanks for pointing out package.mask, helpful indeed. I did find that info via google and installed eclipse-sdk-bin from the java overlay a few days ago and probably should've mentioned that here, sorry.
Is there a reason this version hasn't made it to Entropy? Would my package request have any use?
Handtekening? Zeg...ik ga niet op m'n monitor schrijven!
ReemZ
Old Dear Hen
 
Posts: 701
Joined: Mon Oct 27, 2008 10:50
Location: Here! No, here! Over heeeeeeere!

Re: Package version bump request policy

Postby cmost » Sat Jun 29, 2013 3:31

I enterend a bugzilla request for Linux Mint's display manager (MDM) more than a month ago and didn't here didly squat one way or the other. I guess the developers decide at their lesiure which packages are updated.
AMD Phenom II 64 X6 1090T Black Edition
8192 MB DDR2 RAM
nVidia GeForce GTX 660 w 2048 MB DDR5
Sabayon 2014.x 64 Bit KDE
"Better to remain silent and be thought a fool than to speak out and remove all doubt." -- Abraham Lincoln
cmost
Advanced Hen
 
Posts: 208
Joined: Wed Dec 13, 2006 22:25
Location: Cincinnati, OH

Re: Package version bump request policy

Postby ReemZ » Sat Jun 29, 2013 18:08

cmost wrote:I enterend a bugzilla request for Linux Mint's display manager (MDM) more than a month ago and didn't here didly squat one way or the other. I guess the developers decide at their lesiure which packages are updated.

You should read your sig and read it well :roll:
Handtekening? Zeg...ik ga niet op m'n monitor schrijven!
ReemZ
Old Dear Hen
 
Posts: 701
Joined: Mon Oct 27, 2008 10:50
Location: Here! No, here! Over heeeeeeere!

Re: Package version bump request policy

Postby cmost » Sun Jun 30, 2013 21:06

@ Reemz

Um, nothing I wrote isn't true. Sorry if that bothers you.
AMD Phenom II 64 X6 1090T Black Edition
8192 MB DDR2 RAM
nVidia GeForce GTX 660 w 2048 MB DDR5
Sabayon 2014.x 64 Bit KDE
"Better to remain silent and be thought a fool than to speak out and remove all doubt." -- Abraham Lincoln
cmost
Advanced Hen
 
Posts: 208
Joined: Wed Dec 13, 2006 22:25
Location: Cincinnati, OH

Next

Return to Software in General

Who is online

Users browsing this forum: No registered users and 1 guest

cron