downgrade [Solved]

Discussions Regarding Software

Moderator: Moderators

downgrade [Solved]

Postby camilla » Thu May 02, 2013 1:40

Hi everybody!
I need to downgrade avidemux to the version 2.5.6, because I need to match "old" srt subtitles (a hardsub (xvid+mp3) for the playstation 2, I mean), and this feature is no more available in the 2.6.* version.

Installing from source i get this error, which I don't understand:
Code: Select all
Linking CXX static library libADM_dialogQt4_qt4.a
[ 92%] Built target ADM_dialogQt4_qt4
make: *** [all] Errore 2
*** fail make_main ***


Why doesn't exist a downgrade option on sulfur? :evil:

I need 1 of these solution:
1) srt subtitle plug in for the current avidemux
2) downgrade to a version with srt option
3) another way to quick and easy make subtitled avi for playstation2

any idea?
Last edited by camilla on Thu May 02, 2013 21:10, edited 1 time in total.
camilla
Simple Hen
 
Posts: 42
Joined: Sun Nov 30, 2008 15:21

Re: downgrade

Postby lxnay » Thu May 02, 2013 9:29

Hi camilla,
you should post the full error output, not just 3 random lines :)
Image
Join us on IRC (chat.freenode.net #sabayon or WebChat)
Submit bugs to our Bug Tracker
Follow me on Twitter
Add me on Facebook
Add me on Google+
lxnay
Land Owner
 
Posts: 3596
Joined: Thu Oct 13, 2005 23:16
Location: Italy

Re: downgrade

Postby albfneto » Thu May 02, 2013 12:29

Hi Camilla. Alberto, Brazil.

Another possibility, since this version of Avidemux may be found in the Gentoo, Portage and in the Sabayon Overlays.

You may install it using Portage.Edit the file /etc/entropy/client.conf , change, in the line "spmdowngrades" :
"disable" to "enable". Save the file.

then,execute these commands, to verify and to install using Portage:

Code: Select all
# emerge --sync
# layman -S
# emerge -p =avidemux-2.5.6-r2
# LINGUAS="it" emerge -av =avidemux-2.5.6-r2


After installing, mask future versions of avidemux, in order no more upgraded:

Code: Select all
# equo mask avidemux
Last edited by albfneto on Thu May 02, 2013 16:25, edited 1 time in total.
ALBERTO FEDERMAN NETO
albfneto
[email protected]
Favorite Distros: Sabayon, Gentoo, Mageia and OpenSUSE
User avatar
albfneto
Sagely Hen
 
Posts: 1728
Joined: Fri Nov 16, 2007 1:15
Location: Ribeirão Preto City, São Paulo State, Brazil

Re: downgrade

Postby Fitzcarraldo » Thu May 02, 2013 13:37

avidemux-2.5.6-r2 is hard masked in Portage, though, so you'd need to unmask it first in Portage before merging it:

Code: Select all
echo "=media-video/avidemux-2.5.6-r2" >> /etc/portage/package.unmask

It's probably hard masked in Portage for a good reason, though, so don't be surprised if it doesn't install.

A possible alternative might be to try Bombono DVD, which, despite the name, can also create AVI files with subtitles, if I recall correctly. You can use the GNOME Subtitles application with it too, or just edit the subtitles file manually. Excellent application, by the way. I used it once to create a DVD-Video disc from a MKV file with subtitles: Using Bombono DVD in Linux to create a DVD-Video disc from a MKV file (Avidemux crashed when I tried to use that rather than Bombono).
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7997
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: downgrade

Postby camilla » Thu May 02, 2013 21:10

Hi everybody!

The Alberto-Fitz solution works.

@lxnay: I'm sorry but I got only this few lines. Before of these there is a very long tail but no errors.

But I found also another solution - I don't know if I can write this :-\ - an unofficial repository with a lot of old packages. I was able to install the old and - surprise! - maintaining the new one. ["I want it all! I want it aaall!" :D *singing*]

I'm trying this "Bombono" too. :)

Thanks a lot!
camilla
Simple Hen
 
Posts: 42
Joined: Sun Nov 30, 2008 15:21


Return to Software in General

Who is online

Users browsing this forum: No registered users and 2 guests