Broken kernel upgrade-more info posted

Discussions Regarding Software

Moderator: Moderators

Broken kernel upgrade-more info posted

Postby Mark Nei » Sat Apr 27, 2013 0:11

Recently I installed Sabayon 11. I also installed virtualbox, but it did not work. I read that I should make sure that my kernel is updated (3.7 to 3.8 ), so I followed the steps in:
http://wiki.sabayon.org/index.php?title ... ng_Entropy
and used entropy to update my kernel. The only place where I had a problem was I didn't know how to deal with the following notices from updating the modules:
CONFIG_B43 should not be set, but is
CONFIG_SSB should not be set, but it
CONFIG_MAC80211 should not be set, but is

I didn't know where to find these, so there was nothing I could do about them. I followed all other directions to the letter. Now I can't boot into Sabayon. I go through the boot process without errors, but when I'm waiting for the kdm screen to appear, all I see is a flashing cursor in the upper left corner (not a pretty sight).

Fortunately, I have a second HDD with a different linux version installed so that I am able to boot up, log on and ask for help in getting my system restored to running condition. Worst case I can reinstall (/home is a separate partition, so my data should be safe).

Does anyone have any guidance for getting my system back in working order? I could really use the help at this point.

Thank you very much,
Mark
Last edited by Mark Nei on Sat Apr 27, 2013 12:52, edited 1 time in total.
Mark Nei
Baby Hen
 
Posts: 12
Joined: Sun Mar 17, 2013 20:04

Re: Broken kernel upgrade

Postby Mark Nei » Sat Apr 27, 2013 12:51

More information....my Sabayon drive is /dev/sdb . In addition, grub is installed on /dev/sda . This does not make the installer happy. For example, the bzImage and initrd links in the /boot directory do not get updated. I updated them manually this AM to point to the correct boot files, but kdm still does not start. Here is the Xorg.0.log file.

Code: Select all
[    15.343]
X.Org X Server 1.13.3
Release Date: 2013-03-07
[    15.343] X Protocol Version 11, Revision 0
[    15.343] Build Operating System: Linux 3.7.0-server x86_64 Gentoo
[    15.343] Current Operating System: Linux Mark 3.8.0-sabayon #1 SMP Fri Apr 26 12:02:11 UTC 2013 x86_64
[    15.343] Kernel command line: root=/dev/sdb2 quiet splash vga=788
[    15.343] Build Date: 17 March 2013  09:56:56PM
[    15.343]
[    15.343] Current version of pixman: 0.29.2
[    15.343]    Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
[    15.343] Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    15.343] (==) Log file: "/var/log/Xorg.0.log", Time: Sat Apr 27 03:25:18 2013
[    15.362] (==) Using config file: "/etc/X11/xorg.conf"
[    15.362] (==) Using config directory: "/etc/X11/xorg.conf.d"
[    15.362] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    15.416] (==) ServerLayout "Main Layout"
[    15.416] (**) |-->Screen "Screen 0" (0)
[    15.416] (**) |   |-->Monitor "Generic Monitor"
[    15.417] (**) |   |-->Device "SabayonVga0"
[    15.417] (**) Option "AllowMouseOpenFail" "true"
[    15.417] (==) Automatically adding devices
[    15.417] (==) Automatically enabling devices
[    15.417] (==) Automatically adding GPU devices
[    15.441] (WW) The directory "/usr/share/fonts/TTF/" does not exist.
[    15.441]    Entry deleted from font path.
[    15.441] (WW) The directory "/usr/share/fonts/OTF/" does not exist.
[    15.441]    Entry deleted from font path.
[    15.441] (WW) The directory "/usr/share/fonts/Type1/" does not exist.
[    15.442] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi/".
[    15.442]    Entry deleted from font path.
[    15.442]    (Run 'mkfontdir' on "/usr/share/fonts/100dpi/").
[    15.442] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi/".
[    15.442]    Entry deleted from font path.
[    15.442]    (Run 'mkfontdir' on "/usr/share/fonts/75dpi/").
[    15.442] (==) FontPath set to:
        /usr/share/fonts/misc/
[    15.442] (==) ModulePath set to "/usr/lib64/xorg/modules"
[    15.442] (II) The server relies on udev to provide the list of input devices.
        If no devices become available, reconfigure udev or disable AutoAddDevices.
[    15.442] (II) Loader magic: 0x808be0
[    15.442] (II) Module ABI versions:
[    15.442]    X.Org ANSI C Emulation: 0.4
[    15.442]    X.Org Video Driver: 13.1
[    15.442]    X.Org XInput driver : 18.0
[    15.442]    X.Org Server Extension : 7.0
[    15.443] (--) PCI:*(0:1:0:0) 10de:0402:1458:3455 rev 161, Mem @ 0xfa000000/16777216, 0xc0000000/268435456, 0xf8000000/33554432, I/O @ 0x0000e000/128, BIOS @ 0x????????/131072
[    15.443] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
[    15.460] Initializing built-in extension Generic Event Extension
[    15.460] Initializing built-in extension SHAPE
[    15.460] Initializing built-in extension MIT-SHM
[    15.460] Initializing built-in extension XInputExtension
[    15.460] Initializing built-in extension XTEST
[    15.460] Initializing built-in extension BIG-REQUESTS
[    15.460] Initializing built-in extension SYNC
[    15.460] Initializing built-in extension XKEYBOARD
[    15.460] Initializing built-in extension XC-MISC
[    15.460] Initializing built-in extension XINERAMA
[    15.460] Initializing built-in extension XFIXES
[    15.460] Initializing built-in extension RENDER
[    15.460] Initializing built-in extension RANDR
[    15.460] Initializing built-in extension COMPOSITE
[    15.460] Initializing built-in extension DAMAGE
[    15.460] Initializing built-in extension MIT-SCREEN-SAVER
[    15.460] Initializing built-in extension DOUBLE-BUFFER
[    15.460] Initializing built-in extension RECORD
[    15.460] Initializing built-in extension DPMS
[    15.460] Initializing built-in extension X-Resource
[    15.460] Initializing built-in extension XVideo
[    15.460] Initializing built-in extension XVideo-MotionCompensation
[    15.460] Initializing built-in extension XFree86-VidModeExtension
[    15.460] Initializing built-in extension XFree86-DGA
[    15.460] Initializing built-in extension XFree86-DRI
[    15.460] Initializing built-in extension DRI2
[    15.460] (II) "glx" will be loaded. This was enabled by default and also specified in the config file.
[    15.460] (II) LoadModule: "extmod"
[    15.460] (II) Module "extmod" already built-in
[    15.460] (II) LoadModule: "i2c"
[    15.460] (II) Module "i2c" already built-in
[    15.460] (II) LoadModule: "ddc"
[    15.460] (II) Module "ddc" already built-in
[    15.460] (II) LoadModule: "vbe"
[    15.482] (II) Loading /usr/lib64/xorg/modules/libvbe.so
[    15.483] (II) Module vbe: vendor="X.Org Foundation"
[    15.483]    compiled for 1.13.3, module version = 1.1.0
[    15.483]    ABI class: X.Org Video Driver, version 13.1
[    15.483] (II) LoadModule: "dri"
[    15.483] (II) Module "dri" already built-in
[    15.483] (II) LoadModule: "glx"
[    15.533] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
[    16.075] (II) Module glx: vendor="NVIDIA Corporation"
[    16.075]    compiled for 4.0.2, module version = 1.0.0
[    16.075]    Module class: X.Org Server Extension
[    16.075] (II) NVIDIA GLX Module  313.18  Wed Jan  9 15:34:35 PST 2013
[    16.084] Loading extension GLX
[    16.084] (II) LoadModule: "synaptics"
[    16.084] (II) Loading /usr/lib64/xorg/modules/input/synaptics_drv.so
[    16.108] (II) Module synaptics: vendor="X.Org Foundation"
[    16.108]    compiled for 1.13.3, module version = 1.6.3
[    16.108]    Module class: X.Org XInput Driver
[    16.108]    ABI class: X.Org XInput driver, version 18.0
[    16.108] (II) LoadModule: "vboxvideo"
[    16.148] (II) Loading /usr/lib64/xorg/modules/drivers/vboxvideo_drv.so
[    16.163] (II) Module vboxvideo: vendor="Oracle Corporation"
[    16.163]    compiled for 10.13.0, module version = 1.0.1
[    16.163]    Module class: X.Org Video Driver
[    16.163]    ABI class: X.Org Video Driver, version 13.0
[    16.163] (**) Load address of symbol "VBOXVIDEO" is 0x7f0685b4d400
[    16.163] (II) VBoxVideo: guest driver for VirtualBox: vbox
[    16.163] (++) using VT number 7

[    16.173] (EE) No devices detected.
[    16.173]
Fatal server error:
[    16.173] no screens found
[    16.173] (EE)
Please consult the The X.Org Foundation support
         at http://wiki.x.org
 for help.
[    16.173] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[    16.173] (EE)



I think that the error "no screens found" is the important bit, but on line 21, I (think) I see where a screen is created???

Thanks for any help,
Mark Nei
Baby Hen
 
Posts: 12
Joined: Sun Mar 17, 2013 20:04


Return to Software in General

Who is online

Users browsing this forum: No registered users and 3 guests

cron