/etc/mtab, cannot modify [Solved]

Discussions Regarding Software

Moderator: Moderators

/etc/mtab, cannot modify [Solved]

Postby kwacorn » Tue Apr 23, 2013 9:22

Since performing the Sabayon-weekly updates, on 21st April 2013, my system displays the following message during boot up:

Code: Select all
mount.nilfs2: cannot modify /etc/mtab.
Please remount the partition with -f option after making /etc/mtab writable.
nilfs_cleanerd not started

Checking the most recent archive log of rc.log, /var/log/rc.log-20130421.gz, I see the message did not appear prior to the recent updates making me wonder if this may be a new system bug? Could someone advise, as I am not knowledgeable enough in that area to know. I presume this may be preventing garbage collection on the nilfs partitions at present.

mtab is symlinked to /proc/self/mounts both are read only and the owner and group are myself and not root, I do not know what the settings should be, but I had expected mtab to be writeable and owned by root?

(nilfs_cleanerd is provided by the nilfs-utils package which may be due a version bump soon).
Last edited by kwacorn on Sun Apr 28, 2013 14:27, edited 1 time in total.
kwacorn
Young Hen
 
Posts: 37
Joined: Sat Jan 21, 2012 11:50

Re: /etc/mtab, cannot modify

Postby joost » Tue Apr 23, 2013 14:22

Hello.

I'm sure that the recent changes made, needed for systemd, caused this issue for you.
Not being familiar with nilfs at all I did see the package was fairly outdated in Entropy.

I will bump this package to a more recent version ( 2.1.4 ) and it will soon be available in the testing repository.
joost
Sagely Hen
 
Posts: 2547
Joined: Fri Nov 17, 2006 12:11
Location: The Netherlands

Re: /etc/mtab, cannot modify

Postby kwacorn » Sun Apr 28, 2013 14:25

Thank you for the prompt update of nilfs-utils, along with the weekly updates that has fixed the original problem. Also additional nilfs tools are now available in this latest version, which could be very useful.
kwacorn
Young Hen
 
Posts: 37
Joined: Sat Jan 21, 2012 11:50


Return to Software in General

Who is online

Users browsing this forum: No registered users and 1 guest