gcc problem after fix of problem

Discussions Regarding Software

Moderator: Moderators

gcc problem after fix of problem

Postby Mark Nei » Sun Apr 21, 2013 0:51

Running Sabayon fully up to date. Trying to compile the software for my printer drivers. Ran into problems with gcc, but I re-installed as was suggested. Now I'm getting the following problems:

***begin terminal output***
Code: Select all
[email protected] [email protected]s-common-2.50 $ make gen
(cd cngplp; ./autogen.sh; make) || exit 1
**Warning**: I am going to run `configure' with no arguments.
If you wish to pass any to it, please specify them on the
`./autogen.sh' command line.

processing .
Creating ./aclocal.m4 ...
Running glib-gettextize...  Ignore non-fatal messages.
Copying file mkinstalldirs
Copying file po/Makefile.in.in

Please add the files
  codeset.m4 gettext.m4 glibc21.m4 iconv.m4 isc-posix.m4 lcmessage.m4
  progtest.m4
from the /usr/share/aclocal directory to your autoconf macro directory
or directly to your aclocal.m4 file.
You will also need config.guess and config.sub, which you can get from
ftp://ftp.gnu.org/pub/gnu/config/.

***End terminal output***

So my questions in this section:
1. Where is the autoconf macro directory?
2. When I download config.guess and config.sub, in what folder do they go?

Here is some more terminal output:

Code: Select all
***start more terminal output after many lines cut out***
checking whether to build shared libraries... yes
checking whether to build static libraries... yes
./configure: line 12607: syntax error near unexpected token `PACKAGE,'
./configure: line 12607: `PKG_CHECK_MODULES(PACKAGE, $pkg_modules)'
make[1]: Entering directory `/home/mark/Downloads/Linux_UFRII_PrinterDriver_V250_us_EN/Sources/cndrvcups-common-2.50/cngplp'
make[1]: *** No targets specified and no makefile found.  Stop.
make[1]: Leaving directory `/home/mark/Downloads/Linux_UFRII_PrinterDriver_V250_us_EN/Sources/cndrvcups-common-2.50/cngplp'
make: *** [gen] Error 1
***end more terminal output***

Is the reason that no makefile was found the errors above?

Thanks for the help.

Mark
Mark Nei
Baby Hen
 
Posts: 12
Joined: Sun Mar 17, 2013 20:04

Return to Software in General

Who is online

Users browsing this forum: No registered users and 2 guests

cron