Skype audio problem on amd64

Discussions Regarding Software

Moderator: Moderators

Post Reply
sireangelus
Baby Hen
Posts: 4
Joined: Wed Mar 20, 2013 17:42

Skype audio problem on amd64

Post by sireangelus » Fri Apr 19, 2013 12:49

Sabayon mate amd64, limbo-rep

the audio has significant distortion when it plays the notification sounds, and i've yet to be able to make a call.

User avatar
Fitzcarraldo
Sagely Hen
Posts: 8092
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom
Contact:

Re: Skype audio problem on amd64

Post by Fitzcarraldo » Fri Apr 19, 2013 14:56

I had a problem with audio distortion in Skype on an Acer Aspire 5536 laptop running SL Xfce amd64 a few weeks ago and solved it by editing a config file, but can't recall whether or not it was /etc/pulse/default.pa or /etc/pulse/daemon.conf. Have you tried any of the suggestions in the Arch Linux forums thread PULSEAUDIO Crackling / Distortion?

User avatar
Fitzcarraldo
Sagely Hen
Posts: 8092
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom
Contact:

Re: Skype audio problem on amd64

Post by Fitzcarraldo » Sun May 12, 2013 16:23

I've remembered what I did, as I had to re-apply it today to SL running on an Acer Aspire 5536 to stop again the scratchy audio for notifications sounds and conversation in Skype. Strangely, the scratchy audio stops of its own accord after a minute or two, but it was nonetheless irritating. In my case the solution was to edit the file /etc/pulse/default.pa and change the line:

Code: Select all

load-module module-udev-detect
to:

Code: Select all

load-module module-udev-detect tsched=0
The parameter "tsched=0" disables PulseAudio's so-called 'glitch-fee' mode.

This older laptop is from Acer's 'budget' range and I think the audio hardware is not that good:

Code: Select all

# lspci | grep -i audio 
00:14.2 Audio device: Advanced Micro Devices [AMD] nee ATI SBx00 Azalia (Intel HDA)
01:05.1 Audio device: Advanced Micro Devices [AMD] nee ATI RS780 HDMI Audio [Radeon (HD) 3000 Series]

TDKyon
Young Hen
Posts: 25
Joined: Mon Apr 29, 2013 9:52

Re: Skype audio problem on amd64

Post by TDKyon » Sun May 19, 2013 6:34

What I do to stop that 'toilet' sound is: Once I start video conversation, right click on the Volume icon->Sound Preferences->Applications
then moving the skype slider a little bit, doesn't matter in which direction, just moving it and that nasty sound has gone.

image: http://imgbox.com/abq0wpLP

Post Reply