Libusb problem [Solved]

Discussions Regarding Software

Moderator: Moderators

Libusb problem [Solved]

Postby tek640 » Mon Apr 08, 2013 7:04

I am trying to use Flashtool, which is for flashing kernels and others stuff in Xperia phones. The problem is when I try to run it, I get a message which says that libusb version is 1.0.9 and the minimum requirement is 1.0.14. I tried to compile libusbx 1.0.14 but still flashtool cannot find it. After a little more searching I discover that flashtool search for libusb in directory /usr/local but sabayon put libusbx in directory /usr/portage. Is there a way to change the directory so Flashtool runs correctly? Or another way to made it run somehow?
Last edited by tek640 on Mon Apr 08, 2013 18:00, edited 1 time in total.
tek640
Young Hen
 
Posts: 35
Joined: Mon Mar 26, 2012 18:03

Re: Libusb problem

Postby colock » Mon Apr 08, 2013 11:06

Your findings are quite imprecise:

  • Sabayon does clearly NOT put anything in /usr/portage.
  • Maybe you found an ebuild for libusb in /usr/portage, where it is expected to be.

is Flashtool a precompiled binary? if so, it is compiled for x86 or x86_64 (i.e. 32bit or 64bit?). At any rate, libusb is 1.0.9, either a) wait for an upgrade from sabayon, b) install a new version of libusb with portage and the recompile any program linking to it [very not recommended] c) see if Flashtool relaly needs 1.0.14 or it was just compiled against it, in the latter case, see if you can find the sources and recompile Flashtool yourself against your current libusb.


Good luck!
colock
Simple Hen
 
Posts: 56
Joined: Mon Feb 25, 2013 12:01

Re: Libusb problem

Postby belcocco » Mon Apr 08, 2013 11:45

@colock +1

in addition, I do not know what flashtool, I'll tell you the general method, then see how to act.
If the library you want is in /usr/portage/ named 'libusbx', while the program looks for it in /usr/local directory, open a terminal as root and create a symbolic link with the command (general syntax):
#ln -s source_file target_file

In your case would be (only to see):
#ln -s /usr/portage/libusbx /usr/local/libusb

Ciao
belcocco
Technological Hen
 
Posts: 439
Joined: Sat Nov 29, 2008 18:53
Location: Milan, Italy

Re: Libusb problem

Postby sabayonino » Mon Apr 08, 2013 17:50

portage put its .ebuild in /usr/portage/<category>/name.ebuild

.ebuilds are not libraries !

all libreries are stored in /lib /lib32 /lib64 and /usr/lib /usr/lib32 /usr/lib64
User avatar
sabayonino
Sagely Hen
 
Posts: 2438
Joined: Sun Sep 21, 2008 1:12
Location: Italy

Re: Libusb problem

Postby tek640 » Mon Apr 08, 2013 17:59

@colock, sabayonino

Sorry, my mistake, it's ebuild and not library. But still I cannot find libusbx in lib64.

Flashtool is precompiled and it's compiled x86_64 as my system.
From your answers, I think I 'll wait for new version of libusb or I will search for older version of flashtool.

Thanks.
tek640
Young Hen
 
Posts: 35
Joined: Mon Mar 26, 2012 18:03


Return to Software in General

Who is online

Users browsing this forum: No registered users and 2 guests