Problem with KDEnlive

Discussions Regarding Software

Moderator: Moderators

Post Reply
vfafou
Young Hen
Posts: 33
Joined: Mon May 14, 2012 22:40

Problem with KDEnlive

Post by vfafou » Sun Mar 31, 2013 21:41

Hello!
I' m an openshot user since it was appeared to Ubuntu. Now I'm a Sabayon KDE user and I needed to use a video editor. I decided to give KDEnlive a try, but I can run it only as root. The console error I get when trying to run it as user is:

Code: Select all

libDeckLinkAPI.so: cannot open shared object file: No such file or directory
QCoreApplication::postEvent: Unexpected null receiver
detected format: YUV 4:2:2 (YUYV): YUYV
Size: 640x480: 1/30, 
Size: 320x240: 1/30, 
Size: 176x144: 1/30, 
Size: 160x120: 1/30,
The library libDeckLinkAPI.so exist in /usr/lib.
Does anyone have solved this issue?

Thank you in advance!

Stupot
Sagely Hen
Posts: 1665
Joined: Wed Feb 14, 2007 3:44
Location: St. Louis, MO, USA

Re: Problem with KDEnlive

Post by Stupot » Sun Mar 31, 2013 22:08

Looks like somebody else has this problem over in gentoo just like you.

http://forums.gentoo.org/viewtopic-p-7257912.html

Can you try what was tried here: http://www.kdenlive.org/mantis/view.php?id=3001
Hello,

After few days, in my case the solution was (I think so) to delete everything in /var/tmp/kdecache-user. After this both kdenlive 0.9.4 and from Daily Builds works fine. As I said before deleting just config files like kdenliverc in /home/user wasn't enough.

So everything works fine - solved.

vfafou
Young Hen
Posts: 33
Joined: Mon May 14, 2012 22:40

Re: Problem with KDEnlive

Post by vfafou » Mon Apr 01, 2013 21:26

Hello Stupot!
Thank you for replying!
I tried your suggestion but it didn't work.
I don't understand why I have to be root in order to run KDEnlive. Note that I hadn't tried to run it before...

Stupot
Sagely Hen
Posts: 1665
Joined: Wed Feb 14, 2007 3:44
Location: St. Louis, MO, USA

Re: Problem with KDEnlive

Post by Stupot » Mon Apr 01, 2013 22:33

I can run KDEnlive on my system as my usual user with no errors.

But the fact that you haven't run it before could be helpful in figuring out what is going on.

vfafou
Young Hen
Posts: 33
Joined: Mon May 14, 2012 22:40

Re: Problem with KDEnlive

Post by vfafou » Tue Apr 02, 2013 20:11

Any idea??? :cry: :cry: :cry:

Stupot
Sagely Hen
Posts: 1665
Joined: Wed Feb 14, 2007 3:44
Location: St. Louis, MO, USA

Re: Problem with KDEnlive

Post by Stupot » Wed Apr 03, 2013 17:35

Try deleting
$HOME/.kde/share/config/kdenliverc

Other than that, I can't really think of anything else with the information you've provided.

Ryuno-Ki
Old Dear Hen
Posts: 494
Joined: Mon Feb 27, 2012 22:15
Location: Southern Germany
Contact:

Re: Problem with KDEnlive

Post by Ryuno-Ki » Wed Apr 03, 2013 21:01

Stupot wrote:Try deleting
$HOME/.kde/share/config/kdenliverc
Or moving away

Code: Select all

mv $HOME/.kde/share/config/kdenliverc $HOME/.kde/share/config/kdenliverc-backup
German Wiki translator ◆ Want to contribute on the wiki? Ask the Bureaucrats!
Please, mark solved threads ◆ Posts unread and unansweredPackage requests

vfafou
Young Hen
Posts: 33
Joined: Mon May 14, 2012 22:40

Re: Problem with KDEnlive

Post by vfafou » Wed Apr 03, 2013 22:58

Hello again and thank you for your replies!
It will drive me crazy!!! There is not any kdenliverc file in ~/.kde4/share/config!
What can I do?

Matte88
Technological Hen
Posts: 399
Joined: Wed Dec 29, 2010 14:37
Location: @/etc/entropy/repositories.conf.d/entropy_sabayon-limbo

Re: Problem with KDEnlive

Post by Matte88 » Fri Apr 05, 2013 0:51

Try

Code: Select all

equo lt && equo dt && equo i kdenlive
Image
When I became the sun,
I shone life into the man's hearts.

Post Reply