Is udev-mount really needed?

Discussions Regarding Software

Moderator: Moderators

Is udev-mount really needed?

Postby Matte88 » Thu Mar 21, 2013 0:24

Continuing from here just to keep discussion clear and on its own.

What's happening with udev-mount? Is safe to remove it from runlevel (since it was not there before)?
Code: Select all
rc-service udev-mount describe
* mount devtmpfs on /dev
Code: Select all
cat /etc/mtab | grep udev
udev /dev devtmpfs rw,nosuid,relatime,size=10240k,nr_inodes=381156,mode=755 0 0
Code: Select all
cat /etc/fstab

#
# /etc/fstab
# Created by anaconda on Fri Mar  1 00:04:52 2013
#
# Accessible filesystems, by reference, are maintained under '/dev/disk'
# See man pages fstab(5), findfs(8), mount(8) and/or blkid(8) for more info
#
UUID=cdac4baf-00f3-42ba-a348-534b5ba647f5       /                       ext4    defaults        1 1
tmpfs                                           /dev/shm                tmpfs   defaults        0 0
devpts                                          /dev/pts                devpts  gid=5,mode=620  0 0
sysfs                                           /sys                    sysfs   defaults        0 0
proc                                            /proc                   proc    defaults        0 0
Image
When I became the sun,
I shone life into the man's hearts.
Matte88
Technological Hen
 
Posts: 399
Joined: Wed Dec 29, 2010 14:37
Location: @/etc/entropy/repositories.conf.d/entropy_sabayon-limbo

Re: Is udev-mount really needed?

Postby Fitzcarraldo » Fri Mar 22, 2013 16:11

I don't know, but I have it in the sysinit runlevel on my main laptop running up-to-date ~amd64 Gentoo:

Code: Select all
meshedgedx fitzcarraldo # rc-update show -v | grep udev
                 udev |                                        sysinit
           udev-mount |                                        sysinit

Code: Select all
meshedgedx fitzcarraldo # cat /etc/fstab
/dev/sda6    /                  ext4       user_xattr,noatime           1 1
/dev/sda7    /home              ext4       user_xattr,noatime           1 2
/dev/sda3    /boot              ext4       user_xattr,noatime,noauto    1 2
/dev/shm     /dev/shm           tmpfs      defaults                     0 0
/dev/sda5    swap               swap       defaults                     0 0
/dev/sda2    /media/Windows7    ntfs-3g    defaults                     0 0

Code: Select all
meshedgedx fitzcarraldo # cat /usr/src/linux/.config | grep DEVTMPFS
CONFIG_DEVTMPFS=y
# CONFIG_DEVTMPFS_MOUNT is not set

Read the following post in the Gentoo Forums, which I think I understand! Notice his Point 3, in particular.

http://forums.gentoo.org/viewtopic-p-72 ... ml#7232480
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7981
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom


Return to Software in General

Who is online

Users browsing this forum: No registered users and 3 guests