Entropy does not support anymore some packages [Solved]

Discussions Regarding Software

Moderator: Moderators

Entropy does not support anymore some packages [Solved]

Postby aia » Tue Jan 22, 2013 11:43

Hello forum,

I have Sabayon 10 in my laptop.
The last 2 months approximately when i do update i take a message that "these packages does not support any more".
Please remove for your own safety.
I dont remember very well the messages but it says something like that.After that i checked the version of the software from official site and i see that continues but in sabayon stop the developing of some package.
When i do update i realized that more and more packages does not support any more.
Some of them :
Dcbd, Acx Firmware, Boost, Linux Wlan Ng Firmware, Vdpau Video, Linux Wlan Ng Utils, phpmyadmin....e.t.c
I thought that Sabayon is rolling release distribution.Isn't it?
Could anyone tell me what is going on and why i take this messages?
I suppose that i must remove these packages which does not support any more from developers and to install it again from source code.Right?

Thanks!
Last edited by aia on Thu Jan 24, 2013 15:39, edited 1 time in total.
aia
Young Hen
 
Posts: 30
Joined: Wed Nov 28, 2012 11:43

Re: Entropy does not support anymore some packages

Postby Fitzcarraldo » Tue Jan 22, 2013 15:44

It could be that the message you are seeing relates to a slotted package.

Gentoo (and therefore SL) can have different versions of an application installed simultaneously if the package is slotted. For example, I have both cnijfilter-2.70-r1 and cnijfilter-3.20-r3 installed simultaneously because I use different models of Canon printer. Therefore, if you see a message from Entropy stating that an atom no longer supported, you need to look at the version as well as the package name. For example, if the message says foo-1.2.3 is no longer supported, you would explicitly remove foo-1.2.3 but it could be that foo-2.0.0 is installed (or needs to be installed). After you have removed foo-1.2.3 you can in any case run equo deptest && equo libtest just to check that everything is sane.
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7984
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: Entropy does not support anymore some packages

Postby albfneto » Tue Jan 22, 2013 21:27

the packages are not more supported i n Entropy. significates that they were no more updated by entropy, no more in entropy repositories.

but are packages installed in your comp.

but if you uses the packages, or your system uses, the you may simple not delete then, neither updates... lets the system still continuing using the old versions.
ALBERTO FEDERMAN NETO
albfneto
[email protected]
Favorite Distros: Sabayon, Gentoo, Mageia and OpenSUSE
User avatar
albfneto
Sagely Hen
 
Posts: 1725
Joined: Fri Nov 16, 2007 1:15
Location: Ribeirão Preto City, São Paulo State, Brazil

Re: Entropy does not support anymore some packages

Postby aia » Wed Jan 23, 2013 10:32

I try to explain you, that these packages that does not support any more, in the final version.
So there aren't new version for those packages.If does not support the last version why i have to put or keep the older version?

For instance:
I have in my system the package phpmyadmin.If you check from official site http://www.phpmyadmin.net/home_page/ you will see that the last version is 3.5.5.

Then i enter in my terminal:
Code: Select all
equo search phpmyadmin

and i see that the last version of the phpmyadmin is the 3.5.3.
And now when i am going to do update i get the message that for example this package phpmyadmin 3.5.3 does not support any more for your system.Please remove it for your own safety. I don't have other previous version for this package in my system.

My question is that if i remove this package phpmyadmin 3.5.3 (which is the only and the last version where i have in my system which developing from sabayon developers)i will not have any more this phpmyadmin and i need it.

So i guess that the solution is if i should ignore this message or to remove it and i have to install phpmyadmin manual or in an other case(other software) to do a compile.

But why entropy says this messages?
I didn't see similar message in any of package managment from any distribution.

I think that now i am clear and you can understant my message.

Thanks!
aia
Young Hen
 
Posts: 30
Joined: Wed Nov 28, 2012 11:43

Re: Entropy does not support anymore some packages

Postby Ryuno-Ki » Wed Jan 23, 2013 13:46

aia wrote:i will not have any more this phpmyadmin and i need it.

Learn administrating from CLI *scnr*
aia wrote:I didn't see similar message in any of package managment from any distribution.

I cannot confirm. I have a dozen of this message. Just ignore them. It won't hurt.
HP-Pavilion ◆ AMD Athlon™ 64 Processor 4000+ ◆ GeForce 6150SE nForce 430 ◆ 1 GiB RAM
German Wiki translator ◆ Want to contribute on the wiki? Ask the Bureaucrats!
Please, mark solved threads ◆ Posts unread and unansweredPackage requests ◆ Sabayon XI with MATE
Ryuno-Ki
Technological Hen
 
Posts: 437
Joined: Mon Feb 27, 2012 22:15
Location: Southern Germany

Re: Entropy does not support anymore some packages

Postby aia » Wed Jan 23, 2013 19:19

Learn administrating from CLI *scnr*

Υou are out of discussion.Τhis is not our topic.This was just my example for this package.

I cannot confirm. I have a dozen of this message. Just ignore them. It won't hurt.

I didn't say that it will hurt.Just I wonder.why happened that?And if someone wants to has the last version in his system what he must to do. To compile the programm from source code in the last version,or there is an other way?

Thanks
aia
Young Hen
 
Posts: 30
Joined: Wed Nov 28, 2012 11:43

Re: Entropy does not support anymore some packages

Postby Ryuno-Ki » Wed Jan 23, 2013 20:25

aia wrote:ust I wonder.why happened that?And if someone wants to has the last version in his system what he must to do.

It happens, because we have just a dozen (or less?) developer working on Sabayon Linux. You're welcome to contribute …
Before compiling I would have a look in portage. Install "e-file" therefore:
Code: Select all
# equo install app-portage/pfl
# exit
$ e-file phpmyadmin # didn't work for me right now …

In case you can't find it, have a look at Gentoo. Note, I've never touched an ebuild.
Oh, and be careful with e-file. It's not documented.

Edit: Oh, you could fill a feature request also …
HP-Pavilion ◆ AMD Athlon™ 64 Processor 4000+ ◆ GeForce 6150SE nForce 430 ◆ 1 GiB RAM
German Wiki translator ◆ Want to contribute on the wiki? Ask the Bureaucrats!
Please, mark solved threads ◆ Posts unread and unansweredPackage requests ◆ Sabayon XI with MATE
Ryuno-Ki
Technological Hen
 
Posts: 437
Joined: Mon Feb 27, 2012 22:15
Location: Southern Germany

Re: Entropy does not support anymore some packages

Postby aia » Thu Jan 24, 2013 15:38

Thank all for your help!
aia
Young Hen
 
Posts: 30
Joined: Wed Nov 28, 2012 11:43

Re: Entropy does not support anymore some packages [Solved]

Postby wolfden » Fri Jan 25, 2013 3:53

Just to be clear, there can be several reasons why a package is dropped, from no longer supported upstream to portage dropping it to it simply won't build against current stuff. Those are 3 quick reasons and there is other scenarios also such as package is renamed, picked up and supported in another package, things like that.
wolfden
Sharecropper
 
Posts: 9051
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA


Return to Software in General

Who is online

Users browsing this forum: No registered users and 1 guest