Can't get iBus to work with gedit and several others

Discussions Regarding Software

Moderator: Moderators

Post Reply
sdlion
Baby Hen
Posts: 1
Joined: Fri Nov 16, 2012 18:26

Can't get iBus to work with gedit and several others

Post by sdlion » Sun Nov 18, 2012 4:42

I'm using iBus with Mozc to write in japanese but now I can't write with accents in gedit and the like.

In Chromium is working fine. If I right click a textbox, under Input Methods I get "System (iBus (Intelligent Input Bus))" and I'm able to change to Japanese with Ctrl+Spacebar.
But on gedit and several others, in Input Methods I get "System (X Input Method)", one might think is just not using iBus, but with Ctrl+Spacebar it changes succesfully to Japanese. When I change de IM to "Simple" I get to write accents but I can't change to Japanese.

My .xprofile says:

Code: Select all

# IME and non-roman fonts support
# see Sabayon bug #2518
if [ -x "/usr/bin/ibus-setup" ]; then
	export GTK_IM_MODULE=ibus
	export [email protected]=ibus
	export QT_IM_MODULE=xim
fi
But if I check my environment variables:

Code: Select all

$ echo $GTK_IM_MODULE
[Nothing, it's not set]
$ echo $XMODIFIERS
@im=imsettings
$ echo $QT_IM_MODULE
ibus
If I try to force those variables with .xprofile eliminating the if block, the variables still won't be set.

Set them manually with export, won't make a change. Neither with:

Code: Select all

$ GTK_IM_MODULE=ibus gedit
.imsettings.log:

Code: Select all

[ 1353209542.962998]: IMSettings-Daemon[8870]: INFO: Starting imsettings-daemon...
[ 1353209542.963153]: IMSettings-Daemon[8870]: INFO:   [HOME=/home/ppc]
[ 1353209542.963184]: IMSettings-Daemon[8870]: INFO:   [XINPUTRCDIR=/etc/X11/xinit/]
[ 1353209542.963211]: IMSettings-Daemon[8870]: INFO:   [XINPUTDIR=/etc/X11/xinit/xinput.d/]

[ 1353209542.963237]: IMSettings-Daemon[8870]: INFO:   [MODULEDIR=/usr/lib/imsettings]

[ 1353209542.963267]: IMSettings-Daemon[8870]: INFO:   [MODULES=lxde, gsettings, xim, qt, gconf]


[ 1353209543.186500]: IMSettings-XIM backend[8870]: WARNING **: imsettings-xim XIM server isn't running.

[ 1353209543.216744]: IMSettings-LXDE backend[8870]: WARNING **: Unable to load the lxde configuration file.

[ 1353209543.233412]: IMSettings-XIM backend[8870]: WARNING **: imsettings-xim XIM server isn't running.

[ 1353209543.233806]: IMSettings-LXDE backend[8870]: WARNING **: Unable to load the lxde configuration file.

[ 1353209543.262536]: IMSettings-XIM backend[8870]: WARNING **: imsettings-xim XIM server isn't running.

[ 1353209543.262911]: IMSettings-LXDE backend[8870]: WARNING **: Unable to load the lxde configuration file.

[ 1353209543.280149]: IMSettings-XIM backend[8870]: WARNING **: imsettings-xim XIM server isn't running.

[ 1353209543.280534]: IMSettings-LXDE backend[8870]: WARNING **: Unable to load the lxde configuration file.

[ 1353209543.306905]: IMSettings-XIM backend[8870]: WARNING **: imsettings-xim XIM server isn't running.

[ 1353209543.307285]: IMSettings-LXDE backend[8870]: WARNING **: Unable to load the lxde configuration file.

[ 1353209543.324223]: IMSettings-XIM backend[8870]: WARNING **: imsettings-xim XIM server isn't running.

[ 1353209543.324595]: IMSettings-LXDE backend[8870]: WARNING **: Unable to load the lxde configuration file.
imsettings information
==========================
XINPUTRC: /home/ppc/.xinputrc
	  Fichero: «/home/ppc/.xinputrc» -> «/etc/X11/xinit/xinput.d/ibus.conf»
	  Tamaño: 33        	Bloques: 0          Bloque E/S: 4096   enlace simbólico
	Dispositivo: 808h/2056d	Nodo-i: 264711      Enlaces: 1
	Acceso: (0777/lrwxrwxrwx)  Uid: ( 1000/     ppc)   Gid: ( 1001/     ppc)
	      Acceso: 2012-11-17 20:37:30.612263961 -0600
	Modificación: 2012-11-17 20:36:59.185249057 -0600
	      Cambio: 2012-11-17 20:36:59.185249057 -0600
	    Creación: -
Is DBus enabled: yes
Is imsettings enabled: yes
Is GTK+ supported: 
[ 1353209543.398024]: IMSettings-XIM backend[8870]: WARNING **: imsettings-xim XIM server isn't running.

[ 1353209543.398402]: IMSettings-LXDE backend[8870]: WARNING **: Unable to load the lxde configuration file.

[ 1353209543.416289]: IMSettings-XIM backend[8870]: WARNING **: imsettings-xim XIM server isn't running.

[ 1353209543.416660]: IMSettings-LXDE backend[8870]: WARNING **: Unable to load the lxde configuration file.
yes
Is Qt supported: 
[ 1353209543.436289]: IMSettings-XIM backend[8870]: WARNING **: imsettings-xim XIM server isn't running.

[ 1353209543.436657]: IMSettings-LXDE backend[8870]: WARNING **: Unable to load the lxde configuration file.

[ 1353209543.454651]: IMSettings-XIM backend[8870]: WARNING **: imsettings-xim XIM server isn't running.

[ 1353209543.455051]: IMSettings-LXDE backend[8870]: WARNING **: Unable to load the lxde configuration file.
yes
DESKTOP: gnome
GUESS_DESKTOP: $GDMSESSION
DISABLE_IMSETTINGS: 
IMSETTINGS_DISABLE_DESKTOP_CHECK: 
DBUS_SESSION_BUS_ADDRESS: 
GTK_IM_MODULE: 
QT_IM_MODULE: ibus
XMODIFIERS: @im=imsettings
IMSETTINGS_MODULE: IBus
IMSETTINGS_INTEGRATE_DESKTOP: yes

[ 1353209576.072136]: IMSettings-Daemon[9208]: INFO: Starting imsettings-daemon...
[ 1353209576.072601]: IMSettings-Daemon[9208]: INFO:   [HOME=/home/ppc]
[ 1353209576.072648]: IMSettings-Daemon[9208]: INFO:   [XINPUTRCDIR=/etc/X11/xinit/]
[ 1353209576.072682]: IMSettings-Daemon[9208]: INFO:   [XINPUTDIR=/etc/X11/xinit/xinput.d/]

[ 1353209576.072716]: IMSettings-Daemon[9208]: INFO:   [MODULEDIR=/usr/lib/imsettings]

[ 1353209576.072751]: IMSettings-Daemon[9208]: INFO:   [MODULES=lxde, gsettings, xim, qt, gconf]


[ 1353209576.079930]: IMSettings-XIM backend[9208]: WARNING **: imsettings-xim XIM server isn't running.

[ 1353209576.081025]: IMSettings-LXDE backend[9208]: WARNING **: Unable to load the lxde configuration file.
[ 1353209576.590319]: IMSettings-Daemon[9208]: INFO: Attempting to switch IM to IBus [lang=es_MX.UTF-8, update=false]
[ 1353209576.757214]: IMSettings-Daemon[9208]: INFO:   no need to invoke any auxiliary process for IBus
[ 1353209576.757323]: IMSettings-Daemon[9208]: INFO:   Starting the main process for IBus [lang:es_MX.UTF-8]
[ 1353209577.348657]: IMSettings-Daemon[9208]: INFO:   Started IBus: [process: /usr/bin/ibus-daemon --xim, lang: es_MX.UTF-8, pid: 9525, id: 16, time: 2012-11-18T03:32:57.348485Z
[ 1353209577.348791]: IMSettings-GConf backend[9208]: INFO: Setting up ibus:xim as gtk+ immodule
[ 1353209578.257045]: IMSettings-Qt backend[9208]: INFO: Setting up ibus as Qt immodule
[ 1353209581.747654]: IMSettings-XIM backend[9208]: INFO: Setting up ibus as XIM
[ 1353209581.748036]: IMSettings-GSettings backend[9208]: INFO: Setting up ibus:xim as gtk+ immodule

[ 1353209581.749236]: IMSettings-LXDE backend[9208]: WARNING **: Unable to read the LXDE configuration file.

[ 1353209582.289062]: IMSettings-LXDE backend[9208]: WARNING **: the changes will not be applied until your next login.
Locale:

Code: Select all

LANG=es_MX.UTF-8
LC_CTYPE="es_MX.UTF-8"
LC_NUMERIC="es_MX.UTF-8"
LC_TIME="es_MX.UTF-8"
LC_COLLATE="es_MX.UTF-8"
LC_MONETARY="es_MX.UTF-8"
LC_MESSAGES="es_MX.UTF-8"
LC_PAPER="es_MX.UTF-8"
LC_NAME="es_MX.UTF-8"
LC_ADDRESS="es_MX.UTF-8"
LC_TELEPHONE="es_MX.UTF-8"
LC_MEASUREMENT="es_MX.UTF-8"
LC_IDENTIFICATION="es_MX.UTF-8"
LC_ALL=
/etc/locale.gen:

Code: Select all

es_MX.UTF-8 UTF-8
es_MX ISO-8859-1
ja_JP.EUC-JP EUC-JP
ja_JP.UTF-8 UTF-8
en_US.UTF-8 UTF-8
en_US ISO-8859-1
en_US.UTF-8 UTF-8
en_US ISO-8859-1
I've already installed: ibus, ibus-qt, mozc, imsettings

I've also tried scim anthy, but I won't even run.

Post Reply