Java not working? [Solved]

Discussions Regarding Software

Moderator: Moderators

Java not working? [Solved]

Postby Matt » Sat Oct 29, 2011 1:54

I'm having a bizarre problem with Java. It must be something i'm doing but i can't work it out. The back story is that i've just started learning java, i'm as far along as writing the Hello World program. Anyway from within Eclipse i can compile and run programs, however from a terminal i can still compile just fine but when i try to run said program
Code: Select all
java HelloWorld.class

i get a this error
Code: Select all
Exception in thread "main" java.lang.NoClassDefFoundError: HelloWorld/class


I've tried removing Icedtea in favour of sun-jdk but no change. Google searches have found me nothing helpful either but i may not have searched for the right question yet. I'm sure this is a case of equipment being superior to operator but any suggestions would be greatly appreciated.

Cheers,

Matt
Matt
Baby Hen
 
Posts: 5
Joined: Sat Oct 29, 2011 1:37

Re: Java not working??

Postby Matt » Sat Oct 29, 2011 6:05

Got it! Exactly as i thought, equipment superior to operator
:oops:
Matt
Baby Hen
 
Posts: 5
Joined: Sat Oct 29, 2011 1:37

Re: Java not working??

Postby micia » Sat Oct 29, 2011 10:00

Hi Matt, welcome to the Sabayon Linux Forums and Community :mrgreen:

Remember to mark your threads as solved when you find a solution, as explained in:
viewtopic.php?f=59&t=17059
I will do it for you this time.

Also, if you find out why it was not working or which was the problem, it is better to explain how you solved it, no matter how simple the solution looks, maybe somebody else is having the same issue :)
micia
Sagely Hen
 
Posts: 2718
Joined: Wed Nov 26, 2008 16:41


Return to Software in General

Who is online

Users browsing this forum: No registered users and 1 guest