music on console mocp can't decode .wav files...[Solved]

Discussions Regarding Software

Moderator: Moderators

music on console mocp can't decode .wav files...[Solved]

Postby joe3 » Sat Sep 24, 2011 17:19

My problem with moc was solved in: https://forum.sabayon.org/viewtopic.php?f=57&t=25422 But I think this largely ignored posting does a better job of describing the actual problem, so I'll leave it in place adding only this topnote and the [Solved] marker, in short though, if your having this problem, look at recompiling with different flags. Not sure which of several I added (see other thread) actually solved it however. But the other thread does include some good useful info {kindly provided by Fitzcarraldo} on safely using portage to emerge moc with diferent flags on an entropy managed Sabayon system... Worth the read just for that I think.

I like to use moc (mocp) to play music while I'm working. I multi-boot several Linux distros and since moc usually works well for me I promptly installed it in Sabayon:
Code: Select all
 /home/jtwdyp
UnderTree=-> equo search media-sound/moc
>>  @@ Searching...
>>      @@ Package: media-sound/moc-2.5.0_alpha4_p20110428 branch: 5, [sabayonlinux.org]
>>         Available:     version: 2.5.0_alpha4_p20110428 ~ tag: NoTag ~ revision: 0
>>         Installed:     version: 2.5.0_alpha4_p20110428 ~ tag: NoTag ~ revision: 0
>>         Slot:          0
>>         Homepage:      http://moc.daper.net
>>         Description:   Music On Console - ncurses interface
>>                        for playing audio files
>>         License:       GPL-2
>>  Keywords:  media-sound/moc
>>  Found:     1 entries
 /home/jtwdyp
UnderTree=->

My Sabayon 6 installation is just new enough that it wasn't until yesterday that I got around to wanting some music while working on something... Trouble is mocp wasn't working.,,

I mounted my music partition and tried to add music folder contents like usual. But the command failed. It was like it couldn't find the music files. (as it happens they are all wav files BTW...)

So I inported the ~/.moc/playlist.m3u file from one of my other Linux (I think it was Arch)
and suddenly it displayed the long pathnames of the music files in the right hand panel. But when I tried to turn full pathnames off with "P" it said it turned them off but the full path was still displayed. Then I tried to select a title for playback with the enter key... Nothing happened. So I tried "n" the next selection and got this error
Code: Select all
[] (187!) Can't get decoder for /home/MusicStuff/theMusicStuff/LindaDisk/03-LindaDisk.wav
At which point I did a man mocp which said {in the "Files" section} that: "/usr/share/moc/decoder_plugins" was the "Default directories for audio decoder plugins." Yet when I tried to look there to see what plugins were there I discovered the directory didn't exist.
Code: Select all
JtWdyP -> /home/jtwdyp
> ls -al /usr/share/moc
total 16
drwxr-xr-x   3 root root 4096 Sep 10 02:37 .
drwxr-xr-x 285 root root 8192 Sep 24 11:05 ..
drwxr-xr-x   2 root root 4096 Sep 10 02:37 themes
JtWdyP -> /home/jtwdyp
>


What can I do to get moc functional in Sabayon???
joe3
Advanced Hen
 
Posts: 200
Joined: Sun May 06, 2007 21:28

Return to Software in General

Who is online

Users browsing this forum: No registered users and 1 guest