Transmission 2.33 [Solved]

Discussions Regarding Software

Moderator: Moderators

Transmission 2.33 [Solved]

Postby grimly64 » Sat Aug 13, 2011 2:44

Updated Transmission to 2.33 - worked fine. (using KDE 64bit with all the latest updates)

Then did
Equo Update
Equo Upgrade
emerge --sync && layman --sync sabayon
lafilefixer --justfixit
equo deptest
equo libtest
revdep-rebuild

Now Transmission will not show gui, a box appears and dissappears immediately, no icon in tray showing that it would be running. Try again and it says it's already running but still no interface, System Monitor shows it running, try to "kill" to try again, but "kill" does nothing "force-kill" does nothing.

Have un-installed and installed. Cannot get Transmission to run anymore.

dmesg shows:

[ 3165.357083] transmission-gt[8750] general protection ip:7fdc3b2212d8 sp:7fdc2f1f9280 error:0 in libminiupnpc.so.8[7fdc3b21d000+a000]
[ 3209.341813] transmission-gt[10480] general protection ip:7f68ad2bc2d8 sp:7f68a1294280 error:0 in libminiupnpc.so.8[7f68ad2b8000+a000]
[ 3427.862930] transmission-gt[19556] general protection ip:7f9ea48f62d8 sp:7f9e988ce280 error:0 in libminiupnpc.so.8[7f9ea48f2000+a000]


*Update to Entrorpy changed Transmission to 2.33r1. Running normal.
Last edited by grimly64 on Tue Aug 16, 2011 5:52, edited 2 times in total.
grimly64
Simple Hen
 
Posts: 43
Joined: Sun Apr 17, 2011 2:38

Re: Transmission 2.33

Postby grimly64 » Sat Aug 13, 2011 2:54

Problem with net-libs/miniupnpc-1.6

Seems there is a patch
https://bugs.gentoo.org/376795?id=376795

How do I run the patch?

Got this from http://en.gentoo-wiki.com/wiki/Creating ... ted_Ebuild
But I just can't make any sense of it. Trying to figure this out, but feels like everyone knows how to patch, except me, lol

How to Fix

Sometimes, some fixes are necessary. Don't forget to produce the manifest after you edit ebuild or added patches.
[edit] Adding a patch

What if you have a patch at my-new-patch.patch, and want to apply it? Easy. Put the file under .../category/package/files/ Add to ebuild:
File: /usr/local/portage/www-client/foo-zilla/foo-zilla-2.0.9.ebuild

src_unpack() {
unpack ${A}
cd "${S}"
epatch "${FILESDIR}"/my-new-patch.patch
}

If src_unpack is there, then put epatch after cd "${S}".

Also, add

inherit eutils

near the beginning of the ebuild so that the ebuild can use epatch (if there's already an inherit line, make sure it contains eutils).

Don't forget to update manifest:
ebuild /usr/local/portage/www-client/foo-zilla/foo-zilla-2.0.8.ebuild digest

Note: if the ebuild inherits cvs, for example, you have to use: cvs_src_unpack in place of unpack ${A}. Another example of this kind is git.
grimly64
Simple Hen
 
Posts: 43
Joined: Sun Apr 17, 2011 2:38

Re: Transmission 2.33

Postby joost » Sat Aug 13, 2011 10:23

Don't do that.
Report it on our bugzilla so it gets fixed for everybody.
joost
Sagely Hen
 
Posts: 2603
Joined: Fri Nov 17, 2006 12:11
Location: The Netherlands

Re: Transmission 2.33

Postby grimly64 » Sat Aug 13, 2011 17:43

Bug 2623 Submitted – transmission-daemon NOT running with >=net-libs/miniupnpc-1.6

I hope the originally posted bug, https://bugs.gentoo.org/376795?id=376795 would include what would normally be required for a bug report. Sorry, my first time reporting a bug.
grimly64
Simple Hen
 
Posts: 43
Joined: Sun Apr 17, 2011 2:38


Return to Software in General

Who is online

Users browsing this forum: No registered users and 1 guest

cron