Guake won't start [Solved]

Discussions Regarding Software

Moderator: Moderators

Guake won't start [Solved]

Postby svantoviit » Fri Aug 12, 2011 12:05

>> @@ Package: x11-terms/guake-0.4.2 branch: 5, [sabayonlinux.org]

Code: Select all
 $ guake
Traceback (most recent call last):
  File "/usr/lib64/guake/guake.py", line 1353, in <module>
    if not main():
  File "/usr/lib64/guake/guake.py", line 1296, in main
    instance = Guake()
  File "/usr/lib64/guake/guake.py", line 649, in __init__
    notification.show()
glib.GError: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.Notifications was not provided by any .service files

Any hints how to get guake work again?
Last edited by svantoviit on Fri Aug 12, 2011 14:08, edited 1 time in total.
svantoviit
Old Dear Hen
 
Posts: 651
Joined: Sun Feb 28, 2010 17:55

Re: Guake won't start

Postby joost » Fri Aug 12, 2011 12:07

joost
Sagely Hen
 
Posts: 2582
Joined: Fri Nov 17, 2006 12:11
Location: The Netherlands

Re: Guake won't start

Postby svantoviit » Fri Aug 12, 2011 12:33

I'm still on Gnome 2 and using notify-osd.

Code: Select all
>>  @@ Searching...
>>      @@ Package: x11-misc/notify-osd-0.7.1 branch: 5, [__system__]
>>         Installed:     version: 0.7.1 ~ tag: NoTag ~ revision: 0
>>         Slot:          0
>>         Homepage:      http://git.gnome.org/browse/notification-daemon/
>>         Description:   Notification daemon
>>         License:       GPL-2
>>      @@ Package: x11-themes/notify-osd-icons-0.7 branch: 5, [__system__]
>>         Installed:     version: 0.7 ~ tag: NoTag ~ revision: 2
>>         Slot:          0
>>         Homepage:      http://launchpad.net/notify-osd
>>         Description:   Icons for on-screen-display notification
>>                        agent
>>         License:       CCPL-Attribution-ShareAlike-3.0
>>  Keywords:  notify-osd
>>  Found:     2 entries

Code: Select all
>>  @@ Searching...
>>      @@ Package: virtual/notification-daemon-0 branch: 5, [sabayonlinux.org]
>>         Available:     version: 0 ~ tag: NoTag ~ revision: 3
>>         Installed:     version: 0 ~ tag: NoTag ~ revision: 3
>>         Slot:          0
>>         Description:   Virtual for notification daemon
>>                        dbus service
>>         License:       
>>      @@ Package: x11-misc/notification-daemon-0.7.1 branch: 5, [sabayonlinux.org]
>>         Available:     version: 0.7.1 ~ tag: NoTag ~ revision: 0
>>         Installed:     version: Not installed ~ tag: N/A ~ revision: N/A
>>         Slot:          0
>>         Homepage:      http://git.gnome.org/browse/notification-daemon/
>>         Description:   Notification daemon
>>         License:       GPL-2
>>  Keywords:  notification-daemon
>>  Found:     2 entries

It's the same on Xfce, but no problems in an awesome session.
svantoviit
Old Dear Hen
 
Posts: 651
Joined: Sun Feb 28, 2010 17:55

Re: Guake won't start

Postby joost » Fri Aug 12, 2011 12:47

heh, I noticed the python bindings never got bumped after notification stuff got updated.
I'll bump it in Entropy and we'll see.
joost
Sagely Hen
 
Posts: 2582
Joined: Fri Nov 17, 2006 12:11
Location: The Netherlands

Re: Guake won't start

Postby svantoviit » Fri Aug 12, 2011 12:54

Yeah, and I got a similar error with Bleachbit which won't start too.
Code: Select all
$ bleachbit
Traceback (most recent call last):
  File "/usr/bin/bleachbit", line 42, in <module>
    import bleachbit.GUI
ImportError: No module named bleachbit.GUI

Could it be for the same reason?
svantoviit
Old Dear Hen
 
Posts: 651
Joined: Sun Feb 28, 2010 17:55

Re: Guake won't start

Postby joost » Fri Aug 12, 2011 13:30

Nope that isn´t it.

I do have a workaround.
If you install xfce-extra/xfce4-notifyd you can get guake to work.
joost
Sagely Hen
 
Posts: 2582
Joined: Fri Nov 17, 2006 12:11
Location: The Netherlands

Re: Guake won't start

Postby svantoviit » Fri Aug 12, 2011 14:07

Installing xfce-extra/xfce4-notifyd as suggested solved the Guake issue on Gnome and Xfce.
Thanks Joost!
svantoviit
Old Dear Hen
 
Posts: 651
Joined: Sun Feb 28, 2010 17:55

Re: Guake won't start [Solved]

Postby rumahsiput » Sat Aug 13, 2011 15:35

Same problem; guake won't start on my newly installed Sabayon 6/xfce4 on netbook i686 Intel(R) Atom(TM) CPU N450 @ 1.66GHz GenuineIntel GNU/Linux
Unfortunately xfce-extra/xfce4-notifyd is not available in Entropy Store.
Tried emerge and I got this:
Code: Select all
Calculating dependencies... done!
[ebuild  N     ] dev-util/pkgconfig-0.26  USE="-hardened"
[ebuild  N    #] xfce-extra/xfce4-notifyd-0.2.2  USE="-debug"

The following mask changes are necessary to proceed:
#required by xfce-extra/xfce4-notifyd (argument)
>=xfce-extra/xfce4-notifyd-0.2.2

Use --autounmask-write to write changes to config files (honoring CONFIG_PROTECT).

Not sure how to proceed from here. Appreciate some help. Thank you.
rumahsiput
Simple Hen
 
Posts: 50
Joined: Sun Mar 28, 2010 6:22

Re: Guake won't start [Solved]

Postby joost » Sat Aug 13, 2011 16:32

It will be in sabayon-weekly repository tomorrow.
joost
Sagely Hen
 
Posts: 2582
Joined: Fri Nov 17, 2006 12:11
Location: The Netherlands

Re: Guake won't start [Solved]

Postby rumahsiput » Sun Aug 14, 2011 3:18

Thank you very much. Guake worked and so did other things like mixer and cheese after update (still struggling with skype but that's another story). I'm glad I switched to xfce. It's really nice. Thanks!
P/S With mixer working, I've got Skype going too!
rumahsiput
Simple Hen
 
Posts: 50
Joined: Sun Mar 28, 2010 6:22


Return to Software in General

Who is online

Users browsing this forum: No registered users and 1 guest

cron