Problem with Apache

Discussions Regarding Software

Moderator: Moderators

Problem with Apache

Postby Ignatius881 » Sat Jul 09, 2011 19:58

Hello.

I've a problem with Apache DocumentRoot directory. After changing it from /var/www to /home/myuser/www, it shows a message error.

I've followed this thread: http://forum.sabayon.org/viewtopic.php?t=23291, but it doesn't work to me.
Ignatius881
Baby Hen
 
Posts: 17
Joined: Sat Jan 23, 2010 19:37
Location: Oviedo


Re: Problem with Apache

Postby Ignatius881 » Sat Jul 09, 2011 22:49

It's the typical message when a webpage is not found or something:

Forbidden

You don't have permission to access / on this server.

Apache Server at 127.0.0.1 Port 80
Ignatius881
Baby Hen
 
Posts: 17
Joined: Sat Jan 23, 2010 19:37
Location: Oviedo


Re: Problem with Apache

Postby Ignatius881 » Sun Jul 10, 2011 11:52

It doesn't work.

I'll show the files I've edited.

/etc/apache2/vhosts.d/00_default_vhost.conf:

Code: Select all
# Virtual Hosts
#
# If you want to maintain multiple domains/hostnames on your
# machine you can setup VirtualHost containers for them. Most configurations
# use only name-based virtual hosts so the server doesn't need to worry about
# IP addresses. This is indicated by the asterisks in the directives below.
#
# Please see the documentation at
# <URL:http://httpd.apache.org/docs/2.2/vhosts/>
# for further details before you try to setup virtual hosts.
#
# You may use the command line option '-S' to verify your virtual host
# configuration.

<IfDefine DEFAULT_VHOST>
# see bug #178966 why this is in here

# Listen: Allows you to bind Apache to specific IP addresses and/or
# ports, instead of the default. See also the <VirtualHost>
# directive.
#
# Change this to Listen on specific IP addresses as shown below to
# prevent Apache from glomming onto all bound IP addresses.
#
#Listen 12.34.56.78:80
Listen 80

# Use name-based virtual hosting.
NameVirtualHost *:80

# When virtual hosts are enabled, the main host defined in the default
# httpd.conf configuration will go away. We redefine it here so that it is
# still available.
#
# If you disable this vhost by removing -D DEFAULT_VHOST from
# /etc/conf.d/apache2, the first defined virtual host elsewhere will be
# the default.
<VirtualHost *:80>
   DocumentRoot "/home/ignacio/www"
   ServerName sabayon
   Include /etc/apache2/vhosts.d/default_vhost.include

   <IfModule mpm_peruser_module>
      ServerEnvironment apache apache
   </IfModule>
</VirtualHost>
</IfDefine>

# vim: ts=4 filetype=apache


/etc/apache2/vhosts.d/default_vhost.include:

Code: Select all
# ServerAdmin: Your address, where problems with the server should be
# e-mailed.  This address appears on some server-generated pages, such
# as error documents.  e.g. [email protected]
ServerAdmin [email protected]

# DocumentRoot: The directory out of which you will serve your
# documents. By default, all requests are taken from this directory, but
# symbolic links and aliases may be used to point to other locations.
#
# If you change this to something that isn't under /var/www then suexec
# will no longer work.
DocumentRoot "/home/ignacio/www"

# This should be changed to whatever you set DocumentRoot to.
<Directory "/home/ignacio/www">
   # Possible values for the Options directive are "None", "All",
   # or any combination of:
   #   Indexes Includes FollowSymLinks SymLinksifOwnerMatch ExecCGI MultiViews
   #
   # Note that "MultiViews" must be named *explicitly* --- "Options All"
   # doesn't give it to you.
   #
   # The Options directive is both complicated and important.  Please see
   # http://httpd.apache.org/docs/2.2/mod/core.html#options
   # for more information.
   Options Indexes FollowSymLinks

   # AllowOverride controls what directives may be placed in .htaccess files.
   # It can be "All", "None", or any combination of the keywords:
   #   Options FileInfo AuthConfig Limit
   AllowOverride All

   # Controls who can get stuff from this server.
   Order allow,deny
   Allow from all
</Directory>

<IfModule alias_module>
   # Redirect: Allows you to tell clients about documents that used to
   # exist in your server's namespace, but do not anymore. The client
   # will make a new request for the document at its new location.
   # Example:
   #   Redirect permanent /foo http://www.example.com/bar

   # Alias: Maps web paths into filesystem paths and is used to
   # access content that does not live under the DocumentRoot.
   # Example:
   #   Alias /webpath /full/filesystem/path
   #
   # If you include a trailing / on /webpath then the server will
   # require it to be present in the URL.  You will also likely
   # need to provide a <Directory> section to allow access to
   # the filesystem path.

   # ScriptAlias: This controls which directories contain server scripts.
   # ScriptAliases are essentially the same as Aliases, except that
   # documents in the target directory are treated as applications and
   # run by the server when requested rather than as documents sent to the
   # client.  The same rules about trailing "/" apply to ScriptAlias
   # directives as to Alias.
   ScriptAlias /cgi-bin/ "/var/www/localhost/cgi-bin/"
</IfModule>

# "/var/www/localhost/cgi-bin" should be changed to whatever your ScriptAliased
# CGI directory exists, if you have that configured.
<Directory "/var/www/localhost/cgi-bin">
   AllowOverride None
   Options None
   Order allow,deny
   Allow from all
</Directory>

# vim: ts=4 filetype=apache
Ignatius881
Baby Hen
 
Posts: 17
Joined: Sat Jan 23, 2010 19:37
Location: Oviedo

Re: Problem with Apache

Postby Thev00d00 » Mon Jul 11, 2011 20:45

This is clearly permissions being incorrect. Sabayonino is right, however remember that ALL THE PARENT directories need to be readable by the apache user otherwise the apache will still not be able to read it, hence the denied.
Image
Please report Bugs on the Bugzilla, not forum
Please Adopt an Unanswered thread
Website / Blog : v00d00.net
twitter: Follow Me
G+: Circle Me
Thev00d00
Generally Awesome (tm)
 
Posts: 1472
Joined: Wed Feb 21, 2007 15:52
Location: United Kingdom

Re: Problem with Apache

Postby sabayonino » Tue Jul 12, 2011 12:10

Thev00d00 wrote:This is clearly permissions being incorrect. Sabayonino is right, however remember that ALL THE PARENT directories need to be readable by the apache user otherwise the apache will still not be able to read it, hence the denied.
:roll:
you're right.
User avatar
sabayonino
Sagely Hen
 
Posts: 2533
Joined: Sun Sep 21, 2008 1:12
Location: Italy


Return to Software in General

Who is online

Users browsing this forum: No registered users and 1 guest