input chinese characters

Discussions Regarding Software

Moderator: Moderators

Post Reply
hanz
Baby Hen
Posts: 15
Joined: Tue Jul 07, 2009 11:22

input chinese characters

Post by hanz » Thu Jul 23, 2009 5:15

hi,

does anyone know how it's possible to input chinese characters using the pinyin system - on sabayon or on linux in gerneral.
on windows i have this little language-switch icon in the lower right corner.
is it possible to get something like this on sabayon/linux?

thanks, hannes

DHalens
Old Dear Hen
Posts: 933
Joined: Thu Apr 10, 2008 23:08
Location: Canary Islands, Spain

Re: input chinese characters

Post by DHalens » Thu Jul 23, 2009 5:43

I suggest you to use ibus.
You'll probably have to add gentoo-china layman with layman -a gentoo-china and then install it with emerge -va ibus ibus-pinyin

Ibus has an issue with deadkeys under kde4, that's the reason to not having it yet in entropy...
Former Sabayon staff (retired).
For any personal questions or whatever, contact me trough my G+ profile

User avatar
Fitzcarraldo
Sagely Hen
Posts: 8116
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom
Contact:

Re: input chinese characters

Post by Fitzcarraldo » Thu Jul 23, 2009 10:54

Although some of the package version numbers will probably have changed, take a look the Nov. 2007 thread in the SL forum: Personal summary of installing SCIM and Chewing input method which also mentions how to use Pinyin rather than Chewing.

SL is customised Gentoo, so you can also have a look in the Gentoo Chinese forum.

Other useful resources are Gentoo Linux Localization Guide, Using UTF-8 with Gentoo and the well-illustrated guide A Quick Primer On Unicode and Software Internationalization Under Linux and UNIX.

hanz
Baby Hen
Posts: 15
Joined: Tue Jul 07, 2009 11:22

Re: input chinese characters

Post by hanz » Fri Jul 24, 2009 12:51

Fitzcarraldo wrote:... take a look the Nov. 2007 thread in the SL forum: Personal summary of installing SCIM and Chewing input method which also mentions how to use Pinyin rather than Chewing.
ok, that helped a lot, thank you!
after restart fluxbox i'm able to get the menu with ctrl+space in firefox. but it's not poping up in skype or open office.
do you know how i can get it to work there either?

but for so far... 谢谢你!

edit.
found a solution for skype:
I'm using Mandriva 2007.1 and GNOME 2.18. I use the command "skype | scim". It works for me.
(http://forum.skype.com/index.php?showtopic=70843)

but i don't get why it's not working in oowriter. it seems he graps the control+space command or something.


hanz
Baby Hen
Posts: 15
Joined: Tue Jul 07, 2009 11:22

Re: input chinese characters

Post by hanz » Thu Mar 18, 2010 0:24

I just installed the newest 5.x version and also the newest scim-package.
But I can't get scim to work with chinese characters again.
I guess the first problem is, that the locale just shows "en_US.UTF-8" for all the diffrent types. How do I extend these? I guess it's a pretty basic thing, but my Linux-knowlegde is also pretty basic.

I tried doing this:

Code: Select all

localedef -i en_AU -f UTF-8 en_AU.UTF-8
But after doing locale I just get this again:

Code: Select all

LANG=en_US.UTF-8
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=en_US.UTF-8
Doing locale -a I now get:

Code: Select all

C
en_US
en_US.iso88591
en_US.utf8
POSIX
zh_CN.utf8
scim itself is running, but I just can choose between "RAW Code" and "English/European".

User avatar
Fitzcarraldo
Sagely Hen
Posts: 8116
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom
Contact:

Re: input chinese characters

Post by Fitzcarraldo » Thu Mar 18, 2010 0:30

Don't know, but have a look at the Gentoo Linux Localization Guide which covers setting up locales correctly.

(BTW, beware of the sections in the Gentoo Linux Localization Guide that relate to the time zone and hardware clock, as the configurations in that guide are currently still for Baselayout-1 installations, i.e. before Baselayout-2 and OpenRC. SL uses Baselayout-2 and OpenRC, so for the time zone and hardware clock configuration you should follow the article in the SL Wiki: HOWTO: Clock, Time, UTC, Dual boot with Windows.)

hanz
Baby Hen
Posts: 15
Joined: Tue Jul 07, 2009 11:22

Re: input chinese characters

Post by hanz » Thu Mar 18, 2010 10:41

thanks fitz, i'll have look at that.

hanz
Baby Hen
Posts: 15
Joined: Tue Jul 07, 2009 11:22

Re: input chinese characters

Post by hanz » Sun Mar 21, 2010 23:33

hm, so I added zh_CN.UTF-8 to the locale.gen and did locale-gen.
i get:

Code: Select all

# locale -a
C
en_US
en_US.iso88591
en_US.utf8
POSIX
zh_CN.utf8

Code: Select all

# locale
LANG=en_US.UTF-8
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=en_US.UTF-8
still missing the chinese locale. I don't get it.
I mean. It has to get listed there, to get chinese input with scim to work, right?
in sabayon 4.x it just worked fine.

User avatar
Fitzcarraldo
Sagely Hen
Posts: 8116
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom
Contact:

Re: input chinese characters

Post by Fitzcarraldo » Fri Jun 04, 2010 7:57

I wonder if the environment variable LC_ALL is causing the problem. See Environment Variables, which states that:
This variable determines the values for all locale categories. The value of the LC_ALL environment variable has precedence over any of the other environment variables starting with LC_ (LC_COLLATE, LC_CTYPE, LC_MESSAGES, LC_MONETARY, LC_NUMERIC, LC_TIME) and the LANG environment variable.

Post Reply