Rootfs won't mount in rw with kernel .29 [Solved]

Discussions Regarding Software

Moderator: Moderators

Rootfs won't mount in rw with kernel .29 [Solved]

Postby BlueAngelTC » Tue May 12, 2009 9:08

Hi to everybody,
I'm new to the forum and this is my first post so please don't blame me immediately: I made a search for similar problem but I didn't find anything similar. If a similar problem exist forgive me for a double post.
Also I'm unsure if this is the correct section: again forgive me if I'm wrong.

Anyway I have a problem which happened almost a month ago but I had the time for write just now: the kernel 2.6.29 won't mount the rootfs in read write, it does only in read only. Of course this mounting follow a long sequence of crashes.
I tried to specify in grub to mount the partition with "rw" to force read/write but the rootfs still mount as read only and the system won't boot, nor I'm able to login after the system crashes continuosly (login prompt appear but fail).

I'm not able to gather logs, after booting I can't login so I'm unable to read anything (anyway most of log files would not be wrote).

I'm using Sabayon 4.1 with lastest update (since yesterday), the main partition is an extended partition with ext4 and this happend only with kernel 2.6.29, kernels prior this version work with no problem.

Does anyone have an idea?
Thank you in advance for your time.
BlueAngelTC
Baby Hen
 
Posts: 2
Joined: Sun Apr 19, 2009 11:26

Re: Rootfs won't mount in rw with kernel .29

Postby Thev00d00 » Tue May 12, 2009 9:18

Welcome!

There is a sticky with this exact issue, the "what to do before world updating" thread...

If you upgrade to kernel 2.6.29 and have ext4, you have to edit you /etc/fstab file and remove the extents option as it is now default
so you will have a line like

Code: Select all
/dev/sdb8       /                       ext4    extents,user_xattr,noatime 1 1

THIS IS WRONG NOW

You need to change it so it looks like:

Code: Select all
/dev/sdb8       /                       ext4    user_xattr,noatime 1 1

THIS IS CORRECT

if you don't remove the extents option, your system will be stuck in Read Only mode and nothing will start up, you will have to reboot to the previous kernel to edit the /etc/fstab file than reboot back to .29


Linkage: viewtopic.php?f=57&t=16399
Image
Please report Bugs on the Bugzilla, not forum
Please Adopt an Unanswered thread
Website / Blog : v00d00.net
twitter: Follow Me
G+: Circle Me
Thev00d00
Generally Awesome (tm)
 
Posts: 1472
Joined: Wed Feb 21, 2007 15:52
Location: United Kingdom

Re: Rootfs won't mount in rw with kernel .29

Postby BlueAngelTC » Tue May 12, 2009 9:42

Thank you very much.

Sorry for the double post then.
BlueAngelTC
Baby Hen
 
Posts: 2
Joined: Sun Apr 19, 2009 11:26


Return to Software in General

Who is online

Users browsing this forum: No registered users and 1 guest