Discussions Regarding Software

Moderator: Moderators


Postby howiebinnz » Mon Apr 06, 2009 11:41

have been using sabayon now for a few months but really a bit of a windows convert, so a lot of the stuff is still very new. anyway have been really happy with sl4.1 wife has been playing pysol - her favourite solitaire card game and it works no problems. i saw that pysolfc is also out but not in portage, downloaded it and put it in its own folder and tried to start it ( but terminal just says:
Code: Select all
bash: command not found

if i enter pysol at command line then the "old" pysol starts. have tried uninstalling pysol, but same problem. i presume this is possibly something to do with python ??? any help appreciated. every thing i think is up to date as far as equo/spritz is concerned. if you need any logs etc will be happy to post. spritz shows python-2.5.4-r2 as being installed. thnx
Last edited by howiebinnz on Fri Apr 17, 2009 3:28, edited 2 times in total.
Baby Hen
Posts: 4
Joined: Mon Apr 06, 2009 11:18

Re: pysolfc

Postby colejv » Mon Apr 06, 2009 12:57

I don't know anything about the software you are trying to use so this may only get you further along the path to failure but

If you are in the directory the program is in, you need to start it like this ./ or use the full path /path/to/

Run ls -l and make sure the file is executable and you have permissions to execute it
Young Hen
Posts: 32
Joined: Sat Aug 04, 2007 19:30

Re: pysolfc

Postby DHalens » Mon Apr 06, 2009 13:03

Probably what you have to do is run the program with python (or what colejv told you).
If so, you can create a .desktop file for run the game without using console. Edit the following lines acording to what you have and save it as pysolfc.desktop in your desktop or anywhere you want.
Note i haven't tried this myself so it may not work...

Code: Select all
[Desktop Entry]
Exec=python /path/to/the/game/
Icon= /path/to/the/icon/you/want/icon.png
Former Sabayon staff (retired).
For any personal questions or whatever, contact me trough my G+ profile
Old Dear Hen
Posts: 933
Joined: Thu Apr 10, 2008 23:08
Location: Canary Islands, Spain

Re: pysolfc

Postby howiebinnz » Mon Apr 06, 2009 21:30

ok, thanks for those replies, gets me a little further along, but still no luck. i now get the following when i enter "python"
Code: Select all
Traceback (most recent call last):
  File "", line 29, in <module>
    from pysollib.main import main
  File "/home/howard/downloads/PySolFC-1.1/pysollib/", line 46, in <module>
    from app import Application
  File "/home/howard/downloads/PySolFC-1.1/pysollib/", line 52, in <module>
    from images import Images, SubsampledImages
  File "/home/howard/downloads/PySolFC-1.1/pysollib/", line 45, in <module>
    from pysoltk import loadImage, copyImage, createImage, shadowImage
  File "/home/howard/downloads/PySolFC-1.1/pysollib/", line 66, in <module>
    from tk.toolbar import *
  File "/home/howard/downloads/PySolFC-1.1/pysollib/tk/", line 48, in <module>
    from pysollib.winsystems import TkSettings
  File "/home/howard/downloads/PySolFC-1.1/pysollib/winsystems/", line 29, in <module>
    import x11 as gui
  File "/home/howard/downloads/PySolFC-1.1/pysollib/winsystems/", line 29, in <module>
    from pysollib.tile import Tile
ImportError: No module named tile

am i right in that it can't find a module called "tile" (in folder pysollib there is a folder called "Tile" but it is empty, and where should it be? should i try a new d/l of pysolfc?
Baby Hen
Posts: 4
Joined: Mon Apr 06, 2009 11:18

Re: pysolfc

Postby howiebinnz » Mon Apr 06, 2009 22:23

yes, well that seemed to do it (new d/l), must have been corrupted somewhere along the way. all working now with the help of the above comments, thankyou for your quick responses.
Baby Hen
Posts: 4
Joined: Mon Apr 06, 2009 11:18

Re: pysolfc [UnSolved]

Postby howiebinnz » Fri Apr 17, 2009 3:26

well, pysolfc was working for about 10 days, i decided to do an update yesterday which included kernel 2.6.29 plus i managed to update the nvidia drivers (have an older agp video card). this all eventually went well but went to start pysol and came up with the following error.
Code: Select all
Traceback (most recent call last):
  File "", line 26, in <module>
  File "/home/howard/pysol/PySolFC-1.1/pysollib/", line 117, in init
    import Tkinter
ImportError: No module named Tkinter

it seems something has been changed somewhere (a quick google tells me i need development libraries maybe and there seems to be plenty of hits on the topic ?) but am a bit of a loss as to exactly what i need. hope you can help again please.
Baby Hen
Posts: 4
Joined: Mon Apr 06, 2009 11:18

Re: pysolfc

Postby christo4 » Fri Jun 05, 2009 1:02

I also would like very much to run pysol. However, I get the same message as howiebinzz. I have a fully updated 4.1 system. It appears we're missing "Tkinter." Is there a way to install this from binary--I don't see it in Sulfur?
Baby Hen
Posts: 12
Joined: Sat Mar 07, 2009 20:52

Re: pysolfc

Postby Thev00d00 » Fri Jun 05, 2009 12:29

You need to build python with the "tk" use flag, the entropy version does not include it, maybe file a bug?
Please report Bugs on the Bugzilla, not forum
Please Adopt an Unanswered thread
Website / Blog :
twitter: Follow Me
G+: Circle Me
Generally Awesome (tm)
Posts: 1472
Joined: Wed Feb 21, 2007 15:52
Location: United Kingdom

Return to Software in General

Who is online

Users browsing this forum: No registered users and 1 guest