yakuake shortcut conflicts [Solved]

Discussions Regarding Software

Moderator: Moderators

yakuake shortcut conflicts [Solved]

Postby kodiakmax » Sun Feb 22, 2009 21:16

KDE 3.5.10
Linux 2.6.28-sabayon #1 SMP Sun Feb 15 13:17:30 CST 2009 x86_64 Intel(R) Core(TM)2 Duo CPU T7500 @ 2.20GHz GenuineIntel GNU/Linux

I just upgraded to yakuake-2.9.4-r2.
My problem is I can't assign any shortcuts to yakuake. I get the following error:
Code: Select all
Conflict with Registerd Global Shortcut(s) - Yakuake
The shortcut 'Alt+`' conflicts with the following key combinations:



It does not matter which key combo I try. It does not tell me what key it is in conflict with. I can't even get the default F12 to extend and retract the window. I was going to just downgrade yakuake but I don't see an earlier version when I do an "equo search yakuake" or "emerge --search yakuake".
Last edited by kodiakmax on Mon Feb 23, 2009 20:08, edited 1 time in total.
If you check the wiki, use the search function and google you can find the answer to most of your questions.

Remember to mark your thread [Solved] if your issue is fixed.
kodiakmax
Advanced Hen
 
Posts: 278
Joined: Thu Oct 16, 2008 23:46

Re: yakuake shortcut conflicts

Postby Fitzcarraldo » Mon Feb 23, 2009 9:27

Code: Select all
$ eix yakuake
[U] kde-misc/yakuake
     Available versions:
        (0)     2.8 (~)2.8.1
        (4.1)   (~)2.9.4-r2
        {arts debug elibc_FreeBSD kdeprefix linguas_ca linguas_cs linguas_da linguas_de linguas_el linguas_en_GB linguas_es linguas_et linguas_fr linguas_ga linguas_gl linguas_hu linguas_it linguas_ja linguas_ko linguas_nds linguas_nl linguas_pa linguas_pl linguas_pt linguas_pt_BR linguas_ro linguas_ru linguas_sv linguas_tr linguas_uk xinerama}
     Installed versions:  2.8.1(16:41:00 02/02/09)(xinerama -arts -debug -elibc_FreeBSD -linguas_de -linguas_el -linguas_es -linguas_et -linguas_fr -linguas_hu -linguas_it -linguas_ja -linguas_nl -linguas_pl -linguas_pt -linguas_pt_BR -linguas_sv -linguas_tr)
     Homepage:            http://yakuake.kde.org/
     Description:         A quake-style terminal emulator based on KDE konsole technology


^Version 2.9.4-r2 is for KDE 4.x by the look of it. Version 2.8 and 2.8.1 are in Portage, though. You probably can't see them because either you haven't synced your Portage tree or you haven't updated eix (if you're using the latter). Do the following as root in a Terminal window to see if you can see it:

Code: Select all
emerge --sync
layman -S

If you have eix installed then also do:
Code: Select all
update-eix


Version 2.8.1 works well under KDE 3.5.10.
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7978
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: yakuake shortcut conflicts

Postby kodiakmax » Mon Feb 23, 2009 20:08

ok that worked. eix did find the older version.
so I had to:
emerge =kde-misc/yakuake-2.8.1
Why doesn't emerge find the older version with "emerge --search yakuake"?

thanks
If you check the wiki, use the search function and google you can find the answer to most of your questions.

Remember to mark your thread [Solved] if your issue is fixed.
kodiakmax
Advanced Hen
 
Posts: 278
Joined: Thu Oct 16, 2008 23:46

Re: yakuake shortcut conflicts [Solved]

Postby Fitzcarraldo » Tue Feb 24, 2009 8:33

Because emerge --search only shows the latest version:

Code: Select all
fitzcarraldo@acertm8215 ~ $ emerge --search yakuake
Searching...
[ Results for search key : yakuake ]
[ Applications found : 1 ]

*  kde-misc/yakuake
      Latest version available: 2.9.4-r2
      Latest version installed: 2.8.1
      Size of files: 211 kB
      Homepage:      http://yakuake.kde.org/
      Description:   A quake-style terminal emulator based on KDE konsole technology
      License:       GPL-2 LGPL-2

fitzcarraldo@acertm8215 ~ $


eix is essential, really.
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7978
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom


Return to Software in General

Who is online

Users browsing this forum: No registered users and 4 guests